include/download.mk: Allow specify DownloadMethod specific options
authorFlorian Fainelli <f.fainelli@gmail.com>
Wed, 9 Nov 2016 17:34:17 +0000 (09:34 -0800)
committerFelix Fietkau <nbd@nbd.name>
Sun, 4 Dec 2016 10:41:51 +0000 (11:41 +0100)
This is going to be used to migrate the hand rolled git clone for the kernel
into using the git download method. The kernel uses custom options that we may
have to pass down.

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
include/download.mk

index 2797e90364b1742e79a1d74ed37bb0814eab9f6a..9fbc3fb656f724be2f8b1c96fe7800f8af819e64 100644 (file)
@@ -93,7 +93,7 @@ define DownloadMethod/git
                cd $(TMP_DIR)/dl && \
                rm -rf $(SUBDIR) && \
                [ \! -d $(SUBDIR) ] && \
-               git clone $(URL) $(SUBDIR) && \
+               git clone $(OPTS) $(URL) $(SUBDIR) && \
                (cd $(SUBDIR) && git checkout $(VERSION) && \
                git submodule update --init --recursive) && \
                echo "Packing checkout..." && \
@@ -172,6 +172,7 @@ define Download/Defaults
   MIRROR:=1
   MIRROR_MD5SUM:=x
   VERSION:=
+  OPTS:=
 endef
 
 define Download