libubox: update to version 2019-12-26
authorPetr Štetiar <ynezz@true.cz>
Wed, 11 Dec 2019 20:08:15 +0000 (21:08 +0100)
committerPetr Štetiar <ynezz@true.cz>
Thu, 26 Dec 2019 07:41:37 +0000 (08:41 +0100)
Contains following changes:

 eb7eb6393d47 blobmsg: fix array out of bounds GCC 10 warning
 86f6a5b8d1f1 blobmsg: reuse blobmsg_namelen in blobmsg_data
 586ce031eaa0 tests: fuzz: fuzz _len variants of checking methods
 b0e21553ae8c blobmsg: add _len variants for all attribute checking methods
 cd3059796a57 Replace use of blobmsg_check_attr by blobmsg_check_attr_len
 143303149c8b Ensure blob_attr length check does not perform out of bounds reads
 f2b2ee441adb blobmsg: fix heap buffer overflow in blobmsg_parse
 4dfd24ed88c4 blobmsg: make blobmsg_len and blobmsg_data_len return unsigned value
 2df6d35e3299 tests: add test cases for blobmsg parsing
 8a34788b46c4 test: fuzz: add blobmsg_check_attr crashes
 478597b9f9ae blob: fix OOB access in blob_check_type
 325418a7a3c0 tests: use blob_parse_untrusted variant
 0b24e24b93e1 blob: introduce blob_parse_untrusted
 6d27336e4a8b blob: refactor attr parsing into separate function
 833d25797b16 test: fuzz: add blob_parse crashes
 09ee90f8d6ed tests: add test cases for blob parsing
 436d6363a10b tests: add libFuzzer based tests
 bf680707acfd tests: add unit tests covered with Clang sanitizers
 f804578847de cmake: add more hardening compiler flags
 46f8268b4b5b blobmsg/ulog: fix format string compiler warnings
 eb216a952407 cmake: use extra compiler warnings only on gcc6+

and bumps ABI_VERSION to 20191226.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/libs/libubox/Makefile

index d0009ab3de611d35c785eefceeaa6a80b741effc..0e3a433806836766a8ce8594340fbfec7a32df6e 100644 (file)
@@ -5,9 +5,9 @@ PKG_RELEASE=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/libubox.git
-PKG_MIRROR_HASH:=e7ef39ffe693d6f106aa320268d90a68aebd0a0aa1baa0051d70b3bb1f8a64fc
-PKG_SOURCE_DATE:=2019-11-24
-PKG_SOURCE_VERSION:=07413cce72e19520af55dfcbc765484f5ab41dd9
+PKG_MIRROR_HASH:=8072cf0ca0b4de23ad91bffae95a1e3a243ca2e4736e114992d5a7ebc2185235
+PKG_SOURCE_DATE:=2019-12-26
+PKG_SOURCE_VERSION:=eb7eb6393d47a918c420f5b287946dbd6c0d5f57
 CMAKE_INSTALL:=1
 
 PKG_LICENSE:=ISC
@@ -27,7 +27,7 @@ define Package/libubox
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Basic utility library
-  ABI_VERSION:=20170601
+  ABI_VERSION:=20191226
   DEPENDS:=
 endef