Add checksum for 2.6.34, refresh 2.6.34 patches and update targets from 2.6.34-rcX...
authorLars-Peter Clausen <lars@metafoo.de>
Mon, 17 May 2010 22:05:07 +0000 (22:05 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Mon, 17 May 2010 22:05:07 +0000 (22:05 +0000)
SVN-Revision: 21498

12 files changed:
include/kernel-version.mk
target/linux/generic-2.6/patches-2.6.34/021-mips_image_cmdline_hack.patch
target/linux/generic-2.6/patches-2.6.34/025-mips_disable_fpu.patch
target/linux/generic-2.6/patches-2.6.34/150-netfilter_imq.patch
target/linux/generic-2.6/patches-2.6.34/620-phy_adm6996.patch
target/linux/generic-2.6/patches-2.6.34/660-phy_mvswitch.patch
target/linux/generic-2.6/patches-2.6.34/670-phy_ip175c.patch
target/linux/generic-2.6/patches-2.6.34/680-phy_ar8216.patch
target/linux/generic-2.6/patches-2.6.34/690-phy_rtl8306.patch
target/linux/generic-2.6/patches-2.6.34/691-phy_rtl8366.patch
target/linux/mx2/Makefile
target/linux/xburst/Makefile

index fbf934ae670e084c1ec145b53f1854b0e3039049..2e6d1411151d75097d071aad25df7f8548092ef3 100644 (file)
@@ -26,10 +26,11 @@ endif
 ifeq ($(LINUX_VERSION),2.6.33.3)
   LINUX_KERNEL_MD5SUM:=f651e9aafb2f910812257a63bcd639f2
 endif
-ifeq ($(LINUX_VERSION),2.6.34-rc5)
-  LINUX_KERNEL_MD5SUM:=c09ea93cd4e2684ebb506866c65a4c9f
+ifeq ($(LINUX_VERSION),2.6.34)
+  LINUX_KERNEL_MD5SUM:=10eebcb0178fb4540e2165bfd7efc7ad
 endif
 
+
 # disable the md5sum check for unknown kernel versions
 LINUX_KERNEL_MD5SUM?=x
 
index 00de8d545039a502c030e5a3e31b9b8a10261f8e..a304f0bcc71ab3a68527cac5f525ce1bc9b182c4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -854,6 +854,10 @@ config SYNC_R4K
+@@ -856,6 +856,10 @@ config SYNC_R4K
  config MIPS_MACHINE
        def_bool n
  
index e6b764e2df31c7042296996b0e7a67bd27fe5adf..a65be6f2cfe714b135ad7aa3c217ce4aea2d9ad9 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
 --
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -839,6 +839,17 @@ config I8259
+@@ -841,6 +841,17 @@ config I8259
  config MIPS_BONITO64
        bool
  
@@ -70,7 +70,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
  /* Control registers */
  
  #define FPCREG_RID    0       /* $0  = revision id */
-@@ -1277,7 +1277,6 @@ int fpu_emulator_cop1Handler(struct pt_r
+@@ -1284,7 +1284,6 @@ int fpu_emulator_cop1Handler(struct pt_r
  
        return sig;
  }
@@ -78,7 +78,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
  #ifdef CONFIG_DEBUG_FS
  
  static int fpuemu_stat_get(void *data, u64 *val)
-@@ -1326,4 +1325,11 @@ static int __init debugfs_fpuemu(void)
+@@ -1333,4 +1332,11 @@ static int __init debugfs_fpuemu(void)
        return 0;
  }
  __initcall(debugfs_fpuemu);
index 71554d1d3f7dcd3ad6e41443951b9596de66b5fe..8a0507fa013bf44ebabc168e5a1059208063750d 100644 (file)
  #include <linux/proc_fs.h>
  #include <linux/seq_file.h>
  #include <linux/stat.h>
-@@ -1860,7 +1863,11 @@ int dev_hard_start_xmit(struct sk_buff *
+@@ -1859,7 +1862,11 @@ int dev_hard_start_xmit(struct sk_buff *
        int rc = NETDEV_TX_OK;
  
        if (likely(!skb->next)) {
                        dev_queue_xmit_nit(skb, dev);
  
                if (netif_needs_gso(dev, skb)) {
-@@ -1970,8 +1977,7 @@ static inline u16 dev_cap_txqueue(struct
+@@ -1969,8 +1976,7 @@ static inline u16 dev_cap_txqueue(struct
        return queue_index;
  }
  
  {
        u16 queue_index;
        struct sock *sk = skb->sk;
-@@ -2001,6 +2007,7 @@ static struct netdev_queue *dev_pick_tx(
+@@ -2000,6 +2006,7 @@ static struct netdev_queue *dev_pick_tx(
        skb_set_queue_mapping(skb, queue_index);
        return netdev_get_tx_queue(dev, queue_index);
  }
  /* return EBUSY when somebody else is registered, return EEXIST if the
   * same handler is registered, return 0 in case of success. */
  int nf_register_queue_handler(u_int8_t pf, const struct nf_queue_handler *qh)
-@@ -81,7 +101,7 @@ void nf_unregister_queue_handlers(const
+@@ -81,7 +101,7 @@ void nf_unregister_queue_handlers(const 
  }
  EXPORT_SYMBOL_GPL(nf_unregister_queue_handlers);
  
index b3e469a8d655c6485b0e8800357811365f6d8c25..86bab7a1eb3d14115c16151a1d68f65ca3b7d8cd 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -88,6 +88,11 @@ config LSI_ET1011C_PHY
+@@ -93,6 +93,11 @@ config MICREL_PHY
        ---help---
-         Supports the LSI ET1011C PHY.
+         Supports the KSZ9021, VSC8201, KS8001 PHYs.
  
 +config ADM6996_PHY
 +      tristate "Driver for ADM6996 switches"
index 36551fd57018f225b5369acddd985e74df3ab5aa..f5ff558b0f07ebb44ee0bbecb7c9a71ea187e8ea 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -99,6 +99,9 @@ config ADM6996_PHY
+@@ -104,6 +104,9 @@ config ADM6996_PHY
        ---help---
          Currently supports the ADM6996F switch
  
index 862868c8d17a423d54c8fd513a907d1ca903445c..e8c57cada0232e8ece9c8e2b06b661bd24ce39e5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -102,6 +102,10 @@ config ADM6996_PHY
+@@ -107,6 +107,10 @@ config ADM6996_PHY
  config MVSWITCH_PHY
        tristate "Driver for Marvell 88E6060 switches"
  
index 00372aae0e11689eac851b7776ec055217450fba..2bc9d6754d57a2c89fdf64c3280658dc8df10c48 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -106,6 +106,10 @@ config IP175C_PHY
+@@ -111,6 +111,10 @@ config IP175C_PHY
        tristate "Driver for IC+ IP175C/IP178C switches"
        select SWCONFIG
  
index a4793cb63b6fceea853cc7835eb75d4fccd83bdb..9e86748a86e973bbf8026d06f795056498196c35 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -110,6 +110,10 @@ config AR8216_PHY
+@@ -115,6 +115,10 @@ config AR8216_PHY
        tristate "Driver for Atheros AR8216 switches"
        select SWCONFIG
  
index 0963bd81beab7a72936780c4e7505b8de74a872b..ec07636308b73353ebc3e1d93d562a1a59e778c1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -152,4 +152,29 @@ config MDIO_OCTEON
+@@ -157,4 +157,29 @@ config MDIO_OCTEON
  
          If in doubt, say Y.
  
index 9ccf2cbed6813d9b7b1ed971d4cb62046b249d0c..7690e4e5042d4d9007b51a80893fe284b99e9043 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MX2
 FEATURES:=jffs2
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
 
-LINUX_VERSION:=2.6.34-rc5
+LINUX_VERSION:=2.6.34
 
 DEVICE_TYPE=phone
 
index 3a68cabe95206083b1591660822f9dd71b0a1a9f..05b41da62d53358df1afb4d9fe200c5917ffdd24 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526
 
-LINUX_VERSION:=2.6.34-rc7
+LINUX_VERSION:=2.6.34
 
 DEVICE_TYPE=other