buildroot: filter out dtbs KERNELNAME target (#13785)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 30 Jun 2013 17:09:21 +0000 (17:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 30 Jun 2013 17:09:21 +0000 (17:09 +0000)
Do not attempt to copy arch/$(LINUX_KARCH)/boot/dtbs because these are
not real files, fixes #13785.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 37107

include/kernel-defaults.mk

index 7e807bfaff8f83ab10f3175f8bb691275703623d..ca520f55c95a6a86c620d02ccfc433c062642a48 100644 (file)
@@ -128,7 +128,7 @@ define Kernel/CopyImage
        $(KERNEL_CROSS)objcopy $(OBJCOPY_STRIP) -S $(LINUX_DIR)/vmlinux $(KERNEL_BUILD_DIR)/vmlinux$(1).elf
 ifneq ($(subst ",,$(KERNELNAME)),)
        #")
-       $(foreach k,$(subst ",,$(KERNELNAME)),$(CP) $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/$(IMAGES_DIR)/$(k) $(KERNEL_BUILD_DIR)/$(k)$(1);)
+       $(foreach k,$(filter-out dtbs,$(subst ",,$(KERNELNAME))),$(CP) $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/$(IMAGES_DIR)/$(k) $(KERNEL_BUILD_DIR)/$(k)$(1);)
        #")
 endif
 endef