uboot-envtools: fix configuration for I2SE Duckbills
authorMichael Heimpold <mhei@heimpold.de>
Mon, 17 Dec 2018 22:59:31 +0000 (23:59 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 18 Dec 2018 19:17:22 +0000 (20:17 +0100)
After changing board names to DT compat string, we also need to
adjust the script which generates uboot-env configuration files.

Fixes: e880a30549b ("mxs: use generic sysinfo board detection")
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/mxs

index 7cd9e9fb631a7808d69d8267cabc9578d45ed26c..71b842b96eb3df8c1e4e978f7b192186e37e3879 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2018.03
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.xz
index 37d3c96ed47dd09d58897b3b4aab21db4c1beba8..ecfb5de1621ff70ba3ba3afe74167b3ff02ba40c 100644 (file)
@@ -13,7 +13,7 @@ touch /etc/config/ubootenv
 board=$(board_name)
 
 case "$board" in
-duckbill)
+i2se,duckbill)
        ubootenv_add_uci_config "/dev/mmcblk0" "0x20000" "0x20000"
        ubootenv_add_uci_config "/dev/mmcblk0" "0x40000" "0x20000"
        ;;