Revert "version.mk: add "%s" placeholder for dotted target.subtarget notation"
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 23 Jan 2015 13:09:50 +0000 (13:09 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 23 Jan 2015 13:09:50 +0000 (13:09 +0000)
This reverts commit d388882dccc1b25575939c3713b3ab394c371fd0.

SVN-Revision: 44090

include/version.mk

index d4addd608f830503b5b3ac61205ba957d6c3fc7c..c4747f236f9b2a04f0ef825a135cb805271b78c6 100644 (file)
@@ -30,7 +30,7 @@ VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
 VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
 
 VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%s/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%T/packages)
 
 VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
@@ -79,7 +79,6 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
        -e 's,%R,$(REVISION),g' \
        -e 's,%T,$(BOARD),g' \
        -e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \
-       -e 's,%s,$(BOARD)$(if $(SUBTARGET),.$(SUBTARGET)),g' \
        -e 's,%t,$(VERSION_TAINTS),g' \
        -e 's,%M,$(VERSION_MANUFACTURER),g' \
        -e 's,%P,$(VERSION_PRODUCT),g' \