fix shell return status of the find symlink command
authorFelix Fietkau <nbd@openwrt.org>
Wed, 3 Sep 2008 13:25:26 +0000 (13:25 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 3 Sep 2008 13:25:26 +0000 (13:25 +0000)
SVN-Revision: 12514

tools/Makefile

index e15f061a4d35d2f8590e89b9100caf9828dceac6..ecde1191baffdede062bdd1f6658c10468681d9b 100644 (file)
@@ -38,7 +38,9 @@ $(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
        fi
 
 $(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
-       [ -x "$(FIND)" -a "$(FIND)" != "$@" ] && ln -sf "$(FIND)" $@
+       if [ -x "$(FIND)" -a "$(FIND)" != "$@" ]; then \
+               ln -sf "$(FIND)" $@; \
+       fi
 
 
 $(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)