strace: Only allow libdw or libunwind
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 16 Feb 2019 22:43:50 +0000 (23:43 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Feb 2019 18:22:39 +0000 (19:22 +0100)
These two dependencies are mutual exclusive and it is only possible to
select one of them, change the select to a chose so it is only possible
to select one of them in OpenWrt menu config.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/devel/strace/Makefile

index 55fdc80c1ba35626fb8d7272a92139a7791a6ba8..dd7f31eeebedcfe874bf1f10d847392932b7fb9e 100644 (file)
@@ -57,17 +57,19 @@ system calls a program makes while it is running.
 endef
 
 define Package/strace/config
-menu "Select strace configuration options"
-       depends on PACKAGE_strace
+choice
+       prompt "stack tracing support"
+       default STRACE_NONE
 
-config STRACE_LIBDW
-       bool "Enable stack tracing support using libdw"
-       default n
-config STRACE_LIBUNWIND
-       bool "Enable stack tracing support using libunwind (experimental)"
-       default n
+       config STRACE_NONE
+               bool "None"
 
-endmenu
+       config STRACE_LIBDW
+               bool "libdw"
+
+       config STRACE_LIBUNWIND
+               bool "libunwind (experimental)"
+endchoice
 endef
 
 CONFIGURE_ARGS += \