make base-files dependent on opkg host compile, fixes install errors when package...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 27 Jul 2010 22:26:13 +0000 (22:26 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 27 Jul 2010 22:26:13 +0000 (22:26 +0000)
SVN-Revision: 22405

package/Makefile

index 530405cd06bd9102b0e8f4f74377ae6c44f80563..3c7b0b49bc477b02a45d3aae27fd3201224596e0 100644 (file)
@@ -12,6 +12,7 @@ $(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
 ifeq ($(SDK),1)
   $(curdir)/builddirs-install:=.
 else
+  $(curdir)/base-files/compile += $(curdir)/opkg/host/compile
   $(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
   $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
   $(curdir)/builddirs-install:=. $(sort $(package-y))
@@ -20,9 +21,6 @@ ifneq ($(IGNORE_ERRORS),)
   $(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
 endif
 
-$(curdir)/opkghost: $(TMP_DIR)/.build
-       @-$(MAKE) package/opkg/host/install
-
 $(curdir)/install:=$(curdir)/install-cleanup
 
 $(curdir)/cleanup: $(TMP_DIR)/.build
@@ -93,8 +91,7 @@ $(curdir)/flags-install:= -j1
 $(eval $(call stampfile,$(curdir),package,prereq,.config))
 $(eval $(call stampfile,$(curdir),package,cleanup))
 $(eval $(call stampfile,$(curdir),package,compile))
-$(eval $(call stampfile,$(curdir),package,opkghost))
-$(eval $(call stampfile,$(curdir),package,install,$(STAGING_DIR)/stamp/.package_opkghost))
+$(eval $(call stampfile,$(curdir),package,install))
 $(eval $(call stampfile,$(curdir),package,rootfs-prepare))
 
 $(eval $(call subdir,$(curdir)))