bpftools: fix feature override for masking clang
authorTony Ambardar <itugrok@yahoo.com>
Mon, 12 Apr 2021 23:46:22 +0000 (16:46 -0700)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sat, 24 Apr 2021 11:21:40 +0000 (12:21 +0100)
Rename feature variable clang-bpf-global-var following upstream changes.
This restores the HAVE_CLANG feature override and should avoid rare build
errors where a recent host clang and BTF-enabled host kernel are present.

Fixes: 23be333401f0 ("bpftools: update to 5.10.10")
Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
package/network/utils/bpftools/Makefile

index 9955d361f4882512ab085c54f5c3b92153536d81..52963e41484f27c682968c80678ba025ee22b534 100644 (file)
@@ -128,7 +128,7 @@ define Build/Configure
                | sort | uniq > FEATURE-DUMP.openwrt)
        $(SED) 's/feature-libbfd=1/feature-libbfd=$(HAVE_LIBBFD)/' \
                -e 's/feature-libcap=1/feature-libcap=$(HAVE_LIBCAP)/' \
-               -e 's/feature-clang-bpf-global-var=1/feature-clang-bpf-global-var=$(HAVE_CLANG)/' \
+               -e 's/feature-clang-bpf-co-re=1/feature-clang-bpf-co-re=$(HAVE_CLANG)/' \
                $(PKG_BUILD_DIR)/FEATURE-DUMP.openwrt
 endef