update avahi to new upstream release (v0.6.1)
authorNicolas Thill <nico@openwrt.org>
Wed, 7 Dec 2005 05:16:50 +0000 (05:16 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 7 Dec 2005 05:16:50 +0000 (05:16 +0000)
SVN-Revision: 2588

openwrt/package/Makefile
openwrt/package/avahi/Makefile

index 51cfc737f30a20f9cd2283f5e17258cbfb5eceeb..4bfd47861811bfa38ca2ab925205d524b65ae96a 100644 (file)
@@ -234,7 +234,7 @@ $(INSTALL_PACKAGES): base-files-install
 amwall-compile: libamsel-compile
 arpd-compile: libpcap-compile libdnet-compile libevent-compile
 arpwatch-compile: libpcap-compile
-avahi-compile: libdaemon-compile expat-compile
+avahi-compile: libdaemon-compile expat-compile libgdbm-compile
 bind-compile: openssl-compile
 curl-compile: openssl-compile zlib-compile
 cyrus-sasl-compile: openssl-compile
index 43577f89e9b81953d0f59b20b6c03063d93f3e32..a082d54699ab32a4cc426f245cd4b5fa2c9f14a9 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avahi
-PKG_VERSION:=0.5.2
+PKG_VERSION:=0.6.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=dc7ce24ffaab251a2002bf1dfdbe256d
+PKG_MD5SUM:=330613902c59bd597f140a8254e9f4ec
 
 PKG_SOURCE_URL:=http://www.freedesktop.org/~lennart/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -24,8 +24,8 @@ $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -DNDEBUG" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
                ac_cv_func_malloc_0_nonnull=yes \
                ac_cv_func_realloc_0_nonnull=yes \
@@ -64,7 +64,7 @@ $(PKG_BUILD_DIR)/.configured:
                        --disable-pygtk \
                        --disable-python-dbus \
                        --disable-mono \
-                       --disable-mono-docs \
+                       --disable-monodoc \
                        --disable-doxygen-doc \
                        --disable-doxygen-dot \
                        --disable-doxygen-man \