kernel: modules: fix kmod-regmap
authorChristian Lamparter <chunkeey@gmail.com>
Mon, 30 Jul 2018 20:33:51 +0000 (22:33 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Jul 2018 20:37:22 +0000 (22:37 +0200)
This patch fixes the a compile issue that was triggered by
apm821xx/sata when kmod-regmap was selected.

The CONFIG_REGMAP is declared in drivers/base/regmap/Kconfig
as type "bool" and not "tristate". Hence the symbol should
never be set to module, as this confuses the #if CONFIG_REGMAP
guards in include/linux/regmap.h:

|.../drivers/regulator/core.c:4041: undefined reference to `dev_get_regmap'
|.../drivers/regulator/core.c:4042: undefined reference to `dev_get_regmap'
|.../drivers/regulator/core.c:4044: undefined reference to `dev_get_regmap'
|.../drivers/regulator/helpers.o: In function `regulator_is_enabled_regmap':
|.../drivers/regulator/helpers.c:36: undefined reference to `regmap_read'
|...

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/kernel/linux/modules/other.mk

index 7e18a21db3df45fe6fd00b53b66af1c975799ec5..dd037cf86c0f44f3a21acfb06d920bf5e11bbc75 100644 (file)
@@ -718,7 +718,7 @@ define KernelPackage/regmap
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Generic register map support
   DEPENDS:=+kmod-lib-lzo +kmod-i2c-core
-  KCONFIG:=CONFIG_REGMAP \
+  KCONFIG:=CONFIG_REGMAP=y \
           CONFIG_REGMAP_MMIO \
           CONFIG_REGMAP_SPI \
           CONFIG_REGMAP_I2C \