brcm63xx: align DTS model with Makefile and compatible
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 30 Dec 2019 22:12:53 +0000 (23:12 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 8 Feb 2020 17:48:06 +0000 (18:48 +0100)
Since the model string in DTS is not required to derive board name
anymore, we can now align it with the model name in Makefile and
the compatible.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
15 files changed:
target/linux/brcm63xx/dts/bcm6318-sagem-fast-2704n.dts
target/linux/brcm63xx/dts/bcm6328-sagem-fast-2704-v2.dts
target/linux/brcm63xx/dts/bcm6348-bt-voyager-2500v-bb.dts
target/linux/brcm63xx/dts/bcm6348-sagem-fast-2404.dts
target/linux/brcm63xx/dts/bcm6348-sagem-fast-2604.dts
target/linux/brcm63xx/dts/bcm6348-t-com-speedport-w-500v.dts
target/linux/brcm63xx/dts/bcm6348-usrobotics-usr9108.dts
target/linux/brcm63xx/dts/bcm6358-sfr-neufbox-4-foxconn-r1.dts
target/linux/brcm63xx/dts/bcm6358-sfr-neufbox-4-sercomm-r0.dts
target/linux/brcm63xx/dts/bcm6358-t-com-speedport-w-303v.dts
target/linux/brcm63xx/dts/bcm6362-sagem-fast-2504n.dts
target/linux/brcm63xx/dts/bcm6362-sfr-neufbox-6-sercomm-r0.dts
target/linux/brcm63xx/dts/bcm6368-huawei-echolife-hg622.dts
target/linux/brcm63xx/dts/bcm6368-huawei-echolife-hg655b.dts
target/linux/brcm63xx/image/bcm63xx.mk

index 3ceddd09a2aa9c9400e36145900ac1b4072c0e6c..f09310e2bb0bc8dd6c7f506ce5afbde86130700b 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "Sagem F@ST2704N";
+       model = "Sagem F@st 2704N";
        compatible = "sagem,fast-2704n", "brcm,bcm6318";
 
        chosen {
index 1fe0d44810b0829958352e9aa29fe77f0073d392..d00d8fb4e56151d93ef6890063df651c70ca22d9 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "Sagem F@ST2704V2";
+       model = "Sagem F@st 2704 V2";
        compatible = "sagem,fast-2704-v2", "brcm,bcm6328";
 
        chosen {
index a77362f2f6d434157e34926e160383c58045f251..0975cffd65ef989f386db3686146af2283313741 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "BT Voyager V2500V";
+       model = "BT Voyager 2500V";
        compatible = "bt,voyager-2500v-bb", "brcm,bcm6348";
 
        chosen {
index 60b945555b345c267c4422da628714e664b4cb40..945fcc1f1891f6b51fd32e05f405cb6eae8e4937 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "Sagem F@ST2404";
+       model = "Sagem F@st 2404";
        compatible = "sagem,fast-2404", "brcm,bcm6348";
 
        chosen {
index a3394dd70d96b752788f21915a930061f7dec18a..a2d271757584bbedb2fba321f637885ab91f8d77 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "Sagem F@ST2604";
+       model = "Sagem F@st 2604";
        compatible = "sagem,fast-2604", "brcm,bcm6348";
 
        chosen {
index aa2f337253160bad83ea33378609c1c9f7ec88dc..8b0d1cacfd600d740c0a557d0a86ea0fe0240ff4 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "T-Com Speedport W500 V";
+       model = "T-Com Speedport W 500V";
        compatible = "t-com,speedport-w-500v", "brcm,bcm6348";
 
        chosen {
index 35ce1b010d19bfade7c4a2a0cacfb1cd8c045821..366eaf3bcd1758d93d25a06ecf1a1601572847b2 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "USRobotics 9108";
+       model = "USRobotics USR9108";
        compatible = "usrobotics,usr9108", "brcm,bcm6348";
 
        chosen {
index e1a3046c7fb23a47b28cb36949390ea8efa0e2ba..de22658843f35401c539aee793638de97476c601 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "SFR Neuf Box 4 (Foxconn)";
+       model = "SFR Neufbox 4 (Foxconn)";
        compatible = "sfr,neufbox-4-foxconn-r1", "brcm,bcm6358";
 
        chosen {
index b28aaa3fe73bed6afed8a9c01ad75766f8e67732..db6c5f330695032b11470a0fb5be6861b08c4ec2 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "SFR Neuf Box 4 (Sercomm)";
+       model = "SFR Neufbox 4 (Sercomm)";
        compatible = "sfr,neufbox-4-sercomm-r0", "brcm,bcm6358";
 
        chosen {
index 68f8588f55b3efd172614e7d11c7338d4f27d4bd..4aed5f0eb621b2b8527323d0571366407a5ff21e 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "T-Com Speedport W303 V";
+       model = "T-Com Speedport W 303V";
        compatible = "t-com,speedport-w-303v", "brcm,bcm6358";
 
        chosen {
index d1bf98a2b13ac4a1a31e65355792dea611f179f5..db8ce7318f1af78c15ef356b8274d3721b58640d 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "Sagem F@ST2504n";
+       model = "Sagem F@st 2504N";
        compatible = "sagem,fast-2504n", "brcm,bcm6362";
 
        chosen {
index a5184ff5552945912fed2c4b7ad7e7f9467c0892..031aff0748a2df1fc7bed2002a6081ab58b2156e 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "SFR neufbox 6 (Sercomm)";
+       model = "SFR Neufbox 6 (Sercomm)";
        compatible = "sfr,neufbox-6-sercomm-r0", "brcm,bcm6362";
 
        chosen {
index 36598645a3a76c2fc89df217b033f6e14d02243d..77ecc62abd1555d4500e807fe99dca9744db8edd 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "Huawei HG622";
+       model = "Huawei EchoLife HG622";
        compatible = "huawei,echolife-hg622", "brcm,bcm6368";
 
        chosen {
index 10fdcc6fd145bb77c7090bf9fb49cd7339380c47..3f855bf0c9a159c5a83c71596a43b8b3507739c7 100644 (file)
@@ -5,7 +5,7 @@
 #include <dt-bindings/input/input.h>
 
 / {
-       model = "Huawei HG655b";
+       model = "Huawei EchoLife HG655b";
        compatible = "huawei,echolife-hg655b", "brcm,bcm6368";
 
        chosen {
index 433e5859b65c5aea7e4459f3cd8383563c2a169d..bc96b2a24e6365967a251b848913c3eab1ca0e91 100644 (file)
@@ -974,7 +974,7 @@ TARGET_DEVICES += sercomm_ad1018-nor
 define Device/sfr_neufbox-4-sercomm-r0
   $(Device/bcm63xx)
   DEVICE_VENDOR := SFR
-  DEVICE_MODEL := Neufbox4
+  DEVICE_MODEL := Neufbox 4
   DEVICE_VARIANT := Sercomm
   CFE_BOARD_ID := 96358VW
   CFE_CHIP_ID := 6358
@@ -986,7 +986,7 @@ TARGET_DEVICES += sfr_neufbox-4-sercomm-r0
 define Device/sfr_neufbox-4-foxconn-r1
   $(Device/bcm63xx)
   DEVICE_VENDOR := SFR
-  DEVICE_MODEL := Neufbox4
+  DEVICE_MODEL := Neufbox 4
   DEVICE_VARIANT := Foxconn
   CFE_BOARD_ID := 96358VW
   CFE_CHIP_ID := 6358
@@ -998,7 +998,7 @@ TARGET_DEVICES += sfr_neufbox-4-foxconn-r1
 define Device/sfr_neufbox-6-sercomm-r0
   $(Device/bcm63xx)
   DEVICE_VENDOR := SFR
-  DEVICE_MODEL := Neufbox6
+  DEVICE_MODEL := Neufbox 6
   CFE_BOARD_ID := NB6-SER-r0
   CFE_CHIP_ID := 6362
   CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
@@ -1121,7 +1121,7 @@ TARGET_DEVICES += tp-link_td-w8900gb
 define Device/usrobotics_usr9108
   $(Device/bcm63xx)
   DEVICE_VENDOR := USRobotics
-  DEVICE_MODEL := 9108
+  DEVICE_MODEL := USR9108
   CFE_BOARD_ID := 96348GW-A
   CFE_CHIP_ID := 6348
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB1_PACKAGES)