ca-certificates: create symbolic link for certificate hashes
authorFelix Fietkau <nbd@openwrt.org>
Thu, 25 Sep 2014 07:38:02 +0000 (07:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 25 Sep 2014 07:38:02 +0000 (07:38 +0000)
Implementing "add-cert.sh" functionality described at
http://wiki.openwrt.org/doc/howto/wget-ssl-certs into Makefile
otherwise you need to create symbolic links for certificate hashes
yourself.

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
SVN-Revision: 42660

package/system/ca-certificates/Makefile

index 7f38c866534a5be266d07d6a8a725ebdb22f9dcc..08a853fd44f7036becb5df80cf79cd1df2314932 100644 (file)
@@ -34,6 +34,15 @@ endef
 define Package/ca-certificates/install
        $(INSTALL_DIR) $(1)/etc/ssl/certs
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/ca-certificates/*/*.crt $(1)/etc/ssl/certs/
+
+       for CERTFILE in `ls -1 $(1)/etc/ssl/certs`; do \
+               HASH=`openssl x509 -hash -noout -in $(1)/etc/ssl/certs/$$$$CERTFILE` ; \
+               SUFFIX=0 ; \
+               while [ -h "$(1)/etc/ssl/certs/$$$$HASH.$$$$SUFFIX" ]; do \
+                       let "SUFFIX += 1" ; \
+               done ; \
+               ln -s "$$$$CERTFILE" "$(1)/etc/ssl/certs/$$$$HASH.$$$$SUFFIX" ; \
+       done
 endef
 
 $(eval $(call BuildPackage,ca-certificates))