Added package vgp, vgp is a daemon working like Cisco(c) HSRP
authorFlorian Fainelli <florian@openwrt.org>
Mon, 12 Dec 2005 21:04:11 +0000 (21:04 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 12 Dec 2005 21:04:11 +0000 (21:04 +0000)
SVN-Revision: 2643

openwrt/package/vgp/Config.in [new file with mode: 0755]
openwrt/package/vgp/Makefile [new file with mode: 0755]
openwrt/package/vgp/ipkg/vgp.control [new file with mode: 0755]

diff --git a/openwrt/package/vgp/Config.in b/openwrt/package/vgp/Config.in
new file mode 100755 (executable)
index 0000000..ace8446
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_VGP
+       tristate "vgp - a daemon working like Cisco(c) HSRP"
+       default m if CONFIG_DEVEL
+       help
+               VGP (Virtual Gateway Protocol)is a very simple protocol able to work in 
+  a way similar to Cisco(c) HSRP. It implements the idea of Virtual Gateway
+  to provide fault tollerance (and load balancing) on your net. 
+  Each client on your net has as its default gateway the virtual gateway 
+  and not the real router. 
+               
+               http://vgpd.freaknet.org/
\ No newline at end of file
diff --git a/openwrt/package/vgp/Makefile b/openwrt/package/vgp/Makefile
new file mode 100755 (executable)
index 0000000..e2a4277
--- /dev/null
@@ -0,0 +1,48 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vgp
+PKG_VERSION:=0.2.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=b8c25b5dfcb944f78bbc584be9c230c7
+PKG_SOURCE_URL:=http://vgpd.freaknet.org/files/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,VGP,vgp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+               (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+                       $(TARGET_CONFIGURE_OPTS) \
+                       CFLAGS="$(TARGET_CFLAGS)" \
+                       ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --sbindir=/usr/sbin \
+                       --libexecdir=/usr/lib \
+                       --sysconfdir=/etc \
+                       --datadir=/usr/share \
+                       --localstatedir=/var \
+                       --mandir=/usr/man \
+                       --infodir=/usr/info \
+                       --program-prefix="" \
+               );
+               touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
+       touch $@
+
+$(IPKG_VGP):
+       mkdir -p $(IDIR_VGP)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VGP)/
+       $(RSTRIP) $(IDIR_VGP)
+       $(IPKG_BUILD) $(IDIR_VGP) $(PACKAGE_DIR)
diff --git a/openwrt/package/vgp/ipkg/vgp.control b/openwrt/package/vgp/ipkg/vgp.control
new file mode 100755 (executable)
index 0000000..18fdc91
--- /dev/null
@@ -0,0 +1,5 @@
+Package: vgp
+Section: net
+Architecture: mipsel
+Priority: optional
+Description: vgp is a daemon working like Cisco(c) HSRP