bcm53xx: use upstream queued patches for R8500 and AC9
authorRafał Miłecki <rafal@milecki.pl>
Thu, 8 Sep 2016 20:53:00 +0000 (22:53 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Thu, 8 Sep 2016 20:53:37 +0000 (22:53 +0200)
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/bcm53xx/patches-4.4/044-0001-ARM-BCM5301X-Add-DT-for-Netgear-R8500.patch [new file with mode: 0644]
target/linux/bcm53xx/patches-4.4/044-0002-ARM-BCM5301X-Add-basic-dts-for-BCM53573-based-Tenda-.patch [new file with mode: 0644]
target/linux/bcm53xx/patches-4.4/130-ARM-BCM5301X-Add-basic-dts-for-BCM53573-based-Tenda-.patch [deleted file]
target/linux/bcm53xx/patches-4.4/301-ARM-BCM5301X-Add-DT-for-Netgear-R7900.patch
target/linux/bcm53xx/patches-4.4/306-ARM-BCM5301X-Add-DT-for-Netgear-R8500.patch [deleted file]
target/linux/bcm53xx/patches-4.4/331-ARM-BCM5301X-Specify-RAM-on-devices-by-including-HIG.patch

diff --git a/target/linux/bcm53xx/patches-4.4/044-0001-ARM-BCM5301X-Add-DT-for-Netgear-R8500.patch b/target/linux/bcm53xx/patches-4.4/044-0001-ARM-BCM5301X-Add-DT-for-Netgear-R8500.patch
new file mode 100644 (file)
index 0000000..954e8f9
--- /dev/null
@@ -0,0 +1,136 @@
+From b5057e498da8211ac3cc8ff5780034e5da61d077 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
+Date: Tue, 23 Aug 2016 08:40:32 +0200
+Subject: [PATCH] ARM: BCM5301X: Add DT for Netgear R8500
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Netgear R8500 is another BCM47094 device, it just has three BCM4366
+wireless chipsets. It's a very standard DT with mostly GPIO devices.
+
+Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/Makefile                   |   1 +
+ arch/arm/boot/dts/bcm47094-netgear-r8500.dts | 104 +++++++++++++++++++++++++++
+ 2 files changed, 105 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47094-netgear-r8500.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -77,6 +77,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm4709-netgear-r7000.dtb \
+       bcm4709-netgear-r8000.dtb \
+       bcm47094-dlink-dir-885l.dtb \
++      bcm47094-netgear-r8500.dtb \
+       bcm94708.dtb \
+       bcm94709.dtb \
+       bcm953012er.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
+@@ -0,0 +1,104 @@
++/*
++ * Copyright (C) 2016 Rafał Miłecki <rafal@milecki.pl>
++ *
++ * Licensed under the ISC license.
++ */
++
++/dts-v1/;
++
++#include "bcm4708.dtsi"
++#include "bcm5301x-nand-cs0-bch8.dtsi"
++
++/ {
++      compatible = "netgear,r8500", "brcm,bcm47094", "brcm,bcm4708";
++      model = "Netgear R8500";
++
++      chosen {
++              bootargs = "console=ttyS0,115200";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000>;
++      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              power0 {
++                      label = "bcm53xx:white:power";
++                      gpios = <&chipcommon 2 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-on";
++              };
++
++              power1 {
++                      label = "bcm53xx:amber:power";
++                      gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++
++              5ghz-1 {
++                      label = "bcm53xx:white:5ghz-1";
++                      gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++
++              5ghz-2 {
++                      label = "bcm53xx:white:5ghz-2";
++                      gpios = <&chipcommon 12 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++
++              2ghz {
++                      label = "bcm53xx:white:2ghz";
++                      gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++
++              usb2 {
++                      label = "bcm53xx:white:usb2";
++                      gpios = <&chipcommon 17 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++
++              usb3 {
++                      label = "bcm53xx:white:usb3";
++                      gpios = <&chipcommon 18 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              brightness {
++                      label = "Backlight";
++                      linux,code = <KEY_BRIGHTNESS_ZERO>;
++                      gpios = <&chipcommon 1 GPIO_ACTIVE_LOW>;
++              };
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 10 GPIO_ACTIVE_LOW>;
++              };
++
++              wps {
++                      label = "WPS";
++                      linux,code = <KEY_WPS_BUTTON>;
++                      gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
++              };
++
++              rfkill {
++                      label = "WiFi";
++                      linux,code = <KEY_RFKILL>;
++                      gpios = <&chipcommon 20 GPIO_ACTIVE_LOW>;
++              };
++      };
++};
++
++&uart0 {
++      status = "okay";
++      clock-frequency = <125000000>;
++};
diff --git a/target/linux/bcm53xx/patches-4.4/044-0002-ARM-BCM5301X-Add-basic-dts-for-BCM53573-based-Tenda-.patch b/target/linux/bcm53xx/patches-4.4/044-0002-ARM-BCM5301X-Add-basic-dts-for-BCM53573-based-Tenda-.patch
new file mode 100644 (file)
index 0000000..a1c462d
--- /dev/null
@@ -0,0 +1,264 @@
+From 21c29be6a69d3ef4f5a2e16272deb4845f8208ad Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
+Date: Tue, 23 Aug 2016 07:37:43 +0200
+Subject: [PATCH] ARM: BCM5301X: Add basic dts for BCM53573 based Tenda AC9
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+BCM53573 seems to be low priced alternative for Northstar chipsts. It
+uses single core Cortex-A7 and doesn't have SDU or local (TWD) timer. It
+was also stripped out of independent SPI controller and 2 GMACs.
+
+DTS for Tenda AC9 isn't completed yet. It misses e.g. switch entry (we
+still need some b53 fixes) and probably some clocks. It adds support for
+basic features however and can be improved later.
+
+Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/Makefile               |   2 +
+ arch/arm/boot/dts/bcm47189-tenda-ac9.dts |  74 ++++++++++++++++
+ arch/arm/boot/dts/bcm53573.dtsi          | 147 +++++++++++++++++++++++++++++++
+ 3 files changed, 223 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47189-tenda-ac9.dts
+ create mode 100644 arch/arm/boot/dts/bcm53573.dtsi
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -82,6 +82,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm94709.dtb \
+       bcm953012er.dtb \
+       bcm953012k.dtb
++dtb-$(CONFIG_ARCH_BCM_53573) += \
++      bcm47189-tenda-ac9.dtb
+ dtb-$(CONFIG_ARCH_BCM_63XX) += \
+       bcm963138dvt.dtb
+ dtb-$(CONFIG_ARCH_BCM_CYGNUS) += \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47189-tenda-ac9.dts
+@@ -0,0 +1,74 @@
++/*
++ * Copyright (C) 2016 Rafał Miłecki <rafal@milecki.pl>
++ *
++ * Licensed under the ISC license.
++ */
++
++/dts-v1/;
++
++#include "bcm53573.dtsi"
++
++/ {
++      compatible = "tenda,ac9", "brcm,bcm47189", "brcm,bcm53573";
++      model = "Tenda AC9";
++
++      chosen {
++              bootargs = "console=ttyS0,115200 earlycon";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000>;
++      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              usb {
++                      label = "bcm53xx:blue:usb";
++                      gpios = <&chipcommon 1 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "default-off";
++              };
++
++              wps {
++                      label = "bcm53xx:blue:wps";
++                      gpios = <&chipcommon 10 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "default-off";
++              };
++
++              5ghz {
++                      label = "bcm53xx:blue:5ghz";
++                      gpios = <&chipcommon 11 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "default-off";
++              };
++
++              system {
++                      label = "bcm53xx:blue:system";
++                      gpios = <&chipcommon 15 GPIO_ACTIVE_HIGH>;
++                      linux,default-trigger = "timer";
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              rfkill {
++                      label = "WiFi";
++                      linux,code = <KEY_RFKILL>;
++                      gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
++              };
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
++              };
++
++              wps {
++                      label = "WPS";
++                      linux,code = <KEY_WPS_BUTTON>;
++                      gpios = <&chipcommon 9 GPIO_ACTIVE_LOW>;
++              };
++      };
++};
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm53573.dtsi
+@@ -0,0 +1,147 @@
++/*
++ * Copyright (C) 2016 Rafał Miłecki <rafal@milecki.pl>
++ *
++ * Licensed under the ISC license.
++ */
++
++#include <dt-bindings/gpio/gpio.h>
++#include <dt-bindings/input/input.h>
++#include <dt-bindings/interrupt-controller/irq.h>
++#include <dt-bindings/interrupt-controller/arm-gic.h>
++#include "skeleton.dtsi"
++
++/ {
++      interrupt-parent = <&gic>;
++
++      chosen {
++              stdout-path = &uart0;
++      };
++
++      cpus {
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              cpu@0 {
++                      device_type = "cpu";
++                      compatible = "arm,cortex-a7";
++                      reg = <0x0>;
++              };
++      };
++
++      mpcore {
++              compatible = "simple-bus";
++              ranges = <0x00000000 0x18310000 0x00008000>;
++              #address-cells = <1>;
++              #size-cells = <1>;
++
++              gic: interrupt-controller@1000 {
++                      compatible = "arm,cortex-a7-gic";
++                      #interrupt-cells = <3>;
++                      #address-cells = <0>;
++                      interrupt-controller;
++                      reg = <0x1000 0x1000>,
++                            <0x2000 0x0100>;
++              };
++      };
++
++      clocks {
++              #address-cells = <1>;
++              #size-cells = <1>;
++              ranges;
++
++              alp: oscillator {
++                      #clock-cells = <0>;
++                      compatible = "fixed-clock";
++                      clock-frequency = <40000000>;
++              };
++      };
++
++      axi@18000000 {
++              compatible = "brcm,bus-axi";
++              reg = <0x18000000 0x1000>;
++              ranges = <0x00000000 0x18000000 0x00100000>;
++              #address-cells = <1>;
++              #size-cells = <1>;
++
++              #interrupt-cells = <1>;
++              interrupt-map-mask = <0x000fffff 0xffff>;
++              interrupt-map =
++                      /* ChipCommon */
++                      <0x00000000 0 &gic GIC_SPI 0 IRQ_TYPE_LEVEL_HIGH>,
++
++                      /* IEEE 802.11 0 */
++                      <0x00001000 0 &gic GIC_SPI 1 IRQ_TYPE_LEVEL_HIGH>,
++
++                      /* PCIe Controller 0 */
++                      <0x00002000 0 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
++                      <0x00002000 1 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
++                      <0x00002000 2 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
++                      <0x00002000 3 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
++                      <0x00002000 4 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
++                      <0x00002000 5 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
++
++                      /* USB 2.0 Controller */
++                      <0x00004000 0 &gic GIC_SPI 4 IRQ_TYPE_LEVEL_HIGH>,
++
++                      /* Ethernet Controller 0 */
++                      <0x00005000 0 &gic GIC_SPI 5 IRQ_TYPE_LEVEL_HIGH>,
++
++                      /* IEEE 802.11 1 */
++                      <0x0000a000 0 &gic GIC_SPI 7 IRQ_TYPE_LEVEL_HIGH>,
++
++                      /* Ethernet Controller 1 */
++                      <0x0000b000 0 &gic GIC_SPI 6 IRQ_TYPE_LEVEL_HIGH>;
++
++              chipcommon: chipcommon@0 {
++                      compatible = "simple-bus";
++                      reg = <0x00000000 0x1000>;
++                      ranges;
++
++                      #address-cells = <1>;
++                      #size-cells = <1>;
++
++                      gpio-controller;
++                      #gpio-cells = <2>;
++
++                      uart0: serial@0300 {
++                              compatible = "ns16550a";
++                              reg = <0x0300 0x100>;
++                              interrupt-parent = <&gic>;
++                              interrupts = <GIC_PPI 16 IRQ_TYPE_LEVEL_HIGH>;
++                              clocks = <&alp>;
++                              status = "okay";
++                      };
++              };
++
++              usb2: usb2@4000 {
++                      reg = <0x4000 0x1000>;
++                      ranges;
++                      #address-cells = <1>;
++                      #size-cells = <1>;
++
++                      ehci: ehci@4000 {
++                              compatible = "generic-ehci";
++                              reg = <0x4000 0x1000>;
++                              interrupt-parent = <&gic>;
++                              interrupts = <GIC_SPI 4 IRQ_TYPE_LEVEL_HIGH>;
++                      };
++
++                      ohci: ohci@d000 {
++                              #usb-cells = <0>;
++
++                              compatible = "generic-ohci";
++                              reg = <0xd000 0x1000>;
++                              interrupt-parent = <&gic>;
++                              interrupts = <GIC_SPI 4 IRQ_TYPE_LEVEL_HIGH>;
++                      };
++              };
++
++              gmac0: ethernet@5000 {
++                      reg = <0x5000 0x1000>;
++              };
++
++              gmac1: ethernet@b000 {
++                      reg = <0xb000 0x1000>;
++              };
++      };
++};
diff --git a/target/linux/bcm53xx/patches-4.4/130-ARM-BCM5301X-Add-basic-dts-for-BCM53573-based-Tenda-.patch b/target/linux/bcm53xx/patches-4.4/130-ARM-BCM5301X-Add-basic-dts-for-BCM53573-based-Tenda-.patch
deleted file mode 100644 (file)
index 9e6886d..0000000
+++ /dev/null
@@ -1,273 +0,0 @@
-From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
-Subject: [PATCH] ARM: BCM5301X: Add basic dts for BCM53573 based Tenda AC9
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-BCM53573 seems to be low priced alternative for standard Northstar
-chipsets. It uses single core Cortex-A7, doesn't have SDU or local (TWD)
-timer. It was also stripped out of independent SPI controller and 2
-GMACs.
-
-DTS for Tenda AC9 isn't completed yet. It misses e.g. switch entry (we
-still need some bgmac/b53 fixes) and probably some clocks. It adds
-support for basic features however and can be improved later.
-
-Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
----
- MAINTAINERS                              |   2 +
- arch/arm/boot/dts/Makefile               |   1 +
- arch/arm/boot/dts/bcm47189-tenda-ac9.dts |  74 ++++++++++++++++
- arch/arm/boot/dts/bcm53573.dtsi          | 147 +++++++++++++++++++++++++++++++
- 4 files changed, 224 insertions(+)
- create mode 100644 arch/arm/boot/dts/bcm47189-tenda-ac9.dts
- create mode 100644 arch/arm/boot/dts/bcm53573.dtsi
-
---- a/MAINTAINERS
-+++ b/MAINTAINERS
-@@ -2337,6 +2337,8 @@ S:       Maintained
- F:    arch/arm/mach-bcm/bcm_5301x.c
- F:    arch/arm/boot/dts/bcm5301x.dtsi
- F:    arch/arm/boot/dts/bcm470*
-+F:    arch/arm/boot/dts/bcm53573*
-+F:    arch/arm/boot/dts/bcm47189*
- BROADCOM BCM53573 ARM ARCHITECTURE
- M:    Rafał Miłecki <rafal@milecki.pl>
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -77,6 +77,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
-       bcm4709-netgear-r7000.dtb \
-       bcm4709-netgear-r8000.dtb \
-       bcm47094-dlink-dir-885l.dtb \
-+      bcm47189-tenda-ac9.dtb \
-       bcm94708.dtb \
-       bcm94709.dtb \
-       bcm953012er.dtb \
---- /dev/null
-+++ b/arch/arm/boot/dts/bcm47189-tenda-ac9.dts
-@@ -0,0 +1,74 @@
-+/*
-+ * Copyright (C) 2016 Rafał Miłecki <rafal@milecki.pl>
-+ *
-+ * Licensed under the ISC license.
-+ */
-+
-+/dts-v1/;
-+
-+#include "bcm53573.dtsi"
-+
-+/ {
-+      compatible = "tenda,ac9", "brcm,bcm47189", "brcm,bcm53573";
-+      model = "Tenda AC9";
-+
-+      chosen {
-+              bootargs = "console=ttyS0,115200 earlycon";
-+      };
-+
-+      memory {
-+              reg = <0x00000000 0x08000000>;
-+      };
-+
-+      leds {
-+              compatible = "gpio-leds";
-+
-+              usb {
-+                      label = "bcm53xx:blue:usb";
-+                      gpios = <&chipcommon 1 GPIO_ACTIVE_HIGH>;
-+                      linux,default-trigger = "default-off";
-+              };
-+
-+              wps {
-+                      label = "bcm53xx:blue:wps";
-+                      gpios = <&chipcommon 10 GPIO_ACTIVE_HIGH>;
-+                      linux,default-trigger = "default-off";
-+              };
-+
-+              5ghz {
-+                      label = "bcm53xx:blue:5ghz";
-+                      gpios = <&chipcommon 11 GPIO_ACTIVE_HIGH>;
-+                      linux,default-trigger = "default-off";
-+              };
-+
-+              system {
-+                      label = "bcm53xx:blue:system";
-+                      gpios = <&chipcommon 15 GPIO_ACTIVE_HIGH>;
-+                      linux,default-trigger = "timer";
-+              };
-+      };
-+
-+      gpio-keys {
-+              compatible = "gpio-keys";
-+              #address-cells = <1>;
-+              #size-cells = <0>;
-+
-+              rfkill {
-+                      label = "WiFi";
-+                      linux,code = <KEY_RFKILL>;
-+                      gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
-+              };
-+
-+              restart {
-+                      label = "Reset";
-+                      linux,code = <KEY_RESTART>;
-+                      gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
-+              };
-+
-+              wps {
-+                      label = "WPS";
-+                      linux,code = <KEY_WPS_BUTTON>;
-+                      gpios = <&chipcommon 9 GPIO_ACTIVE_LOW>;
-+              };
-+      };
-+};
---- /dev/null
-+++ b/arch/arm/boot/dts/bcm53573.dtsi
-@@ -0,0 +1,147 @@
-+/*
-+ * Copyright (C) 2016 Rafał Miłecki <rafal@milecki.pl>
-+ *
-+ * Licensed under the ISC license.
-+ */
-+
-+#include <dt-bindings/gpio/gpio.h>
-+#include <dt-bindings/input/input.h>
-+#include <dt-bindings/interrupt-controller/irq.h>
-+#include <dt-bindings/interrupt-controller/arm-gic.h>
-+#include "skeleton.dtsi"
-+
-+/ {
-+      interrupt-parent = <&gic>;
-+
-+      chosen {
-+              stdout-path = &uart0;
-+      };
-+
-+      cpus {
-+              #address-cells = <1>;
-+              #size-cells = <0>;
-+
-+              cpu@0 {
-+                      device_type = "cpu";
-+                      compatible = "arm,cortex-a7";
-+                      reg = <0x0>;
-+              };
-+      };
-+
-+      mpcore {
-+              compatible = "simple-bus";
-+              ranges = <0x00000000 0x18310000 0x00008000>;
-+              #address-cells = <1>;
-+              #size-cells = <1>;
-+
-+              gic: interrupt-controller@1000 {
-+                      compatible = "arm,cortex-a7-gic";
-+                      #interrupt-cells = <3>;
-+                      #address-cells = <0>;
-+                      interrupt-controller;
-+                      reg = <0x1000 0x1000>,
-+                            <0x2000 0x0100>;
-+              };
-+      };
-+
-+      clocks {
-+              #address-cells = <1>;
-+              #size-cells = <1>;
-+              ranges;
-+
-+              alp: oscillator {
-+                      #clock-cells = <0>;
-+                      compatible = "fixed-clock";
-+                      clock-frequency = <40000000>;
-+              };
-+      };
-+
-+      axi@18000000 {
-+              compatible = "brcm,bus-axi";
-+              reg = <0x18000000 0x1000>;
-+              ranges = <0x00000000 0x18000000 0x00100000>;
-+              #address-cells = <1>;
-+              #size-cells = <1>;
-+
-+              #interrupt-cells = <1>;
-+              interrupt-map-mask = <0x000fffff 0xffff>;
-+              interrupt-map =
-+                      /* ChipCommon */
-+                      <0x00000000 0 &gic GIC_SPI 0 IRQ_TYPE_LEVEL_HIGH>,
-+
-+                      /* IEEE 802.11 0 */
-+                      <0x00001000 0 &gic GIC_SPI 1 IRQ_TYPE_LEVEL_HIGH>,
-+
-+                      /* PCIe Controller 0 */
-+                      <0x00002000 0 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
-+                      <0x00002000 1 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
-+                      <0x00002000 2 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
-+                      <0x00002000 3 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
-+                      <0x00002000 4 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
-+                      <0x00002000 5 &gic GIC_SPI 2 IRQ_TYPE_LEVEL_HIGH>,
-+
-+                      /* USB 2.0 Controller */
-+                      <0x00004000 0 &gic GIC_SPI 4 IRQ_TYPE_LEVEL_HIGH>,
-+
-+                      /* Ethernet Controller 0 */
-+                      <0x00005000 0 &gic GIC_SPI 5 IRQ_TYPE_LEVEL_HIGH>,
-+
-+                      /* IEEE 802.11 1 */
-+                      <0x0000a000 0 &gic GIC_SPI 7 IRQ_TYPE_LEVEL_HIGH>,
-+
-+                      /* Ethernet Controller 1 */
-+                      <0x0000b000 0 &gic GIC_SPI 6 IRQ_TYPE_LEVEL_HIGH>;
-+
-+              chipcommon: chipcommon@0 {
-+                      compatible = "simple-bus";
-+                      reg = <0x00000000 0x1000>;
-+                      ranges;
-+
-+                      #address-cells = <1>;
-+                      #size-cells = <1>;
-+
-+                      gpio-controller;
-+                      #gpio-cells = <2>;
-+
-+                      uart0: serial@0300 {
-+                              compatible = "ns16550a";
-+                              reg = <0x0300 0x100>;
-+                              interrupt-parent = <&gic>;
-+                              interrupts = <GIC_PPI 16 IRQ_TYPE_LEVEL_HIGH>;
-+                              clocks = <&alp>;
-+                              status = "okay";
-+                      };
-+              };
-+
-+              usb2: usb2@4000 {
-+                      reg = <0x4000 0x1000>;
-+                      ranges;
-+                      #address-cells = <1>;
-+                      #size-cells = <1>;
-+
-+                      ehci: ehci@4000 {
-+                              compatible = "generic-ehci";
-+                              reg = <0x4000 0x1000>;
-+                              interrupt-parent = <&gic>;
-+                              interrupts = <GIC_SPI 4 IRQ_TYPE_LEVEL_HIGH>;
-+                      };
-+
-+                      ohci: ohci@d000 {
-+                              #usb-cells = <0>;
-+
-+                              compatible = "generic-ohci";
-+                              reg = <0xd000 0x1000>;
-+                              interrupt-parent = <&gic>;
-+                              interrupts = <GIC_SPI 4 IRQ_TYPE_LEVEL_HIGH>;
-+                      };
-+              };
-+
-+              gmac0: ethernet@5000 {
-+                      reg = <0x5000 0x1000>;
-+              };
-+
-+              gmac1: ethernet@b000 {
-+                      reg = <0xb000 0x1000>;
-+              };
-+      };
-+};
index 6dcdf6caafdeea634b0cc7588ef9867778f16007..eec68abc53bc27c2a63eb5c682c6a0a9f0c790df 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
 +      bcm4709-netgear-r7900.dtb \
        bcm4709-netgear-r8000.dtb \
        bcm47094-dlink-dir-885l.dtb \
-       bcm47189-tenda-ac9.dtb \
+       bcm47094-netgear-r8500.dtb \
 --- /dev/null
 +++ b/arch/arm/boot/dts/bcm4709-netgear-r7900.dts
 @@ -0,0 +1,41 @@
diff --git a/target/linux/bcm53xx/patches-4.4/306-ARM-BCM5301X-Add-DT-for-Netgear-R8500.patch b/target/linux/bcm53xx/patches-4.4/306-ARM-BCM5301X-Add-DT-for-Netgear-R8500.patch
deleted file mode 100644 (file)
index addbe36..0000000
+++ /dev/null
@@ -1,133 +0,0 @@
-From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
-Subject: [PATCH] ARM: BCM5301X: Add DT for Netgear R8500
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
----
- arch/arm/boot/dts/Makefile                   |  1 +
- arch/arm/boot/dts/bcm47094-netgear-r8500.dts | 31 ++++++++++++++++++++++++++++
- 2 files changed, 32 insertions(+)
- create mode 100644 arch/arm/boot/dts/bcm47094-netgear-r8500.dts
-
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -79,6 +79,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
-       bcm4709-netgear-r7900.dtb \
-       bcm4709-netgear-r8000.dtb \
-       bcm47094-dlink-dir-885l.dtb \
-+      bcm47094-netgear-r8500.dtb \
-       bcm47189-tenda-ac9.dtb \
-       bcm94708.dtb \
-       bcm94709.dtb \
---- /dev/null
-+++ b/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
-@@ -0,0 +1,107 @@
-+/*
-+ * Broadcom BCM470X / BCM5301X ARM platform code.
-+ * DTS for Netgear R8500
-+ *
-+ * Copyright (C) 2016 Rafał Miłecki <zajec5@gmail.com>
-+ *
-+ * Licensed under the GNU/GPL. See COPYING for details.
-+ */
-+
-+/dts-v1/;
-+
-+#include "bcm4708.dtsi"
-+#include "bcm5301x-nand-cs0-bch8.dtsi"
-+
-+/ {
-+      compatible = "netgear,r8500", "brcm,bcm47094", "brcm,bcm4708";
-+      model = "Netgear R8500";
-+
-+      chosen {
-+              bootargs = "console=ttyS0,115200";
-+      };
-+
-+      memory {
-+              reg = <0x00000000 0x08000000>;
-+      };
-+
-+      leds {
-+              compatible = "gpio-leds";
-+
-+              power0 {
-+                      label = "bcm53xx:white:power";
-+                      gpios = <&chipcommon 2 GPIO_ACTIVE_LOW>;
-+                      linux,default-trigger = "default-on";
-+              };
-+
-+              power1 {
-+                      label = "bcm53xx:amber:power";
-+                      gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
-+                      linux,default-trigger = "default-off";
-+              };
-+
-+              5ghz-1 {
-+                      label = "bcm53xx:white:5ghz-1";
-+                      gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
-+                      linux,default-trigger = "default-off";
-+              };
-+
-+              5ghz-2 {
-+                      label = "bcm53xx:white:5ghz-2";
-+                      gpios = <&chipcommon 12 GPIO_ACTIVE_LOW>;
-+                      linux,default-trigger = "default-off";
-+              };
-+
-+              2ghz {
-+                      label = "bcm53xx:white:2ghz";
-+                      gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
-+                      linux,default-trigger = "default-off";
-+              };
-+
-+              usb2 {
-+                      label = "bcm53xx:white:usb2";
-+                      gpios = <&chipcommon 17 GPIO_ACTIVE_LOW>;
-+                      linux,default-trigger = "default-off";
-+              };
-+
-+              usb3 {
-+                      label = "bcm53xx:white:usb3";
-+                      gpios = <&chipcommon 18 GPIO_ACTIVE_LOW>;
-+                      linux,default-trigger = "default-off";
-+              };
-+      };
-+
-+      gpio-keys {
-+              compatible = "gpio-keys";
-+              #address-cells = <1>;
-+              #size-cells = <0>;
-+
-+              brightness {
-+                      label = "Backlight";
-+                      linux,code = <KEY_BRIGHTNESS_ZERO>;
-+                      gpios = <&chipcommon 1 GPIO_ACTIVE_LOW>;
-+              };
-+
-+              restart {
-+                      label = "Reset";
-+                      linux,code = <KEY_RESTART>;
-+                      gpios = <&chipcommon 10 GPIO_ACTIVE_LOW>;
-+              };
-+
-+              wps {
-+                      label = "WPS";
-+                      linux,code = <KEY_WPS_BUTTON>;
-+                      gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
-+              };
-+
-+              rfkill {
-+                      label = "WiFi";
-+                      linux,code = <KEY_RFKILL>;
-+                      gpios = <&chipcommon 20 GPIO_ACTIVE_LOW>;
-+              };
-+      };
-+};
-+
-+&uart0 {
-+      status = "okay";
-+      clock-frequency = <125000000>;
-+};
index f2e5a3e2b4d8512e7e3e1e0f58646b87cb0c6177..11d6fa68ac5c9db8b19e6fe2adb07371443b4f96 100644 (file)
@@ -185,7 +185,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
        nand: nand@18028000 {
 --- a/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
 +++ b/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
-@@ -21,7 +21,8 @@
+@@ -18,7 +18,8 @@
        };
  
        memory {