lantiq: fix 0008-MIPS-lantiq-backport-old-timer-code.patch for Amazon-SE
authorTino Reichardt <milky-lede@mcmilk.de>
Sun, 7 May 2017 17:30:36 +0000 (19:30 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 3 Jun 2017 19:35:53 +0000 (21:35 +0200)
The patch 0008 removes the vanilla kernel gptu.c of lantiq.
But the replacement file timer.c does not work Amazon-SE and
is also protected therefore with an CONFIG_SOC_AMAZON_SE :-)

This commit will re-activate the default vanilla kernel code
in gptu.c for Amazon-SE.

Signed-off-by: Tino Reichardt <milky-lede@mcmilk.de>
[refresh patches and add same change for kernel 4.9]
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/lantiq/patches-4.4/0008-MIPS-lantiq-backport-old-timer-code.patch
target/linux/lantiq/patches-4.4/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
target/linux/lantiq/patches-4.9/0008-MIPS-lantiq-backport-old-timer-code.patch
target/linux/lantiq/patches-4.9/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch

index f36a79a83be1ed5fed04bcf1d43857c4f881e3b2..335a1e261670c5289374f08ce8fa82cc57cf5eb1 100644 (file)
@@ -172,9 +172,15 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
 --- a/arch/mips/lantiq/xway/Makefile
 +++ b/arch/mips/lantiq/xway/Makefile
-@@ -1,4 +1,4 @@
+@@ -1,4 +1,10 @@
 -obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
-+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
++obj-y := prom.o sysctrl.o clk.o reset.o dma.o dcdc.o
++
++ifdef CONFIG_SOC_AMAZON_SE
++obj-y += gptu.o
++else
++obj-y += timer.o
++endif
  
  obj-y += vmmc.o
  
index 15ecdb354321ce40a44506be55f06779c486835a..64060ebcecb583077f952fc0bb8dfaa5a968e1c3 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  #endif /* _LTQ_XWAY_H__ */
 --- a/arch/mips/lantiq/xway/Makefile
 +++ b/arch/mips/lantiq/xway/Makefile
-@@ -2,4 +2,7 @@ obj-y := prom.o sysctrl.o clk.o reset.o
+@@ -8,4 +8,7 @@ endif
  
  obj-y += vmmc.o
  
index f36a79a83be1ed5fed04bcf1d43857c4f881e3b2..335a1e261670c5289374f08ce8fa82cc57cf5eb1 100644 (file)
@@ -172,9 +172,15 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
 --- a/arch/mips/lantiq/xway/Makefile
 +++ b/arch/mips/lantiq/xway/Makefile
-@@ -1,4 +1,4 @@
+@@ -1,4 +1,10 @@
 -obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
-+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
++obj-y := prom.o sysctrl.o clk.o reset.o dma.o dcdc.o
++
++ifdef CONFIG_SOC_AMAZON_SE
++obj-y += gptu.o
++else
++obj-y += timer.o
++endif
  
  obj-y += vmmc.o
  
index d875c55fb8cd13e97776f13dadf10fb7ed8224a2..cef4c1e2a37b4fc9dd339d37fce573feaa980fc2 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  #endif /* _LTQ_XWAY_H__ */
 --- a/arch/mips/lantiq/xway/Makefile
 +++ b/arch/mips/lantiq/xway/Makefile
-@@ -2,4 +2,7 @@ obj-y := prom.o sysctrl.o clk.o reset.o
+@@ -8,4 +8,7 @@ endif
  
  obj-y += vmmc.o