modules: add missing wpan fakehard driver
authorJohn Crispin <john@openwrt.org>
Fri, 10 Apr 2015 13:39:38 +0000 (13:39 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 10 Apr 2015 13:39:38 +0000 (13:39 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 45364

package/kernel/linux/modules/wpan.mk

index 40abfcac6e7a011792daf3caeb821af6409cc0d0..a89f3b71fcc4ffb6698eaed37b96e93999bfd065 100644 (file)
@@ -53,10 +53,26 @@ endef
 
 $(eval $(call KernelPackage,mac802154))
 
-define KernelPackage/fakelb
+define KernelPackage/fakehard
   SUBMENU:=$(WPAN_MENU)
   TITLE:=Fake LR-WPAN driver
   DEPENDS:=+kmod-mac802154 @!LINUX_4.0
+  KCONFIG:=CONFIG_IEEE802154_FAKEHARD
+  FILES:=$(LINUX_DIR)/drivers/net/ieee802154/fakehard.ko
+  AUTOLOAD:=$(call AutoLoad,92,fakehard)
+endef
+
+define KernelPackage/fakehard/description
+  Say Y here to enable the fake driver that can emulate a net
+  of several interconnected radio devices.
+endef
+
+$(eval $(call KernelPackage,fakehard))
+
+define KernelPackage/fakelb
+  SUBMENU:=$(WPAN_MENU)
+  TITLE:=Fake LR-WPAN loopback driver
+  DEPENDS:=+kmod-mac802154 @!LINUX_4.0
   KCONFIG:=CONFIG_IEEE802154_FAKELB
   FILES:=$(LINUX_DIR)/drivers/net/ieee802154/fakelb.ko
   AUTOLOAD:=$(call AutoLoad,92,fakelb)