ramips: rt305x: add add support for the Asus WL-330N board
authorGabor Juhos <juhosg@openwrt.org>
Tue, 27 Mar 2012 19:29:57 +0000 (19:29 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 27 Mar 2012 19:29:57 +0000 (19:29 +0000)
[juhosg: reorder several lines in order to keep things sorted
alphabetically]

Signed-off-by: Frédéric Leroy <fredo@starox.org>
SVN-Revision: 31100

12 files changed:
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wl-330n.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-3.2

index f8dac497d6114d85a2e6358af8ff4dcb04d4941d..95f608a4f51e48f25c1ecfa0a251725d705ac9ac 100755 (executable)
@@ -69,7 +69,7 @@ get_status_led() {
        rt-n10-plus)
                status_led="asus:green:wps"
                ;;
-       rt-n56u)
+       rt-n56u | wl-330n )
                status_led="asus:blue:power"
                ;;
        sl-r7205)
index bc23208575819e272f255a0d5d9910bda0538648..7bd58d5facb9f8b7b64bed8093f4720124af8bef 100644 (file)
@@ -67,6 +67,7 @@ case "$FIRMWARE" in
        w502u | \
        wcr-150gn | \
        whr-g300n | \
+       wl-330n | \
        wl-351 | \
        wli-tx4-ag300n | \
        wr512-3gn | \
index 77b65cb3a0b830b160125215414a15e03178d7e7..a17fad8e98266422d03bf17058c25d8c524b4f19 100755 (executable)
@@ -16,7 +16,8 @@ ramips_setup_interfaces()
        ucidef_set_interface_loopback
 
        case $board in
-       all0256n)
+       all0256n | \
+       wl-330n)
                ucidef_set_interface_lan "eth0.1"
                ;;
 
index 97cacfa5ee43fb2e1294c64b31d2b6f3e0aa7c1d..90c327a2ed43d056e509f687eb97ff222fffa31a 100644 (file)
@@ -28,6 +28,7 @@ preinit_set_mac_address() {
        nbg-419n |\
        omni-emb |\
        w502u    |\
+       wl-330n |\
        wr6202 |\
        xdxrn502j)
                mac=$(ramips_get_mac_binary factory 40)
index faa2485365df3ec6be2c40cab860ccbae80b2533..6e1da23040bf605c635ed956efb5e1544ee189dd 100755 (executable)
@@ -53,6 +53,9 @@ ramips_board_name() {
        *"Argus ATP-52B")
                name="argus-atp52b"
                ;;
+       *"Asus WL-330N")
+               name="wl-330n"
+               ;;
        *"Aztech HW550-3G")
                name="hw550-3g"
                ;;
index 1f6910d7620d6e1e3a9d73e7a9f2038e42d9a42e..4d0bb19c77172b87f3bf0cb7c8475a9eb6808cbf 100755 (executable)
@@ -35,6 +35,7 @@ platform_check_image() {
        wr6202 |\
        v22rw-2x2 | \
        wl341v3 | \
+       wl-330n | \
        wli-tx4-ag300n | \
        whr-g300n |\
        wr512-3gn)
index 823416442442cfb73b76fcf8352180fccf8f7ed5..b101dcdacfa81a4055aabf41c0cce80340eaae56 100644 (file)
@@ -28,6 +28,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_RT_G32_B1,          /* Asus RT-G32 B1 */
        RAMIPS_MACH_RT_N10_PLUS,        /* Asus RT-N10+ */
        RAMIPS_MACH_NW718,              /* Netcore NW718 */
+       RAMIPS_MACH_WL_330N,            /* Asus WL-330N */
 
        /* RT3052 based machines */
        RAMIPS_MACH_ARGUS_ATP52B,       /* Argus ATP-52B */
index 1bf960f7eb01bd35a63dee3895d2c3da7e0f8d90..6c5a62f507583b92c7ca66b1d62a5e90aebcf90d 100644 (file)
@@ -31,6 +31,11 @@ config RT305X_MACH_RT_N10_PLUS
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_WL_330N
+       bool "Asus WL-330N board support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_HW550_3G
        bool "Aztech HW550-3G support"
        select RALINK_DEV_GPIO_BUTTONS
index aec57a01163d4863c410287ba09c024d4b143a7c..db3c26210d1a1c478133576137cb5179035617b0 100644 (file)
@@ -32,6 +32,7 @@ obj-$(CONFIG_RT305X_MACH_W502U)               += mach-w502u.o
 obj-$(CONFIG_RT305X_MACH_WCR150GN)     += mach-wcr150gn.o
 obj-$(CONFIG_RT305X_MACH_WHR_G300N)    += mach-whr-g300n.o
 obj-$(CONFIG_RT305X_MACH_WR512_3GN)    += mach-wr512-3gn.o
+obj-$(CONFIG_RT305X_MACH_WL_330N)      += mach-wl-330n.o
 obj-$(CONFIG_RT305X_MACH_WL341V3)      += mach-wl341v3.o
 obj-$(CONFIG_RT305X_MACH_WL351)                += mach-wl351.o
 obj-$(CONFIG_RT305X_MACH_WR6202)       += mach-wr6202.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wl-330n.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-wl-330n.c
new file mode 100644 (file)
index 0000000..b548dfe
--- /dev/null
@@ -0,0 +1,94 @@
+/*
+ *  Asus WL_330N board support
+ *
+ *  Copyright (C) 2012 Frederic Leroy <fredo@starox.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define WL_330N_GPIO_BUTTON_RESET 10
+#define WL_330N_GPIO_BUTTON_WPS 0
+#define WL_330N_GPIO_LED_LINK 9
+#define WL_330N_GPIO_LED_POWER 11
+#define WL_330N_KEYS_POLL_INTERVAL 20
+#define WL_330N_KEYS_DEBOUNCE_INTERVAL (3 * WL_330N_KEYS_POLL_INTERVAL)
+
+const struct flash_platform_data wl_330n_flash = {
+       .type           = "mx25l3205d",
+};
+
+struct spi_board_info wl_330n_spi_slave_info[] __initdata = {
+       {
+               .modalias       = "m25p80",
+               .platform_data  = &wl_330n_flash,
+               .irq            = -1,
+               .max_speed_hz   = 10000000,
+               .bus_num        = 0,
+               .chip_select    = 0,
+       },
+};
+
+static struct gpio_keys_button wl_330n_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = WL_330N_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = WL_330N_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = WL_330N_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = WL_330N_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_led wl_330n_leds_gpio[] __initdata = {
+       {
+               .name           = "asus:blue:link",
+               .gpio           = WL_330N_GPIO_LED_LINK,
+               .active_low     = 1,
+       }, {
+               .name           = "asus:blue:power",
+               .gpio           = WL_330N_GPIO_LED_POWER,
+               .active_low     = 1,
+       }
+};
+
+static void __init wl_330n_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+       rt305x_register_spi(wl_330n_spi_slave_info,
+                           ARRAY_SIZE(wl_330n_spi_slave_info));
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+       rt305x_register_ethernet();
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(wl_330n_leds_gpio),
+                                 wl_330n_leds_gpio);
+       ramips_register_gpio_buttons(-1, WL_330N_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(wl_330n_gpio_buttons),
+                                    wl_330n_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_WL_330N, "WL_330N", "Asus WL-330N",
+            wl_330n_init);
index 97f4a9a42d4f082497a5e6f60710f62c45cc2c6d..3499c9e765f17620c4f2634dd5b8ac3a2bee2405 100644 (file)
@@ -378,6 +378,10 @@ define Image/Build/Profile/WHRG300N
        $(call Image/Build/Template/$(fs_squashfs)/$(1),WHRG300N)
 endef
 
+define Image/Build/Profile/WL_330N
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,wl-330n,WL_330N,ttyS1,57600,spi)
+endef
+
 define Image/Build/Profile/WL341V3
        $(call Image/Build/Template/$(fs_squash)/$(1),WL341V3,wl341v3,WL341V3)
 endef
@@ -421,6 +425,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/W502U,$(1))
        $(call Image/Build/Profile/WCR150GN,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
+       $(call Image/Build/Profile/WL_330N,$(1))
        $(call Image/Build/Profile/WL341V3,$(1))
        $(call Image/Build/Profile/WL351,$(1))
        $(call Image/Build/Profile/WR5123GN,$(1))
index cd25acc2af7a4258db47a1081285af1e99633e9a..4c928a4cdb3b8bfbd00ae59ad8fa4bce2adcec35 100644 (file)
@@ -115,6 +115,7 @@ CONFIG_RT305X_MACH_WCR150GN=y
 CONFIG_RT305X_MACH_WHR_G300N=y
 CONFIG_RT305X_MACH_WL341V3=y
 CONFIG_RT305X_MACH_WL351=y
+CONFIG_RT305X_MACH_WL_330N=y
 CONFIG_RT305X_MACH_WR512_3GN=y
 CONFIG_RT305X_MACH_WR6202=y
 CONFIG_RT305X_MACH_XDX_RN502J=y