uboot-envtools: use new scripts from /lib/ to match boards
authorLuka Perkov <luka@openwrt.org>
Thu, 26 Jun 2014 10:14:14 +0000 (10:14 +0000)
committerLuka Perkov <luka@openwrt.org>
Thu, 26 Jun 2014 10:14:14 +0000 (10:14 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 41340

package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/imx6
package/boot/uboot-envtools/files/kirkwood

index dad971a4e41911a11ec0b505b4f6a2be30443996..301a0e432a644c2725c3c7baa8c29720c79e0600 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2014.04
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
index 66fceac84113b0362b9e2bac87007c81fa1f9998..fac6436c10650fd924bc16ed2c99382b63d53266 100644 (file)
@@ -1,19 +1,20 @@
 #!/bin/sh
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 
 [ -e /etc/config/ubootenv ] && exit 0
 
 touch /etc/config/ubootenv
 
+. /lib/imx6.sh
 . /lib/uboot-envtools.sh
 . /lib/functions.sh
 
-board=$(cat /proc/device-tree/model)
+board=$(imx6_board_name)
 
 case "$board" in
-"Wandboard i.MX6 Dual Lite Board")
+"wandboard")
        ubootenv_add_uci_config "/dev/mmcblk0" "0x60000" "0x2000" "0x2000"
        ;;
 esac
index 7856f3cfd4470b5d7aa4196596619f5bde14dd7a..ef6c1131a7b97d30e90d1eb5ae82cb9d9c1664b2 100644 (file)
@@ -7,13 +7,16 @@
 
 touch /etc/config/ubootenv
 
+. /lib/kirkwood.sh
 . /lib/uboot-envtools.sh
 . /lib/functions.sh
 
-case "`cat /proc/device-tree/model`" in
-"Cloud Engines Pogoplug E02" | \
-"Linksys EA4500" | \
-"RaidSonic ICY BOX IB-NAS62x0 (Rev B)")
+board=$(kirkwood_board_name)
+
+case "$board" in
+"ea4500" | \
+"ib62x0" | \
+"pogo_e02")
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x20000" "0x20000"
        ;;
 esac