gdb: use the libthread-db package instead of throwing the lib into the gdbserver...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 29 Oct 2012 19:25:34 +0000 (19:25 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 29 Oct 2012 19:25:34 +0000 (19:25 +0000)
SVN-Revision: 34000

package/devel/gdb/Makefile

index d9d69d955a8be751f628b629331abf87d0690d43..50d12fcbf7a5ec9ed76f49bdd11e7ba059e9ee7c 100644 (file)
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/gdb/Default
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@!(avr32||cris)
+  DEPENDS:=@!(avr32||cris) +libthread-db
   URL:=http://www.gnu.org/software/gdb/
 endef
 
@@ -80,10 +80,6 @@ endef
 define Package/gdbserver/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
-ifneq ($(CONFIG_USE_EGLIBC),)
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(TOOLCHAIN_DIR)/lib/libthread_db* $(1)/usr/lib
-endif
 endef
 
 $(eval $(call BuildPackage,gdb))