prevent distro default LPATH from interfering
authorJohn Crispin <john@openwrt.org>
Thu, 5 Apr 2012 14:33:03 +0000 (14:33 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 5 Apr 2012 14:33:03 +0000 (14:33 +0000)
Attach patch unsets LPATH flag (found configured in some custom host
distributions) to make OpenWRT compile its toolchain without any issues.
LPATH is used on some distros to define the linkers search path.

Signed-off-by: Tathagata Das <tathagata@alumnux.com>
SVN-Revision: 31203

include/toplevel.mk

index 4c9b85c21185404c0f46e360ad1d54506b1fab46..9a60139329cdc18a5dca6c8682b8609fff956a54 100644 (file)
@@ -33,6 +33,9 @@ unexport QUILT_PATCHES QUILT_PATCH_OPTS
 
 unexport C_INCLUDE_PATH
 
+# prevent distro default LPATH from interfering
+unexport LPATH
+
 # make sure that a predefined CFLAGS variable does not disturb packages
 export CFLAGS=