include: extend SetupHostCommand macro to accept more arguments
authorJo-Philipp Wich <jo@mein.io>
Thu, 5 Apr 2018 11:54:41 +0000 (13:54 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 5 Apr 2018 11:58:15 +0000 (13:58 +0200)
Commit d6d3db0543 added more gcc version probes, exceeding the argument
limit of the SetupHostCommand macro, leading to failing GCC/LLVM tests
on OS X.

Extend the handled number of arguments to restore proper functionality.

Fixes FS#1470
Fixes d6d3db0543 ("build: Improve GCC version detection")

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/prereq.mk

index 6cb590e360aab351b567e8b76dfa35a98815d4af..0f0f2537448f2f314a4b923d0f3fb3f4924f4397 100644 (file)
@@ -90,7 +90,8 @@ define SetupHostCommand
        for cmd in $(call QuoteHostCommand,$(3)) $(call QuoteHostCommand,$(4)) \
                   $(call QuoteHostCommand,$(5)) $(call QuoteHostCommand,$(6)) \
                   $(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)) \
-                          $(call QuoteHostCommand,$(9)); do \
+                  $(call QuoteHostCommand,$(9)) $(call QuoteHostCommand,$(10)) \
+                  $(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
                if [ -n "$$$$$$$$cmd" ]; then \
                        bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
                                which "$$$$$$$${cmd%% *}")"; \