Revert "bzip2: extend/fix the Host/Install rule to install libbz2.so files"
authorFelix Fietkau <nbd@openwrt.org>
Sat, 19 Dec 2015 11:28:49 +0000 (11:28 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 19 Dec 2015 11:28:49 +0000 (11:28 +0000)
This reverts r47245.

Linking to shared libraries under $STAGING_DIR_HOST{,/usr}/lib is harmful,
as these directories aren't added to LD_LIBRARY_PATH (see r47103 for an
explanation why LD_LIBRARY_PATH is not used).

Revert to static linking; in particular, this fixes the build of the python
bz2 module on OpenSUSE and Fedora (which in turn broke the build of
nodejs).

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
SVN-Revision: 47950

package/utils/bzip2/Makefile

index ba47cfb7e3b123abd9108c0bf3332c8a157515ed..4ad9684217dd752f62dbe544596a8dea0fbf9c00 100644 (file)
@@ -97,10 +97,8 @@ HOST_CONFIGURE_ARGS+= \
        --prefix=$(STAGING_DIR_HOST)
 
 define Host/Install
        --prefix=$(STAGING_DIR_HOST)
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/ $(STAGING_DIR_HOST)/usr/lib
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
        $(MAKE) -C $(HOST_BUILD_DIR) PREFIX=$(STAGING_DIR_HOST)/usr/ install
        $(MAKE) -C $(HOST_BUILD_DIR) PREFIX=$(STAGING_DIR_HOST)/usr/ install
-       $(CP) $(HOST_BUILD_DIR)/libbz2.so* $(STAGING_DIR_HOST)/usr/lib/
-       $(CP) $(HOST_BUILD_DIR)/libbz2.so.1.0 $(STAGING_DIR_HOST)/usr/lib/libbz2.so
 endef
 
 $(eval $(call HostBuild))
 endef
 
 $(eval $(call HostBuild))