ramips: convert mt7688 to new image building code
authorJohn Crispin <john@phrozen.org>
Wed, 11 May 2016 10:54:41 +0000 (12:54 +0200)
committerJohn Crispin <john@phrozen.org>
Thu, 12 May 2016 01:29:36 +0000 (03:29 +0200)
Signed-off-by: John Crispin <john@phrozen.org>
target/linux/ramips/image/mt7688.mk
target/linux/ramips/mt7688/profiles/00-default.mk
target/linux/ramips/mt7688/profiles/01-mediatek.mk [deleted file]

index 45991d08741e64afed9279e7fe2a158d6c09c132..b3860ef78a608ce1fe4f0dce9f2ff52b18636ccc 100644 (file)
@@ -2,10 +2,18 @@
 # MT7688 Profiles
 #
 
-Image/Build/Profile/LinkIt7688=$(call BuildFirmware/Default32M/$(1),$(1),LinkIt7688,LINKIT7688)
-Image/Build/Profile/WRTNODE2R=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode2r,WRTNODE2R)
+define Device/LinkIt7688
+  DTS := LINKIT7688
+  IMAGE_SIZE := $(ralink_default_fw_size_32M)
+  DEVICE_TITLE := MediaTek LinkIt Smart 7688
+  DEVICE_PACKAGES:= kmod-usb2 kmod-usb-ohci uboot-envtools
+endef
+TARGET_DEVICES += LinkIt7688
 
-define Image/Build/Profile/Default
-       $(call Image/Build/Profile/LinkIt7688,$(1))
-       $(call Image/Build/Profile/WRTNODE2R,$(1))
+define Device/wrtnode2r
+  DTS := WRTNODE2R
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  DEVICE_TITLE := WRTnode 2R
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
 endef
+TARGET_DEVICES += wrtnode2r
index 6c7d7214448a7c5379e8841d1527cf87adf39f1b..55a85a69e9b8fd1293923a4a565203fceb181ce3 100644 (file)
@@ -7,9 +7,7 @@
 
 define Profile/Default
        NAME:=Default Profile
-       PACKAGES:=\
-               kmod-usb-core kmod-usb2 kmod-usb-ohci \
-               kmod-ledtrig-usbdev
+       PACKAGES:= kmod-usb-core kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
 endef
 
 define Profile/Default/Description
diff --git a/target/linux/ramips/mt7688/profiles/01-mediatek.mk b/target/linux/ramips/mt7688/profiles/01-mediatek.mk
deleted file mode 100644 (file)
index 1ef824d..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/LinkIt7688
-       NAME:=LinkIt7688
-       PACKAGES:=\
-               kmod-usb-core kmod-usb2 kmod-usb-ohci \
-               uboot-envtools kmod-ledtrig-netdev
-endef
-
-define Profile/LinkIt7688/Description
-       Default package set compatible with LinkIt Smart7688 dev board.
-endef
-$(eval $(call Profile,LinkIt7688))