toolchain/uclibc: Fix unmanned configuration with "V=s"
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>
Fri, 10 Feb 2017 18:59:54 +0000 (21:59 +0300)
committerFelix Fietkau <nbd@nbd.name>
Sat, 11 Feb 2017 14:38:32 +0000 (15:38 +0100)
Currently on attempt to configure uClibc with "V=s" user is prompted
to answer on configuration questions. Major inconvenience here is
build procedure get paused until user answers all questions.
That happens because not all symbols are defined in our .config.

Solution is as simple as usage of "olddefconfig" target instead of
simple "oldconfig". In that case default values get silently set
for symbols not defined by our .config explicitly.

We haven't noticed that subtle issue before because without "V=s"
what we do is "make oldconfig < /dev/null" which automatically
answers all questions :)

Signed-off-by: Alexey Brodkin <Alexey.Brodkin@synopsys.com>
toolchain/uClibc/common.mk

index efcbde8f028e30c639bb477f8f61241264697bd6..0e3f5600d63a95f460d4e69a5c99af4b9bb2528a 100644 (file)
@@ -83,7 +83,7 @@ define Host/Configure
                $(HOST_BUILD_DIR)/.config.new
        cmp -s $(HOST_BUILD_DIR)/.config.new $(HOST_BUILD_DIR)/.config.last || { \
                cp $(HOST_BUILD_DIR)/.config.new $(HOST_BUILD_DIR)/.config && \
-               $(MAKE) -C $(HOST_BUILD_DIR) oldconfig KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS" && \
+               $(MAKE) -C $(HOST_BUILD_DIR) olddefconfig KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS" && \
                $(MAKE) -C $(HOST_BUILD_DIR)/extra/config conf KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS" && \
                cp $(HOST_BUILD_DIR)/.config.new $(HOST_BUILD_DIR)/.config.last; \
        }