sysupgrade: do not kill any processes in failsafe
authorJohn Crispin <john@openwrt.org>
Fri, 17 Jan 2014 22:12:05 +0000 (22:12 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 17 Jan 2014 22:12:05 +0000 (22:12 +0000)
sysugrade killed the lock causing failsafe to stop

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
SVN-Revision: 39318

package/base-files/Makefile
package/base-files/files/sbin/sysupgrade

index 0160e41f88c3bba97c17084100d1d482a001fe01..d6c59384ee118afcb64e0a0e2576ebd5f28e258e 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=149
+PKG_RELEASE:=150
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 56e9a92424556d8a981e3f313561becaf6228e3e..e6588bffcf61d0ae5cb906011ac32fa99283cb45 100755 (executable)
@@ -210,9 +210,11 @@ run_hooks "" $sysupgrade_pre_upgrade
 ubus call system upgrade
 touch /tmp/sysupgrade
 
-kill_remaining TERM
-sleep 3
-kill_remaining KILL
+if [ ! -f /tmp/failsafe ] ; then
+       kill_remaining TERM
+       sleep 3
+       kill_remaining KILL
+fi
 
 if [ -n "$(rootfs_type)" ]; then
        v "Switching to ramdisk..."