fix rb532 image build
authorFelix Fietkau <nbd@openwrt.org>
Wed, 31 Jan 2007 17:18:50 +0000 (17:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 31 Jan 2007 17:18:50 +0000 (17:18 +0000)
SVN-Revision: 6233

target/linux/rb532-2.6/image/Makefile

index 706b672e74a67da166fdb5d08b04f682e17cdbca..2ded1c078849af51ede68d476f0df23f5f1e2cbe 100644 (file)
@@ -29,10 +29,9 @@ define Build/Clean
 endef
 
 define Image/Prepare
-       $(KERNEL_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)
        cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
        $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
-       cp $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.elf
+       $(KERNEL_CROSS)objcopy -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.elf
 endef
 
 define Image/BuildKernel
@@ -53,7 +52,7 @@ endef
 
 define Image/Build
        $(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
-       ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(LINUX_DIR)/vmlinux 16 $(KDIR)/root.$(1)
+       ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf 16 $(KDIR)/root.$(1)
 endef
 
 $(eval $(call BuildImage))