uboot-kirkwood: update to 2018.03
authorPaul Wassi <p.wassi@gmx.at>
Tue, 13 Mar 2018 16:25:20 +0000 (17:25 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 20 Mar 2018 20:45:27 +0000 (21:45 +0100)
U-Boot now requires GCC > 5

Catch up with upstream and move some configuration options from
the header files to the corresponding defconfig files.
Also move some options of patch 010 affecting the whole platform
to 010's device only.

Signed-off-by: Paul Wassi <p.wassi@gmx.at>
package/boot/uboot-kirkwood/Makefile
package/boot/uboot-kirkwood/patches/007-nsa310-uboot-generic.patch
package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch
package/boot/uboot-kirkwood/patches/010-pogoplug_v4.patch
package/boot/uboot-kirkwood/patches/110-dockstar.patch
package/boot/uboot-kirkwood/patches/120-iconnect.patch
package/boot/uboot-kirkwood/patches/130-ib62x0.patch
package/boot/uboot-kirkwood/patches/140-pogoplug_e02.patch
package/boot/uboot-kirkwood/patches/150-goflexhome.patch
package/boot/uboot-kirkwood/patches/200-openwrt-config.patch

index f4bb87556cee715ec5267016d31249ef5081442d..e724bdf614cfab383ad79b08951ac36481c3fc3a 100644 (file)
@@ -7,10 +7,10 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=2017.09
+PKG_VERSION:=2018.03
 PKG_RELEASE:=1
 
-PKG_HASH:=b2d15f2cf5f72e706025cde73d67247c6da8cd35f7e10891eefe7d9095089744
+PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
index 10d8d4405c952bdff3c6c1c3d01a1f27ced9e32f..2ff916eb880bf8638edc22cd537b35d44bb540db 100644 (file)
@@ -23,8 +23,6 @@ Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it>
 NOTE: this patch is ready for upstream, LEDE-specific parts are in
       another patch
 
-diff --git a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
-index 9205b1e..819bd3b 100644
 --- a/arch/arm/mach-kirkwood/Kconfig
 +++ b/arch/arm/mach-kirkwood/Kconfig
 @@ -56,6 +56,9 @@ config TARGET_GOFLEXHOME
@@ -45,9 +43,6 @@ index 9205b1e..819bd3b 100644
  source "board/zyxel/nsa310s/Kconfig"
  
  endif
-diff --git a/board/zyxel/nsa310/Kconfig b/board/zyxel/nsa310/Kconfig
-new file mode 100644
-index 0000000..145ade6
 --- /dev/null
 +++ b/board/zyxel/nsa310/Kconfig
 @@ -0,0 +1,12 @@
@@ -63,9 +58,6 @@ index 0000000..145ade6
 +      default "nsa310"
 +
 +endif
-diff --git a/board/zyxel/nsa310/MAINTAINERS b/board/zyxel/nsa310/MAINTAINERS
-new file mode 100644
-index 0000000..d09f1ab
 --- /dev/null
 +++ b/board/zyxel/nsa310/MAINTAINERS
 @@ -0,0 +1,6 @@
@@ -75,9 +67,6 @@ index 0000000..d09f1ab
 +F:    board/zyxel/nsa310/
 +F:    include/configs/nsa310.h
 +F:    configs/nsa310_defconfig
-diff --git a/board/zyxel/nsa310/Makefile b/board/zyxel/nsa310/Makefile
-new file mode 100644
-index 0000000..dfe93cc
 --- /dev/null
 +++ b/board/zyxel/nsa310/Makefile
 @@ -0,0 +1,12 @@
@@ -93,9 +82,6 @@ index 0000000..dfe93cc
 +#
 +
 +obj-y := nsa310.o
-diff --git a/board/zyxel/nsa310/kwbimage.cfg b/board/zyxel/nsa310/kwbimage.cfg
-new file mode 100644
-index 0000000..f60e1d2
 --- /dev/null
 +++ b/board/zyxel/nsa310/kwbimage.cfg
 @@ -0,0 +1,166 @@
@@ -265,9 +251,6 @@ index 0000000..f60e1d2
 +
 +# End of Header extension
 +DATA 0x0 0x0
-diff --git a/board/zyxel/nsa310/nsa310.c b/board/zyxel/nsa310/nsa310.c
-new file mode 100644
-index 0000000..eee3f1a
 --- /dev/null
 +++ b/board/zyxel/nsa310/nsa310.c
 @@ -0,0 +1,190 @@
@@ -461,9 +444,6 @@ index 0000000..eee3f1a
 +      }
 +}
 +#endif
-diff --git a/board/zyxel/nsa310/nsa310.h b/board/zyxel/nsa310/nsa310.h
-new file mode 100644
-index 0000000..6634a4f
 --- /dev/null
 +++ b/board/zyxel/nsa310/nsa310.h
 @@ -0,0 +1,56 @@
@@ -501,19 +481,19 @@ index 0000000..6634a4f
 +/* GPIO's */
 +#define SYS_GREEN_LED         (1 << 28)
 +#define SYS_RED_LED           (1 << 29)
-+#define SATA1_GREEN_LED               (1 << 41)
-+#define SATA1_RED_LED         (1 << 42)
++#define SATA1_GREEN_LED               (1ULL << 41)
++#define SATA1_RED_LED         (1ULL << 42)
 +#define SATA2_GREEN_LED               (1 << 12)
 +#define SATA2_RED_LED         (1 << 13)
 +#define USB_GREEN_LED         (1 << 15)
 +#define USB_RED_LED           (1 << 21)
-+#define COPY_GREEN_LED                (1 << 39)
-+#define COPY_RED_LED          (1 << 40)
++#define COPY_GREEN_LED                (1ULL << 39)
++#define COPY_RED_LED          (1ULL << 40)
 +
 +#define NSA310_OE_LOW   (0)
 +#define NSA310_VAL_LOW    (SYS_GREEN_LED)
-+#define NSA310_OE_HIGH                ((COPY_GREEN_LED | COPY_RED_LED | \
-+                                   SATA1_GREEN_LED | SATA1_RED_LED))
++#define NSA310_OE_HIGH                (((COPY_GREEN_LED | COPY_RED_LED | \
++                                   SATA1_GREEN_LED | SATA1_RED_LED)) >> 32UL)
 +#define NSA310_VAL_HIGH               (0)
 +
 +/* PHY related */
@@ -523,14 +503,12 @@ index 0000000..6634a4f
 +#define MV88E1318_RGMII_RXTM_CTRL     (1 << 5)
 +
 +#endif /* __NSA310_H */
-diff --git a/configs/nsa310_defconfig b/configs/nsa310_defconfig
-new file mode 100644
-index 0000000..d26ef35
 --- /dev/null
 +++ b/configs/nsa310_defconfig
-@@ -0,0 +1,34 @@
+@@ -0,0 +1,37 @@
 +CONFIG_ARM=y
 +CONFIG_KIRKWOOD=y
++CONFIG_SYS_TEXT_BASE=0x600000
 +CONFIG_TARGET_NSA310=y
 +CONFIG_IDENT_STRING="\nZyXEL NSA310 1-Bay Power Media Server"
 +CONFIG_BOOTDELAY=3
@@ -552,6 +530,7 @@ index 0000000..d26ef35
 +CONFIG_CMD_EXT4=y
 +CONFIG_CMD_FAT=y
 +CONFIG_CMD_JFFS2=y
++CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0x0c0000(uboot),0x80000(uboot_env),0x7ec0000(ubi)"
 +CONFIG_CMD_MTDPARTS=y
 +CONFIG_CMD_ENV=y
 +CONFIG_CMD_NAND=y
@@ -563,12 +542,10 @@ index 0000000..d26ef35
 +CONFIG_USB_STORAGE=y
 +CONFIG_LZMA=y
 +CONFIG_LZO=y
-diff --git a/include/configs/nsa310.h b/include/configs/nsa310.h
-new file mode 100644
-index 0000000..86ef825
++CONFIG_SYS_LONGHELP=y
 --- /dev/null
 +++ b/include/configs/nsa310.h
-@@ -0,0 +1,126 @@
+@@ -0,0 +1,119 @@
 +/* Copyright (C) 2015-2016 bodhi <mibodhi@gmail.com>
 + *
 + * Based on
@@ -617,7 +594,6 @@ index 0000000..86ef825
 +/*
 + * Commands configuration
 + */
-+#define CONFIG_SYS_LONGHELP
 +#define CONFIG_PREBOOT
 +
 +/*
@@ -648,16 +624,10 @@ index 0000000..86ef825
 +      "ubi read 0x800000 kernel; " \
 +      "bootm 0x800000"
 +
-+#define CONFIG_MTDPARTS \
-+      "mtdparts=orion_nand:" \
-+      "0x0c0000(uboot)," \
-+      "0x80000(uboot_env)," \
-+      "0x7ec0000(ubi)\0"
-+
 +#define CONFIG_EXTRA_ENV_SETTINGS \
 +      "console=console=ttyS0,115200\0"        \
 +      "mtdids=nand0=orion_nand\0"             \
-+      "mtdparts="CONFIG_MTDPARTS              \
++      "mtdparts="CONFIG_MTDPARTS_DEFAULT      \
 +      "bootargs_root=\0"
 +
 +/*
index 4b4356e5d5e8ab6d5560413562355117061bc7a8..fd6dd6fa36e5790ba5cc9261b9d9838d41215c73 100644 (file)
@@ -1,5 +1,3 @@
-diff --git a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
-index 819bd3b..6a2d578 100644
 --- a/arch/arm/mach-kirkwood/Kconfig
 +++ b/arch/arm/mach-kirkwood/Kconfig
 @@ -62,6 +62,9 @@ config TARGET_NSA310
@@ -19,9 +17,6 @@ index 819bd3b..6a2d578 100644
 +source "board/zyxel/nsa325/Kconfig"
  
  endif
-diff --git a/board/zyxel/nsa325/Kconfig b/board/zyxel/nsa325/Kconfig
-new file mode 100644
-index 0000000..1fe5ead
 --- /dev/null
 +++ b/board/zyxel/nsa325/Kconfig
 @@ -0,0 +1,12 @@
@@ -37,9 +32,6 @@ index 0000000..1fe5ead
 +      default "nsa325"
 +
 +endif
-diff --git a/board/zyxel/nsa325/MAINTAINERS b/board/zyxel/nsa325/MAINTAINERS
-new file mode 100644
-index 0000000..130b4d9
 --- /dev/null
 +++ b/board/zyxel/nsa325/MAINTAINERS
 @@ -0,0 +1,6 @@
@@ -49,9 +41,6 @@ index 0000000..130b4d9
 +F:    board/zyxel/nsa325/
 +F:    include/configs/nsa325.h
 +F:    configs/nsa325_defconfig
-diff --git a/board/zyxel/nsa325/Makefile b/board/zyxel/nsa325/Makefile
-new file mode 100644
-index 0000000..4ee953b
 --- /dev/null
 +++ b/board/zyxel/nsa325/Makefile
 @@ -0,0 +1,13 @@
@@ -68,9 +57,6 @@ index 0000000..4ee953b
 +
 +obj-y := nsa325.o
 +
-diff --git a/board/zyxel/nsa325/kwbimage.cfg b/board/zyxel/nsa325/kwbimage.cfg
-new file mode 100644
-index 0000000..5a27d38
 --- /dev/null
 +++ b/board/zyxel/nsa325/kwbimage.cfg
 @@ -0,0 +1,78 @@
@@ -152,9 +138,6 @@ index 0000000..5a27d38
 +# End of Header extension
 +DATA 0x0 0x0
 +
-diff --git a/board/zyxel/nsa325/nsa325.c b/board/zyxel/nsa325/nsa325.c
-new file mode 100644
-index 0000000..4cd1c0f
 --- /dev/null
 +++ b/board/zyxel/nsa325/nsa325.c
 @@ -0,0 +1,265 @@
@@ -423,9 +406,6 @@ index 0000000..4cd1c0f
 +
 +#endif
 +
-diff --git a/board/zyxel/nsa325/nsa325.h b/board/zyxel/nsa325/nsa325.h
-new file mode 100644
-index 0000000..996653e
 --- /dev/null
 +++ b/board/zyxel/nsa325/nsa325.h
 @@ -0,0 +1,77 @@
@@ -506,14 +486,12 @@ index 0000000..996653e
 +#define BTN_COPY                              37
 +
 +#endif /* __NSA325_H */
-diff --git a/configs/nsa325_defconfig b/configs/nsa325_defconfig
-new file mode 100644
-index 0000000..48e09cc
 --- /dev/null
 +++ b/configs/nsa325_defconfig
-@@ -0,0 +1,34 @@
+@@ -0,0 +1,37 @@
 +CONFIG_ARM=y
 +CONFIG_KIRKWOOD=y
++CONFIG_SYS_TEXT_BASE=0x600000
 +CONFIG_TARGET_NSA325=y
 +CONFIG_IDENT_STRING="\nZyXEL NSA325 2-Bay Power Media Server"
 +CONFIG_BOOTDELAY=3
@@ -536,6 +514,7 @@ index 0000000..48e09cc
 +CONFIG_CMD_EXT4=y
 +CONFIG_CMD_FAT=y
 +CONFIG_CMD_JFFS2=y
++CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0x0c0000(uboot),0x80000(uboot_env),0x7ec0000(ubi)"
 +CONFIG_CMD_MTDPARTS=y
 +CONFIG_CMD_ENV=y
 +CONFIG_CMD_NAND=y
@@ -546,12 +525,10 @@ index 0000000..48e09cc
 +CONFIG_USB_STORAGE=y
 +CONFIG_LZMA=y
 +CONFIG_LZO=y
-diff --git a/include/configs/nsa325.h b/include/configs/nsa325.h
-new file mode 100644
-index 0000000..e5a8e2a
++CONFIG_SYS_LONGHELP=y
 --- /dev/null
 +++ b/include/configs/nsa325.h
-@@ -0,0 +1,129 @@
+@@ -0,0 +1,122 @@
 +/*
 + * (C) Copyright 2016 bodhi <mibodhi@gmail.com>
 + *
@@ -603,7 +580,6 @@ index 0000000..e5a8e2a
 +/*
 + * Commands configuration
 + */
-+#define CONFIG_SYS_LONGHELP
 +#define CONFIG_PREBOOT
 +
 +/*
@@ -634,16 +610,10 @@ index 0000000..e5a8e2a
 +      "ubi read 0x800000 kernel; " \
 +      "bootm 0x800000"
 +
-+#define CONFIG_MTDPARTS \
-+      "mtdparts=orion_nand:" \
-+      "0x0c0000(uboot)," \
-+      "0x80000(uboot_env)," \
-+      "0x7ec0000(ubi)\0"
-+
 +#define CONFIG_EXTRA_ENV_SETTINGS \
 +      "console=console=ttyS0,115200\0"        \
 +      "mtdids=nand0=orion_nand\0"             \
-+      "mtdparts="CONFIG_MTDPARTS              \
++      "mtdparts="CONFIG_MTDPARTS_DEFAULT      \
 +      "bootargs_root=\0"
 +
 +/*
index d2daf0b66f4ffef53f797f754f0199957c44d3dc..50551bad6a042b3ceebd8fabebcd72ac89ba9834 100644 (file)
@@ -3,13 +3,13 @@
 @@ -25,6 +25,9 @@ config TARGET_LSXL
  config TARGET_POGO_E02
        bool "pogo_e02 Board"
-
 +config TARGET_POGOPLUGV4
 +    bool "Pogoplug V4 Board"
 +
  config TARGET_DNS325
        bool "dns325 Board"
-
 @@ -77,6 +80,7 @@ source "board/Marvell/guruplug/Kconfig"
  source "board/Marvell/sheevaplug/Kconfig"
  source "board/buffalo/lsxl/Kconfig"
  source "board/d-link/dns325/Kconfig"
  source "board/iomega/iconnect/Kconfig"
  source "board/keymile/km_arm/Kconfig"
---- a/arch/arm/mach-kirkwood/include/mach/config.h
-+++ b/arch/arm/mach-kirkwood/include/mach/config.h
-@@ -77,6 +77,7 @@
-  * Ethernet Driver configuration
-  */
- #ifdef CONFIG_CMD_NET
-+#define CONFIG_FEATURE_COMMAND_EDITING
- #define CONFIG_NETCONSOLE     /* include NetConsole support   */
- #define CONFIG_MII            /* expose smi ove miiphy interface */
- #define CONFIG_MVGBE          /* Enable Marvell Gbe Controller Driver */
-@@ -110,6 +111,7 @@
- #define CONFIG_SYS_ATA_STRIDE         4
- /* Controller supports 48-bits LBA addressing */
- #define CONFIG_LBA48
-+#define CONFIG_SYS_64BIT_LBA
- /* CONFIG_IDE requires some #defines for ATA registers */
- #define CONFIG_SYS_IDE_MAXBUS         2
- #define CONFIG_SYS_IDE_MAXDEVICE      2
-@@ -134,4 +136,15 @@
- #define CONFIG_SYS_TIMER_COUNTER      (MVEBU_TIMER_BASE + 0x14)
- #define CONFIG_SYS_TIMER_RATE         CONFIG_SYS_TCLK
-
-+/*
-+ * Boot option
-+ */
-+#define CONFIG_CMD_BOOTZ
-+
-+/*
-+ * GPIO
-+ */
-+#define CONFIG_CMD_GPIO
-+#define CONFIG_KIRKWOOD_GPIO
-+
- #endif /* _KW_CONFIG_H */
 --- a/arch/arm/mach-kirkwood/include/mach/kw88f6192.h
 +++ b/arch/arm/mach-kirkwood/include/mach/kw88f6192.h
 @@ -16,6 +16,6 @@
  #define KW_REGS_PHY_BASE              KW88F6192_REGS_PHYS_BASE
-
  /* TCLK Core Clock defination */
 -#define CONFIG_SYS_TCLK         166000000 /* 166MHz */
 +#define CONFIG_SYS_TCLK         166666667 /* 166MHz */
-
  #endif /* _CONFIG_KW88F6192_H */
 --- a/arch/arm/mach-kirkwood/include/mach/mpp.h
 +++ b/arch/arm/mach-kirkwood/include/mach/mpp.h
  #define MPP33_TDM_DTX         MPP( 33, 0x2, 0, 1, 0,   0,   1,   1    )
  #define MPP33_GE1_13          MPP( 33, 0x3, 0, 0, 0,   1,   1,   1    )
 +#define MPP33_SATA1_ACTn        MPP( 33, 0x5, 0, 1, 0,   1,   1,   1    )
-
  #define MPP34_GPIO            MPP( 34, 0x0, 1, 1, 0,   1,   1,   1    )
  #define MPP34_TDM_SPI_CS1     MPP( 34, 0x2, 0, 1, 0,   0,   1,   1    )
  #define MPP34_GE1_14          MPP( 34, 0x3, 0, 0, 0,   1,   1,   1    )
 +#define MPP34_SATA1_ACTn       MPP( 34, 0x5, 0, 1, 0,   1,   1,   1    )
-
  #define MPP35_GPIO            MPP( 35, 0x0, 1, 1, 1,   1,   1,   1    )
  #define MPP35_TDM_CH0_TX_QL   MPP( 35, 0x2, 0, 1, 0,   0,   1,   1    )
---- a/arch/arm/mach-mvebu/include/mach/soc.h
-+++ b/arch/arm/mach-mvebu/include/mach/soc.h
-@@ -18,6 +18,8 @@
- #define SOC_88F6810_ID                0x6810
- #define SOC_88F6820_ID                0x6820
- #define SOC_88F6828_ID                0x6828
-+#define SOC_88F6192_ID                0x6192
-+#define SOC_88F6702_ID                0x6702
-
- /* A375 revisions */
- #define MV_88F67XX_A0_ID      0x3
 --- /dev/null
 +++ b/board/cloudengines/pogoplugv4/Kconfig
 @@ -0,0 +1,12 @@
 +#endif /* __POGOPLUGV4_H */
 --- /dev/null
 +++ b/configs/pogoplugv4_defconfig
-@@ -0,0 +1,35 @@
+@@ -0,0 +1,40 @@
 +CONFIG_ARM=y
 +CONFIG_KIRKWOOD=y
++CONFIG_SYS_TEXT_BASE=0x600000
 +CONFIG_TARGET_POGOPLUGV4=y
 +CONFIG_SYS_PROMPT="pogoplugv4> "
 +CONFIG_IDENT_STRING="\nPogoplug V4"
 +CONFIG_SYS_NS16550=y
 +CONFIG_CMD_FDT=y
 +CONFIG_OF_LIBFDT=y
++CONFIG_OF_BOOTZ=y
 +CONFIG_CMD_SETEXPR=y
 +CONFIG_CMD_DHCP=y
 +CONFIG_CMD_MII=y
 +CONFIG_CMD_EXT4=y
 +CONFIG_CMD_FAT=y
 +CONFIG_CMD_JFFS2=y
++CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0x1c0000(uboot),0x40000(uboot_env),0x7e00000(ubi)"
 +CONFIG_CMD_MTDPARTS=y
 +CONFIG_CMD_ENV=y
 +CONFIG_CMD_NAND=y
 +CONFIG_CMD_MMC=y
++CONFIG_CMD_GPIO=y
 +CONFIG_EFI_PARTITION=y
 +CONFIG_ENV_IS_IN_NAND=y
 +CONFIG_CMD_UBI=y
 +CONFIG_USB_STORAGE=y
 +CONFIG_LZMA=y
 +CONFIG_LZO=y
++CONFIG_SYS_LONGHELP=y
 --- a/drivers/gpio/kw_gpio.c
 +++ b/drivers/gpio/kw_gpio.c
 @@ -148,3 +148,36 @@ void kw_gpio_set_blink(unsigned pin, int
  obj-$(CONFIG_MMC_SDHCI_XENON)         += xenon_sdhci.o
  obj-$(CONFIG_MMC_SDHCI_ZYNQ)          += zynq_sdhci.o
 +obj-$(CONFIG_KIRKWOOD_MMC)            += kirkwood_mmc.o
-
  obj-$(CONFIG_MMC_SUNXI)                       += sunxi_mmc.o
  obj-$(CONFIG_MMC_UNIPHIER)            += uniphier-sd.o
 --- /dev/null
 +}
 --- a/include/configs/mv-common.h
 +++ b/include/configs/mv-common.h
-@@ -130,4 +130,16 @@
+@@ -117,4 +117,10 @@
  #define CONFIG_MTD_PARTITIONS
  #endif
-
 +/*
 + * Kirkwood MMC
 + */
 +#if defined(CONFIG_KIRKWOOD) && defined(CONFIG_CMD_MMC)
 +#define CONFIG_SYS_MMC_BASE KW_SDIO_BASE
 +#endif /* defined(CONFIG_KIRKWOOD) && defined(CONFIG_CMD_MMC) */
-+
-+/*
-+ * GPIO command for all Kirkwood boxes
-+ */
-+#define CONFIG_CMD_GPIO
-+
  #endif /* _MV_COMMON_H */
 --- /dev/null
 +++ b/include/configs/pogoplugv4.h
-@@ -0,0 +1,132 @@
+@@ -0,0 +1,129 @@
 +/*
 + * Copyright (C) 2014-2016 bodhi <mibodhi@gmail.com>
 + * Based on
 +#define CONFIG_KW88F6192              /* SOC Name */
 +#define CONFIG_SKIP_LOWLEVEL_INIT     /* disable board lowlevel_init */
 +
++#define CONFIG_FEATURE_COMMAND_EDITING
++#define CONFIG_SYS_64BIT_LBA
++
 +/*
 + * Commands configuration
 + */
 +
-+#define CONFIG_SYS_LONGHELP
++#define CONFIG_KIRKWOOD_GPIO
 +#define CONFIG_PREBOOT
 +
 +/*
 +      "ubi read 0x800000 kernel; " \
 +      "bootm 0x800000"
 +
-+#define CONFIG_MTDPARTS \
-+      "mtdparts=orion_nand:" \
-+      "0x1c0000(uboot)," \
-+      "0x40000(uboot_env)," \
-+      "0x7e00000(ubi)\0"
-+
 +#define CONFIG_EXTRA_ENV_SETTINGS \
 +      "console=console=ttyS0,115200\0"        \
 +      "mtdids=nand0=orion_nand\0"             \
-+      "mtdparts="CONFIG_MTDPARTS              \
++      "mtdparts="CONFIG_MTDPARTS_DEFAULT      \
 +      "bootargs_root=\0"
 +
 +/*
index 94d62cee82b90a96ca98388f22f7948d641d60a9..43dce1a0d3fe09831955211eba2e6036cd57a110 100644 (file)
@@ -1,14 +1,14 @@
 --- a/include/configs/dockstar.h
 +++ b/include/configs/dockstar.h
-@@ -19,6 +19,7 @@
+@@ -18,6 +18,7 @@
+ #define CONFIG_FEROCEON_88FR131       1       /* CPU Core subversion */
  #define CONFIG_KW88F6281      1       /* SOC Name */
- #define CONFIG_MACH_DOCKSTAR  /* Machine type */
  #define CONFIG_SKIP_LOWLEVEL_INIT     /* disable board lowlevel_init */
 +#define CONFIG_SYS_MVFS
  
  /*
   * mv-common.h should be defined after CMD configs since it used them
-@@ -37,29 +38,29 @@
+@@ -36,27 +37,22 @@
   * it has to be rounded to sector size
   */
  #define CONFIG_ENV_SIZE                       0x20000 /* 128k */
 -      "ubifsload 0x800000 ${kernel}; " \
 -      "ubifsload 0x1100000 ${initrd}; " \
 -      "bootm 0x800000 0x1100000"
--
--#define CONFIG_MTDPARTS               "mtdparts=orion_nand:1m(uboot),-(root)\0"
 +      "ubi part ubi; " \
 +      "ubi read 0x800000 kernel; " \
 +      "bootm 0x800000"
-+
-+#define CONFIG_MTDPARTS \
-+      "mtdparts=orion_nand:"                          \
-+      "0xe0000@0x0(uboot),"                           \
-+      "0x20000@0xe0000(uboot_env),"                   \
-+      "0x100000@0x100000(second_stage_uboot),"        \
-+      "-@0x200000(ubi)\0"
  
  #define CONFIG_EXTRA_ENV_SETTINGS \
 -      "console=console=ttyS0,115200\0" \
 -      "mtdids=nand0=orion_nand\0" \
--      "mtdparts="CONFIG_MTDPARTS \
+-      "mtdparts="CONFIG_MTDPARTS_DEFAULT \
 -      "kernel=/boot/uImage\0" \
 -      "initrd=/boot/uInitrd\0" \
 -      "bootargs_root=ubi.mtd=1 root=ubi0:root rootfstype=ubifs ro\0"
 +      "console=console=ttyS0,115200\0"        \
 +      "mtdids=nand0=orion_nand\0"             \
-+      "mtdparts="CONFIG_MTDPARTS              \
++      "mtdparts="CONFIG_MTDPARTS_DEFAULT      \
 +      "bootargs_root=\0"
  
  /*
   * Ethernet Driver configuration
+--- a/configs/dockstar_defconfig
++++ b/configs/dockstar_defconfig
+@@ -16,7 +16,7 @@ CONFIG_CMD_PING=y
+ CONFIG_CMD_EXT2=y
+ CONFIG_CMD_FAT=y
+ CONFIG_CMD_JFFS2=y
+-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:1m(uboot),-(root)"
++CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
+ CONFIG_CMD_UBI=y
+ CONFIG_ISO_PARTITION=y
+ CONFIG_ENV_IS_IN_NAND=y
index bd1dab818f602847f91b1a3d3d0b810f324dc0fd..d2e89115e8879a43fb8b55d939d25a36aa121f6e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/configs/iconnect.h
 +++ b/include/configs/iconnect.h
-@@ -44,30 +44,29 @@
+@@ -44,24 +44,22 @@
  #define CONFIG_ENV_SECT_SIZE  0x20000
  #endif
  #define CONFIG_ENV_SIZE               0x20000
 +      "ubi read 0x800000 kernel; " \
        "bootm 0x800000"
  
- #define CONFIG_MTDPARTS \
--      "mtdparts=orion_nand:"          \
--      "0x80000@0x0(uboot),"           \
--      "0x20000@0x80000(uboot_env),"   \
--      "-@0xa0000(rootfs)\0"
-+      "mtdparts=orion_nand:"                          \
-+      "0xe0000@0x0(uboot),"                           \
-+      "0x20000@0xe0000(uboot_env),"                   \
-+      "0x100000@0x100000(second_stage_uboot),"        \
-+      "-@0x200000(ubi)\0"
  #define CONFIG_EXTRA_ENV_SETTINGS \
        "console=console=ttyS0,115200\0"        \
        "mtdids=nand0=orion_nand\0"             \
-       "mtdparts="CONFIG_MTDPARTS              \
+       "mtdparts="CONFIG_MTDPARTS_DEFAULT      \
 -      "kernel=/boot/uImage\0"                 \
 -      "bootargs_root=noinitrd ubi.mtd=2 root=ubi0:rootfs rootfstype=ubifs\0"
 +      "bootargs_root=\0"
@@ -42,7 +31,7 @@
   * Ethernet driver configuration
 --- a/configs/iconnect_defconfig
 +++ b/configs/iconnect_defconfig
-@@ -10,6 +10,7 @@ CONFIG_SYS_PROMPT="iconnect => "
+@@ -10,12 +10,13 @@ CONFIG_SYS_PROMPT="iconnect => "
  CONFIG_CMD_NAND=y
  CONFIG_CMD_USB=y
  # CONFIG_CMD_SETEXPR is not set
  CONFIG_CMD_MII=y
  CONFIG_CMD_PING=y
  CONFIG_CMD_EXT2=y
+ CONFIG_CMD_FAT=y
+ CONFIG_CMD_JFFS2=y
+-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0x80000@0x0(uboot),0x20000@0x80000(uboot_env),-@0xa0000(rootfs)"
++CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
+ CONFIG_CMD_UBI=y
+ CONFIG_ISO_PARTITION=y
+ CONFIG_ENV_IS_IN_NAND=y
index 58db8c8c8dc23abe551272d23fc26a46a2f7583f..ec0792c58f00ed6bc447d497a11a05b3c8b0ed54 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/configs/ib62x0.h
 +++ b/include/configs/ib62x0.h
-@@ -49,27 +49,22 @@
+@@ -49,21 +49,15 @@
   */
  #define CONFIG_BOOTCOMMAND \
        "setenv bootargs ${console} ${mtdparts} ${bootargs_root}; "     \
 +      "ubi read 0x800000 kernel; " \
 +      "bootm 0x800000"
  
- #define CONFIG_MTDPARTS \
-       "mtdparts=orion_nand:"                                          \
-       "0xe0000@0x0(uboot),"                                           \
-       "0x20000@0xe0000(uboot_env),"                                   \
--      "-@0x100000(root)\0"
-+      "0x100000@0x100000(second_stage_uboot),"                        \
-+      "-@0x200000(ubi)\0"
  #define CONFIG_EXTRA_ENV_SETTINGS \
        "console=console=ttyS0,115200\0"                                \
        "mtdids=nand0=orion_nand\0"                                     \
-       "mtdparts="CONFIG_MTDPARTS                                      \
+       "mtdparts="CONFIG_MTDPARTS_DEFAULT                      \
 -      "kernel=/boot/zImage\0"                                         \
 -      "fdt=/boot/ib62x0.dtb\0"                                        \
 -      "bootargs_root=ubi.mtd=2 root=ubi0:rootfs rootfstype=ubifs rw\0"
  
  /*
   * Ethernet driver configuration
+--- a/configs/ib62x0_defconfig
++++ b/configs/ib62x0_defconfig
+@@ -19,7 +19,7 @@ CONFIG_CMD_PING=y
+ CONFIG_CMD_EXT2=y
+ CONFIG_CMD_FAT=y
+ CONFIG_CMD_JFFS2=y
+-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),-@0x100000(root)"
++CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
+ CONFIG_CMD_UBI=y
+ CONFIG_ISO_PARTITION=y
+ CONFIG_ENV_IS_IN_NAND=y
index 5c8ff35bee239bcdab1ce9642e9bf7d7a3cd1aad..34379f261755f48df1c61e0003d59ad281abf790 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/configs/pogo_e02.h
 +++ b/include/configs/pogo_e02.h
-@@ -44,23 +44,30 @@
+@@ -44,23 +44,23 @@
  #endif
  
  #define CONFIG_ENV_SIZE                       0x20000 /* 128k */
 -      "setenv bootargs $(bootargs_console); " \
 -      "run bootcmd_usb; " \
 -      "bootm 0x00800000 0x01100000"
-+      "setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
++      "setenv bootargs ${console} ${mtdparts} ${bootargs_root}; "     \
 +      "ubi part ubi; "                                                \
 +      "ubifsmount ubi:rootfs; "                                       \
 +      "ubi read 0x800000 kernel; "                                    \
 +      "bootm 0x800000"
-+
-+#define CONFIG_MTDPARTS \
-+      "mtdparts=orion_nand:" \
-+      "0xe0000@0x0(uboot)," \
-+      "0x20000@0xe0000(uboot_env)," \
-+      "0x100000@0x100000(second_stage_uboot)," \
-+      "-@0x200000(ubi)\0"
  
  #define CONFIG_EXTRA_ENV_SETTINGS \
 -      "mtdparts=mtdparts=orion_nand:1M(u-boot),4M(uImage)," \
 -      "ext2load usb 0:1 0x01100000 /uInitrd\0"
 +      "console=console=ttyS0,115200\0"        \
 +      "mtdids=nand0=orion_nand\0"             \
-+      "mtdparts="CONFIG_MTDPARTS              \
++      "mtdparts="CONFIG_MTDPARTS_DEFAULT      \
 +      "bootargs_root=\0"
  
  /*
   * Ethernet Driver configuration
+--- a/configs/pogo_e02_defconfig
++++ b/configs/pogo_e02_defconfig
+@@ -16,6 +16,7 @@ CONFIG_CMD_PING=y
+ CONFIG_CMD_EXT2=y
+ CONFIG_CMD_FAT=y
+ CONFIG_CMD_JFFS2=y
++CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0xe0000@0x0(uboot),0x20000@0xe0000(uboot_env),0x100000@0x100000(second_stage_uboot),-@0x200000(ubi)"
+ CONFIG_CMD_UBI=y
+ CONFIG_ISO_PARTITION=y
+ CONFIG_ENV_IS_IN_NAND=y
index 88b833072f27b08ece6dd6d51877d030774d26ee..186e33a0c4929c03bf15c34067062f1d066577c4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/configs/goflexhome.h
 +++ b/include/configs/goflexhome.h
-@@ -70,20 +70,18 @@
+@@ -69,17 +69,15 @@
   */
  #define CONFIG_BOOTCOMMAND \
        "setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
 +      "ubi read 0x800000 kernel; " \
        "bootm 0x800000"
  
- #define CONFIG_MTDPARTS \
--      "mtdparts=orion_nand:1m(uboot),6M(uImage),-(root)\0"
-+      "mtdparts=orion_nand:1m(uboot),255m(ubi)\0"
  #define CONFIG_EXTRA_ENV_SETTINGS \
        "console=console=ttyS0,115200\0" \
        "mtdids=nand0=orion_nand\0" \
-       "mtdparts="CONFIG_MTDPARTS \
+       "mtdparts="CONFIG_MTDPARTS_DEFAULT \
 -      "kernel=/boot/uImage\0" \
 -      "bootargs_root=ubi.mtd=root root=ubi0:root rootfstype=ubifs ro\0"
 +      "bootargs_root=\0"
  
  /*
   * Ethernet Driver configuration
+--- a/configs/goflexhome_defconfig
++++ b/configs/goflexhome_defconfig
+@@ -21,7 +21,7 @@ CONFIG_CMD_EXT4=y
+ CONFIG_CMD_FAT=y
+ CONFIG_CMD_JFFS2=y
+ CONFIG_MTDIDS_DEFAULT="nand0=orion_nand"
+-CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:1m(uboot),6M(uImage),-(root)"
++CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:1m(uboot),255m(ubi)"
+ CONFIG_CMD_UBI=y
+ CONFIG_ISO_PARTITION=y
+ CONFIG_ENV_IS_IN_NAND=y
index 04614f77cc0d29a94e0adab423f6b2f24ecf1f8f..6400e5bb699808d3deb723cdae69c117b0288be2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-kirkwood/Kconfig
 +++ b/arch/arm/mach-kirkwood/Kconfig
-@@ -90,4 +90,7 @@ source "board/zyxel/nsa310/Kconfig"
+@@ -94,4 +94,7 @@ source "board/zyxel/nsa310/Kconfig"
  source "board/zyxel/nsa310s/Kconfig"
  source "board/zyxel/nsa325/Kconfig"
  
@@ -10,7 +10,7 @@
  endif
 --- a/include/configs/dockstar.h
 +++ b/include/configs/dockstar.h
-@@ -76,4 +76,6 @@
+@@ -68,4 +68,6 @@
  #define CONFIG_MTD_DEVICE               /* needed for mtdparts commands */
  #define CONFIG_MTD_PARTITIONS
  
@@ -19,7 +19,7 @@
  #endif /* _CONFIG_DOCKSTAR_H */
 --- a/include/configs/ib62x0.h
 +++ b/include/configs/ib62x0.h
-@@ -94,4 +94,6 @@
+@@ -87,4 +87,6 @@
  #define CONFIG_RTC_MV
  #endif /* CONFIG_CMD_DATE */
  
@@ -28,7 +28,7 @@
  #endif /* _CONFIG_IB62x0_H */
 --- a/include/configs/iconnect.h
 +++ b/include/configs/iconnect.h
-@@ -83,4 +83,6 @@
+@@ -76,4 +76,6 @@
  #define CONFIG_MTD_DEVICE
  #define CONFIG_MTD_PARTITIONS
  
@@ -71,7 +71,7 @@
 +#endif /* __OPENWRT_KIRKWOOD_COMMON_H */
 --- a/include/configs/pogo_e02.h
 +++ b/include/configs/pogo_e02.h
-@@ -83,4 +83,6 @@
+@@ -76,4 +76,6 @@
  #define CONFIG_MTD_DEVICE               /* needed for mtdparts commands */
  #define CONFIG_MTD_PARTITIONS
  
@@ -80,7 +80,7 @@
  #endif /* _CONFIG_POGO_E02_H */
 --- a/include/configs/goflexhome.h
 +++ b/include/configs/goflexhome.h
-@@ -105,4 +105,6 @@
+@@ -101,4 +101,6 @@
  #define CONFIG_RTC_MV
  #endif /* CONFIG_CMD_DATE */
  
@@ -89,7 +89,7 @@
  #endif /* _CONFIG_GOFLEXHOME_H */
 --- a/include/configs/nsa310.h
 +++ b/include/configs/nsa310.h
-@@ -123,4 +123,6 @@
+@@ -116,4 +116,6 @@
  #define CONFIG_RTC_MV
  #endif /* CONFIG_CMD_DATE */
  
@@ -98,7 +98,7 @@
  #endif /* _CONFIG_NSA310_H */
 --- a/configs/dockstar_defconfig
 +++ b/configs/dockstar_defconfig
-@@ -25,3 +25,8 @@ CONFIG_USB=y
+@@ -26,3 +26,8 @@ CONFIG_USB=y
  CONFIG_USB_EHCI_HCD=y
  CONFIG_USB_STORAGE=y
  CONFIG_OF_LIBFDT=y
 +CONFIG_LZO=y
 --- a/configs/goflexhome_defconfig
 +++ b/configs/goflexhome_defconfig
-@@ -29,3 +29,8 @@ CONFIG_USB=y
+@@ -32,3 +32,8 @@ CONFIG_USB=y
  CONFIG_USB_EHCI_HCD=y
  CONFIG_USB_STORAGE=y
  CONFIG_OF_LIBFDT=y
 +CONFIG_LZO=y
 --- a/configs/ib62x0_defconfig
 +++ b/configs/ib62x0_defconfig
-@@ -27,5 +27,9 @@ CONFIG_SYS_NS16550=y
+@@ -29,5 +29,8 @@ CONFIG_SYS_NS16550=y
  CONFIG_USB=y
  CONFIG_USB_EHCI_HCD=y
  CONFIG_USB_STORAGE=y
 -CONFIG_LZMA=y
  CONFIG_OF_LIBFDT=y
-+CONFIG_CMD_BOOTZ=y
 +CONFIG_FIT=y
 +CONFIG_FIT_VERBOSE=y
 +CONFIG_LZMA=y
 +CONFIG_LZO=y
 --- a/configs/iconnect_defconfig
 +++ b/configs/iconnect_defconfig
-@@ -24,5 +24,9 @@ CONFIG_SYS_NS16550=y
+@@ -25,5 +25,9 @@ CONFIG_SYS_NS16550=y
  CONFIG_USB=y
  CONFIG_USB_EHCI_HCD=y
  CONFIG_USB_STORAGE=y
 +CONFIG_LZO=y
 --- a/configs/nsa310_defconfig
 +++ b/configs/nsa310_defconfig
-@@ -30,5 +30,8 @@ CONFIG_CMD_UBI=y
+@@ -32,6 +32,9 @@ CONFIG_CMD_UBI=y
  CONFIG_USB=y
  CONFIG_USB_EHCI_HCD=y
  CONFIG_USB_STORAGE=y
 +CONFIG_FIT_VERBOSE=y
  CONFIG_LZMA=y
  CONFIG_LZO=y
+ CONFIG_SYS_LONGHELP=y
 --- a/configs/pogo_e02_defconfig
 +++ b/configs/pogo_e02_defconfig
-@@ -25,3 +25,8 @@ CONFIG_USB=y
+@@ -26,3 +26,8 @@ CONFIG_USB=y
  CONFIG_USB_EHCI_HCD=y
  CONFIG_USB_STORAGE=y
  CONFIG_OF_LIBFDT=y