openssl: Pass in any TARGET_ASFLAGS
authorFlorian Fainelli <florian@openwrt.org>
Fri, 5 Apr 2013 12:36:09 +0000 (12:36 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 5 Apr 2013 12:36:09 +0000 (12:36 +0000)
Packages not picking up the regular TARGET_AS need their openwrt
Makefiles tweaked. For a basic build, that's just openssl.

This depends on patch 1/5.

Signed-off-by: Jay Carlson <nop@nop.com>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 36201

package/libs/openssl/Makefile

index a8b32570ff7829a4da7d788f0f5cc08da02bbd8f..049aad44a8cd9a8ee6d6740b9a9354a8b44b1234 100644 (file)
@@ -124,6 +124,7 @@ define Build/Compile
                depend
        $(_SINGLE)$(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
+               ASFLAGS="$(TARGET_ASFLAGS) -c" \
                AR="$(TARGET_CROSS)ar r" \
                RANLIB="$(TARGET_CROSS)ranlib" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
@@ -131,6 +132,7 @@ define Build/Compile
                all
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
+               ASFLAGS="$(TARGET_ASFLAGS) -c" \
                AR="$(TARGET_CROSS)ar r" \
                RANLIB="$(TARGET_CROSS)ranlib" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \