ath10k-firmware: package Wave1 from linux-firmware
authorDavid Bauer <mail@david-bauer.net>
Sun, 27 Sep 2020 08:11:11 +0000 (10:11 +0200)
committerDavid Bauer <mail@david-bauer.net>
Mon, 28 Sep 2020 14:23:33 +0000 (16:23 +0200)
The firmware for Wave1 chips was updated to the latest release
10.2.4-1.0-00047 at the end of 2019 (commit 513d70cc50b).
Package firmware for these chips from linux-firmware.

This avoids downloading the ath10k-firmware repository.

Signed-off-by: David Bauer <mail@david-bauer.net>
package/firmware/ath10k-firmware/Makefile
package/firmware/linux-firmware/qca_ath10k.mk

index c427f088426528487d839cb57e350708d0375f7e..52c974e9f8c61dff500036a316953654fe2c7d4f 100644 (file)
@@ -173,9 +173,9 @@ define Package/ath10k-firmware-qca9984/install
                $(1)/lib/firmware/ath10k/QCA9984/hw1.0/firmware-5.bin
 endef
 
-$(eval $(call BuildPackage,ath10k-firmware-qca9887))
+#$(eval $(call BuildPackage,ath10k-firmware-qca9887))
 #$(eval $(call BuildPackage,ath10k-firmware-qca9888))
-$(eval $(call BuildPackage,ath10k-firmware-qca988x))
+#$(eval $(call BuildPackage,ath10k-firmware-qca988x))
 #$(eval $(call BuildPackage,ath10k-firmware-qca99x0))
 #$(eval $(call BuildPackage,ath10k-firmware-qca6174))
 #$(eval $(call BuildPackage,ath10k-firmware-qca9984))
index 72735819fd16148f7fbd59309e4920475a719e23..a7c5b13b84e69fd8a9f0f38e9889c4f9539af007 100644 (file)
@@ -31,7 +31,7 @@ define Package/ath10k-firmware-qca9887/install
                $(PKG_BUILD_DIR)/ath10k/QCA9887/hw1.0/board.bin \
                $(1)/lib/firmware/ath10k/QCA9887/hw1.0/board.bin
 endef
-$(eval $(call BuildPackage,ath10k-firmware-qca9887))
+$(eval $(call BuildPackage,ath10k-firmware-qca9887))
 
 Package/ath10k-firmware-qca9888 = $(call Package/firmware-default,ath10k qca9888 firmware)
 define Package/ath10k-firmware-qca9888/install
@@ -55,7 +55,7 @@ define Package/ath10k-firmware-qca988x/install
                $(PKG_BUILD_DIR)/ath10k/QCA988X/hw2.0/firmware-5.bin \
                $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
 endef
-$(eval $(call BuildPackage,ath10k-firmware-qca988x))
+$(eval $(call BuildPackage,ath10k-firmware-qca988x))
 
 Package/ath10k-firmware-qca6174 = $(call Package/firmware-default,ath10k qca6174 firmware)
 define Package/ath10k-firmware-qca6174/install