add libvorbisidec package (thanks to David Collet)
authorNicolas Thill <nico@openwrt.org>
Mon, 17 Oct 2005 22:12:30 +0000 (22:12 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 17 Oct 2005 22:12:30 +0000 (22:12 +0000)
SVN-Revision: 2155

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/libvorbisidec/Config.in [new file with mode: 0644]
openwrt/package/libvorbisidec/Makefile [new file with mode: 0644]
openwrt/package/libvorbisidec/ipkg/libvorbisidec.control [new file with mode: 0644]

index 0734eab707388fb132c936c81136a8f5d5369ca1..e466dcd90ef5dc0016743fa0ee9cc6fd1e4de73d 100644 (file)
@@ -183,6 +183,7 @@ source "package/libtasn1/Config.in"
 source "package/libupnp/Config.in"
 source "package/libusb/Config.in"
 source "package/libvorbis/Config.in"
+source "package/libvorbisidec/Config.in"
 source "package/libxml2/Config.in"
 source "package/libxslt/Config.in"
 source "package/uclibc++/Config.in"
index 0e0e64e2911e786f0f218a94986fc155bbf4227e..2d02d3d7754daf9687440c9f680498277a093bd4 100644 (file)
@@ -94,6 +94,7 @@ package-$(BR2_PACKAGE_LIBTOOL) += libtool
 package-$(BR2_PACKAGE_LIBUPNP) += libupnp
 package-$(BR2_PACKAGE_LIBUSB) += libusb
 package-$(BR2_PACKAGE_LIBVORBIS) += libvorbis
+package-$(BR2_PACKAGE_LIBVORBISIDEC) += libvorbisidec
 package-$(BR2_PACKAGE_LIBXML2) += libxml2
 package-$(BR2_PACKAGE_LIBXSLT) += libxslt
 package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
diff --git a/openwrt/package/libvorbisidec/Config.in b/openwrt/package/libvorbisidec/Config.in
new file mode 100644 (file)
index 0000000..6532c71
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBVORBISIDEC
+       tristate "libvorbisidec - a fixed-point implementation (Tremor) of libogg/libvorbis"
+       default m if CONFIG_DEVEL
+       help
+         libvorbisidec is "tremor", a fixed-point implementation of libvorbis.
+         It also has libogg built-in. It is suitable as a replacement for 
+         libvorbis and libogg in tremor-aware applications.
+         Tremor is a decoder only.
+         
+         http://http://wiki.xiph.org/index.php/Tremor
+         
diff --git a/openwrt/package/libvorbisidec/Makefile b/openwrt/package/libvorbisidec/Makefile
new file mode 100644 (file)
index 0000000..6b78e74
--- /dev/null
@@ -0,0 +1,91 @@
+# $Id: Makefile,v 1.2 2005/10/07 17:05:47 nico Exp $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libvorbisidec
+PKG_VERSION:=1.2.0-dave
+PKG_RELEASE:=1
+PKG_MD5SUM:=cb8e51aab92ef164f8e0e8853f7164fa
+
+PKG_SOURCE_URL:=http://users.tpg.com.au/davico/openwrt/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBVORBISIDEC,libvorbisidec,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(strip $(TARGET_CFLAGS))" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --with-gnu-ld \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_LIBVORBISIDEC):
+       install -m0755 -d $(IDIR_LIBVORBISIDEC)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so.* $(IDIR_LIBVORBISIDEC)/usr/lib/
+       $(RSTRIP) $(IDIR_LIBVORBISIDEC)
+       $(IPKG_BUILD) $(IDIR_LIBVORBISIDEC) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/libvorbisidec.so: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/usr/include
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/tremor $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.a $(STAGING_DIR)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so* $(STAGING_DIR)/usr/lib/
+       touch $@
+
+install-dev: $(STAGING_DIR)/usr/lib/libvorbisidec.so
+
+uninstall-dev:
+       rm -rf \
+               $(STAGING_DIR)/usr/include/tremor \
+               $(STAGING_DIR)/usr/lib/libvorbisidec.a \
+               $(STAGING_DIR)/usr/lib/libvorbisidec.so* \
+
+compile: install-dev
+clean: uninstall-dev
+
+mostlyclean:
+       -$(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm -f $(PKG_BUILD_DIR)/.built
+
diff --git a/openwrt/package/libvorbisidec/ipkg/libvorbisidec.control b/openwrt/package/libvorbisidec/ipkg/libvorbisidec.control
new file mode 100644 (file)
index 0000000..a1e66fa
--- /dev/null
@@ -0,0 +1,8 @@
+Package: libvorbisidec
+Priority: optional
+Section: libs
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, David Collett <daveco@users.sourceforge.net>
+Source: buildroot internal
+Description: A fixed-point implementation (Tremor) of libogg/libvorbis"