ramips: fix Zbtlink ZBT-WR8305RT board name
authorJohn Crispin <john@openwrt.org>
Mon, 17 Aug 2015 05:57:41 +0000 (05:57 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 17 Aug 2015 05:57:41 +0000 (05:57 +0000)
There is another Zbtlink board (ZBT-WA05) supported in ramips target, so use the same naming scheme for ZBT-WR8305RT board and its dts file.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
SVN-Revision: 46614

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WR8305RT.dts [deleted file]
target/linux/ramips/dts/ZBT-WR8305RT.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index c6bfd7e7a89cabd25e9a1dc15ded2e8dfae46a5b..bb990c97edf5aa40998c0e4f1d8b62a1ea1e4ff0 100755 (executable)
@@ -245,10 +245,10 @@ case $board in
                ucidef_set_led_default "power" "power" "oy:green:power" "1"
                set_wifi_led "oy:green:wifi"
                ;;
-       wr8305rt)
-               ucidef_set_led_default "power" "power" "wr8305rt:sys" "1"
-               set_usb_led "wr8305rt:usb"
-               set_wifi_led "wr8305rt:wifi"
+       zbt-wr8305rt)
+               ucidef_set_led_default "power" "power" "zbt-wr8305rt:sys" "1"
+               set_usb_led "zbt-wr8305rt:usb"
+               set_wifi_led "zbt-wr8305rt:wifi"
                ;;
        wt1520)
                set_wifi_led "rt2800pci-phy0::radio"
index da1854a41566bb4a82a0707c06185759540c4488..42447d4d14150d811e6b3b5dfb5dcb18d6dbc64a 100755 (executable)
@@ -228,7 +228,7 @@ ramips_setup_interfaces()
                ucidef_add_switch_vlan "switch0" "2" "6t"
                ;;
 
-       wr8305rt)
+       zbt-wr8305rt)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "switch0" "1" "1"
                ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 4 6t"
index e63f0df079dcfd2979938dd77de79d9a19bc1ec9..019bbbb2a8e3e9c97069434928664a66741c1126 100644 (file)
@@ -196,8 +196,8 @@ get_status_led() {
        wr512-3gn)
                status_led="wr512:green:wps"
                ;;
-       wr8305rt)
-               status_led="wr8305rt:sys"
+       zbt-wr8305rt)
+               status_led="zbt-wr8305rt:sys"
                ;;
        whr-300hp2 | \
        whr-600d | \
index 7db6d370e865b458e2323e5c55067180955adf4b..436ed092e5f18c9995b86dd8b7f4ec994f359a2a 100755 (executable)
@@ -406,8 +406,8 @@ ramips_board_detect() {
        *"OY-0001")
                name="oy-0001"
                ;;
-       *"ZBT WR8305RT")
-               name="wr8305rt"
+       *"Zbtlink ZBT-WR8305RT")
+               name="zbt-wr8305rt"
                ;;
        *"ZTE Q7")
                name="zte-q7"
index 8221997a0a9955da18b96d38b1cd3d56437702cf..1021123693aae0e61acd89466041068fc675ad8c 100755 (executable)
@@ -116,7 +116,7 @@ platform_check_image() {
        wnce2001 | \
        wr512-3gn |\
        wr6202 |\
-       wr8305rt |\
+       zbt-wr8305rt |\
        wrtnode |\
        oy-0001 |\
        wt1520 |\
diff --git a/target/linux/ramips/dts/WR8305RT.dts b/target/linux/ramips/dts/WR8305RT.dts
deleted file mode 100644 (file)
index 1f3c345..0000000
+++ /dev/null
@@ -1,117 +0,0 @@
-/dts-v1/;
-
-/include/ "mt7620n.dtsi"
-
-/ {
-       compatible = "wr8305rt", "ralink,mt7620n-soc";
-       model = "ZBT WR8305RT";
-
-       palmbus@10000000 {
-               gpio1: gpio@638 {
-                       status = "okay";
-               };
-
-               gpio3: gpio@688 {
-                       status = "okay";
-               };
-
-               spi@b00 {
-                       status = "okay";
-
-                       m25p80@0 {
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               compatible = "mx25l6405d";
-                               reg = <0 0>;
-                               linux,modalias = "m25p80", "en25q64";
-                               spi-max-frequency = <10000000>;
-
-                               partition@0 {
-                                       label = "u-boot";
-                                       reg = <0x0 0x30000>;
-                                       read-only;
-                               };
-
-                               partition@30000 {
-                                       label = "u-boot-env";
-                                       reg = <0x30000 0x10000>;
-                                       read-only;
-                               };
-
-                               factory: partition@40000 {
-                                       label = "factory";
-                                       reg = <0x40000 0x10000>;
-                                       read-only;
-                               };
-
-                               partition@50000 {
-                                       label = "firmware";
-                                       reg = <0x50000 0x7b0000>;
-                               };
-                       };
-               };
-       };
-
-       ehci@101c0000 {
-               status = "okay";
-       };
-
-       ohci@101c1000 {
-               status = "okay";
-       };
-
-       ethernet@10100000 {
-               mtd-mac-address = <&factory 0x4>;
-               ralink,port-map = "llllw";
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       ephy {
-                               ralink,group = "ephy";
-                               ralink,function = "ephy";
-                       };
-
-                       default {
-                               ralink,group = "i2c", "uartf", "spi refclk", "wled";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               sys {
-                       label = "wr8305rt:sys";
-                       gpios = <&gpio1 14 1>;
-               };
-
-               lan {
-                       label = "wr8305rt:usb";
-                       gpios = <&gpio1 15 1>;
-               };
-
-               wifi {
-                       label = "wr8305rt:wifi";
-                       gpios = <&gpio3 0 1>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 1 1>;
-                       linux,code = <0x198>;
-               };
-       };
-};
diff --git a/target/linux/ramips/dts/ZBT-WR8305RT.dts b/target/linux/ramips/dts/ZBT-WR8305RT.dts
new file mode 100644 (file)
index 0000000..8c56c15
--- /dev/null
@@ -0,0 +1,117 @@
+/dts-v1/;
+
+/include/ "mt7620n.dtsi"
+
+/ {
+       compatible = "zbtlink,zbt-wr8305rt", "ralink,mt7620n-soc";
+       model = "Zbtlink ZBT-WR8305RT";
+
+       palmbus@10000000 {
+               gpio1: gpio@638 {
+                       status = "okay";
+               };
+
+               gpio3: gpio@688 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "mx25l6405d";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "en25q64";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+                       };
+               };
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "llllw";
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       ephy {
+                               ralink,group = "ephy";
+                               ralink,function = "ephy";
+                       };
+
+                       default {
+                               ralink,group = "i2c", "uartf", "spi refclk", "wled";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               sys {
+                       label = "zbt-wr8305rt:sys";
+                       gpios = <&gpio1 14 1>;
+               };
+
+               lan {
+                       label = "zbt-wr8305rt:usb";
+                       gpios = <&gpio1 15 1>;
+               };
+
+               wifi {
+                       label = "zbt-wr8305rt:wifi";
+                       gpios = <&gpio3 0 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
index 409ff265752bcfcd189aadebdb4a0d7d8577e4e0..6071ae72084d2986b5a5315476663e63332aca12 100644 (file)
@@ -876,12 +876,12 @@ Image/Build/Profile/MLW221=$(call BuildFirmware/Default16M/$(1),$(1),mlw221,MLW2
 Image/Build/Profile/MLWG2=$(call BuildFirmware/Default16M/$(1),$(1),mlwg2,MLWG2)
 Image/Build/Profile/WMR300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR300)
 Image/Build/Profile/RT-N14U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n14u,RT-N14U)
-Image/Build/Profile/WR8305RT=$(call BuildFirmware/Default8M/$(1),$(1),wr8305rt,WR8305RT)
 Image/Build/Profile/WRTNODE=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode,WRTNODE)
 Image/Build/Profile/WT3020=$(call BuildFirmware/PorayDualSize/$(1),$(1),wt3020,WT3020)
 Image/Build/Profile/XIAOMI-MIWIFI-MINI=$(call BuildFirmware/Default16M/$(1),$(1),xiaomi-miwifi-mini,XIAOMI-MIWIFI-MINI)
 Image/Build/Profile/ZTE-Q7=$(call BuildFirmware/Default8M/$(1),$(1),zte-q7,ZTE-Q7)
 Image/Build/Profile/ZBT-WA05=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wa05,ZBT-WA05)
+Image/Build/Profile/ZBT-WR8305RT=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wr8305rt,ZBT-WR8305RT)
 Image/Build/Profile/ArcherC20i=$(call BuildFirmware/Tplink/$(1),$(1),ArcherC20i,ArcherC20i)
 microwrt_mtd_size=16515072
 Image/Build/Profile/MicroWRT=$(call BuildFirmware/CustomFlash/$(1),$(1),microwrt,MicroWRT,$(microwrt_mtd_size))
@@ -910,12 +910,12 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/MLWG2,$(1))
        $(call Image/Build/Profile/WMR300,$(1))
        $(call Image/Build/Profile/RT-N14U,$(1))
-       $(call Image/Build/Profile/WR8305RT,$(1))
        $(call Image/Build/Profile/WRTNODE,$(1))
        $(call Image/Build/Profile/WT3020,$(1))
        $(call Image/Build/Profile/XIAOMI-MIWIFI-MINI,$(1))
        $(call Image/Build/Profile/ZTE-Q7,$(1))
        $(call Image/Build/Profile/ZBT-WA05,$(1))
+       $(call Image/Build/Profile/ZBT-WR8305RT,$(1))
        $(call Image/Build/Profile/ArcherC20i,$(1))
        $(call Image/Build/Profile/MicroWRT,$(1))
 endef