Final image build fixups
authorHamish Guthrie <hcg@openwrt.org>
Fri, 23 Mar 2007 10:24:01 +0000 (10:24 +0000)
committerHamish Guthrie <hcg@openwrt.org>
Fri, 23 Mar 2007 10:24:01 +0000 (10:24 +0000)
SVN-Revision: 6644

target/linux/at91-2.6/image/Makefile
target/linux/at91-2.6/image/u-boot/patches/008-ubparams_bugfix.patch [new file with mode: 0644]

index 8b1a9476d796dd08898d6247f69e76383c02e774..9a9948eaefe64ee3c86ce3d08b1352d68104659f 100644 (file)
@@ -17,13 +17,16 @@ define Build/Compile
        $(MAKE) -C romboot compile
 #      $(MAKE) -C u-boot configure
        $(MAKE) -C u-boot compile
        $(MAKE) -C romboot compile
 #      $(MAKE) -C u-boot configure
        $(MAKE) -C u-boot compile
+       $(KDIR)/u-boot-1.1.4/tools/ubparams
+       cp params $(KDIR)
 endef
 
 define Image/Prepare
   cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
        cp $(KDIR)/romboot/romboot.bin $(KDIR)/romboot.bin
        cp $(KDIR)/u-boot-1.1.4/u-boot.bin $(KDIR)/u-boot.bin
 endef
 
 define Image/Prepare
   cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
        cp $(KDIR)/romboot/romboot.bin $(KDIR)/romboot.bin
        cp $(KDIR)/u-boot-1.1.4/u-boot.bin $(KDIR)/u-boot.bin
-       cat $(KDIR)/romboot/romboot.block $(KDIR)/u-boot-1.1.4/u-boot.block > $(KDIR)/loaders.block
+       dd if=$(KDIR)/u-boot.bin of=$(KDIR)/u-boot.block bs=100k count=1 conv=sync
+       cat $(KDIR)/u-boot.block $(KDIR)/params > $(KDIR)/u-boot.full
 endef
 
 define Image/BuildKernel
 endef
 
 define Image/BuildKernel
@@ -31,6 +34,10 @@ define Image/BuildKernel
 endef
 
 define Image/Build
 endef
 
 define Image/Build
+       dd if=$(KDIR)/uImage of=$(KDIR)/uImage.block bs=1056k count=1 conv=sync
+       dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=1056k count=1 conv=sync
+       cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
+       $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/romboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
        $(call Image/Build/$(1),$(1))
 endef
 
        $(call Image/Build/$(1),$(1))
 endef
 
diff --git a/target/linux/at91-2.6/image/u-boot/patches/008-ubparams_bugfix.patch b/target/linux/at91-2.6/image/u-boot/patches/008-ubparams_bugfix.patch
new file mode 100644 (file)
index 0000000..9a16e19
--- /dev/null
@@ -0,0 +1,10 @@
+--- u-boot-1.1.4.old/tools/ubparams.c  2007-03-23 10:51:17.000000000 +0100
++++ u-boot-1.1.4/tools/ubparams.c      2007-03-23 10:49:37.000000000 +0100
+@@ -73,6 +73,7 @@
+       fclose(params);
+       free(envptr);
++      return 0;
+       }
+       
+