kernel: bump 4.9 to 4.9.67
authorStijn Tintel <stijn@linux-ipv6.be>
Wed, 6 Dec 2017 22:51:31 +0000 (23:51 +0100)
committerStijn Tintel <stijn@linux-ipv6.be>
Wed, 6 Dec 2017 23:41:09 +0000 (01:41 +0200)
Refresh patches.
Remove upstreamed patches:
- generic/190-1-5-e1000e-Fix-error-path-in-link-detection.patch
- generic/190-3-5-e1000e-Fix-return-value-test.patch
- generic/190-4-5-e1000e-Separate-signaling-for-link-check-link-up.patch
- generic/190-5-5-e1000e-Avoid-receiver-overrun-interrupt-bursts.patch
- ramips/0102-MIPS-ralink-Fix-MT7628-pinmux.patch
- ramips/0103-MIPS-ralink-Fix-typo-in-mt7628-pinmux-function
Update patches that no longer apply:
- layerscape/815-spi-support-layerscape.patch
- ramips/0099-pci-mt7620.patch

Compile-tested on ar71xx, brcm2708/bcm2708, octeon and x86/64.
Runtime-tested on ar71xx, brcm2708/bcm2708, octeon and x86/64.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
24 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/432-spi-rb4xx-spi-driver.patch
target/linux/ar71xx/patches-4.9/433-spi-rb4xx-cpld-driver.patch
target/linux/ar71xx/patches-4.9/435-spi-vsc7385_driver.patch
target/linux/cns3xxx/patches-4.9/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch
target/linux/generic/hack-4.9/904-debloat_dma_buf.patch
target/linux/generic/pending-4.9/190-1-5-e1000e-Fix-error-path-in-link-detection.patch [deleted file]
target/linux/generic/pending-4.9/190-2-5-e1000e-Fix-wrong-comment-related-to-link-detection.patch
target/linux/generic/pending-4.9/190-3-5-e1000e-Fix-return-value-test.patch [deleted file]
target/linux/generic/pending-4.9/190-4-5-e1000e-Separate-signaling-for-link-check-link-up.patch [deleted file]
target/linux/generic/pending-4.9/190-5-5-e1000e-Avoid-receiver-overrun-interrupt-bursts.patch [deleted file]
target/linux/generic/pending-4.9/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/ipq806x/patches-4.9/0016-clk-ipq4019-report-accurate-fixed-clock-rates.patch
target/linux/lantiq/patches-4.9/0090-spi-lantiq-ssc-add-support-for-Lantiq-SSC-SPI-contro.patch
target/linux/layerscape/patches-4.9/301-arch-support-layerscape.patch
target/linux/layerscape/patches-4.9/815-spi-support-layerscape.patch
target/linux/pistachio/patches-4.9/411-mtd-nand-Check-length-of-ID-before-reading-bits-per-.patch
target/linux/ramips/patches-4.9/0040-nand-hack.patch
target/linux/ramips/patches-4.9/0042-SPI-ralink-add-Ralink-SoC-spi-driver.patch
target/linux/ramips/patches-4.9/0043-spi-add-mt7621-support.patch
target/linux/ramips/patches-4.9/0099-pci-mt7620.patch
target/linux/ramips/patches-4.9/0102-MIPS-ralink-Fix-MT7628-pinmux.patch [deleted file]
target/linux/ramips/patches-4.9/0103-MIPS-ralink-Fix-typo-in-mt7628-pinmux-function [deleted file]
target/linux/ramips/patches-4.9/0901-spansion_nand_id_fix.patch

index 8fb560ec49bcecb3940ae59bcf91f0e58fdfbfeb..f1fb66a36c33815b2adb2c48727ce7c077ac5c7f 100644 (file)
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .100
-LINUX_VERSION-4.9 = .65
+LINUX_VERSION-4.9 = .67
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.100 = 9936cd99c4bd35f6bc6962c9acdd1fa2ac8999e07a9be6a94a03b5492f1bd14f
-LINUX_KERNEL_HASH-4.9.65 = 24ba70877549a3cf25dc5f12efd260d3e957bce64c087de98baf8968ee514895
+LINUX_KERNEL_HASH-4.9.67 = 7fbaa7dcc17877dfa0c96fb9a7d2f4ffed20ceeb13cbbeb18d77213c6cf75f7d
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index e896d0bdf4b77ebfc097de4fb1afdc7a0ff70c21..5428d3d1c2e57c23edd46c1ad6d07f5b34ec11e2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -533,6 +533,12 @@ config SPI_QUP
+@@ -534,6 +534,12 @@ config SPI_QUP
          This driver can also be built as a module.  If so, the module
          will be called spi_qup.
  
index c44acab32ef2fc7cce6960872f0364244bb3a9e4..b1cd6a545b5f1560f93342a9a9aea325b1b9a09c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -761,6 +761,13 @@ config SPI_TLE62X0
+@@ -762,6 +762,13 @@ config SPI_TLE62X0
          sysfs interface, with each line presented as a kind of GPIO
          exposing both switch control and diagnostic feedback.
  
index f9f1f7a1e5bc2789f1747979bc09e785295ce284..fe6acde70a9896f5639017e572424565a106784d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -768,6 +768,11 @@ config SPI_RB4XX_CPLD
+@@ -769,6 +769,11 @@ config SPI_RB4XX_CPLD
          SPI driver for the Xilinx CPLD chip present on the
          MikroTik RB4xx boards.
  
index 3e28b7e3cd043763d66ecf33487d7e2a2064c1de..15c59ce9549732b789892bb76411a79ca942ae3b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/pci/probe.c
 +++ b/drivers/pci/probe.c
-@@ -2003,7 +2003,8 @@ static void pcie_write_mrrs(struct pci_d
+@@ -2014,7 +2014,8 @@ static void pcie_write_mrrs(struct pci_d
        /* In the "safe" case, do not configure the MRRS.  There appear to be
         * issues with setting MRRS to 0 on a number of devices.
         */
index b9a5c1dca265dedda5876421cf7d636fccc372c5..4f432c3568ecc5f1a416df9898b7a9b3b0f8f224 100644 (file)
@@ -54,7 +54,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +MODULE_LICENSE("GPL");
 --- a/kernel/sched/core.c
 +++ b/kernel/sched/core.c
-@@ -2171,6 +2171,7 @@ int wake_up_state(struct task_struct *p,
+@@ -2170,6 +2170,7 @@ int wake_up_state(struct task_struct *p,
  {
        return try_to_wake_up(p, state, 0);
  }
diff --git a/target/linux/generic/pending-4.9/190-1-5-e1000e-Fix-error-path-in-link-detection.patch b/target/linux/generic/pending-4.9/190-1-5-e1000e-Fix-error-path-in-link-detection.patch
deleted file mode 100644 (file)
index 8ed91db..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-From patchwork Fri Jul 21 18:36:23 2017
-Content-Type: text/plain; charset="utf-8"
-MIME-Version: 1.0
-Content-Transfer-Encoding: 7bit
-Subject: [1/5] e1000e: Fix error path in link detection
-From: Benjamin Poirier <bpoirier@suse.com>
-X-Patchwork-Id: 9857487
-Message-Id: <20170721183627.13373-1-bpoirier@suse.com>
-To: Jeff Kirsher <jeffrey.t.kirsher@intel.com>
-Cc: Lennart Sorensen <lsorense@csclub.uwaterloo.ca>,
- intel-wired-lan@lists.osuosl.org, netdev@vger.kernel.org,
- linux-kernel@vger.kernel.org
-Date: Fri, 21 Jul 2017 11:36:23 -0700
-
-In case of error from e1e_rphy(), the loop will exit early and "success"
-will be set to true erroneously.
-
-Signed-off-by: Benjamin Poirier <bpoirier@suse.com>
----
- drivers/net/ethernet/intel/e1000e/phy.c | 7 ++++---
- 1 file changed, 4 insertions(+), 3 deletions(-)
-
---- a/drivers/net/ethernet/intel/e1000e/phy.c
-+++ b/drivers/net/ethernet/intel/e1000e/phy.c
-@@ -1744,6 +1744,7 @@ s32 e1000e_phy_has_link_generic(struct e
-       s32 ret_val = 0;
-       u16 i, phy_status;
-+      *success = false;
-       for (i = 0; i < iterations; i++) {
-               /* Some PHYs require the MII_BMSR register to be read
-                * twice due to the link bit being sticky.  No harm doing
-@@ -1763,16 +1764,16 @@ s32 e1000e_phy_has_link_generic(struct e
-               ret_val = e1e_rphy(hw, MII_BMSR, &phy_status);
-               if (ret_val)
-                       break;
--              if (phy_status & BMSR_LSTATUS)
-+              if (phy_status & BMSR_LSTATUS) {
-+                      *success = true;
-                       break;
-+              }
-               if (usec_interval >= 1000)
-                       msleep(usec_interval / 1000);
-               else
-                       udelay(usec_interval);
-       }
--      *success = (i < iterations);
--
-       return ret_val;
- }
index b3291dbd6f54edda808ea0f2cc550e163e2ee4ec..f980bb080de0df17f37c8b187c406f4bab52bf39 100644 (file)
@@ -23,7 +23,7 @@ Tested-by: Aaron Brown <aaron.f.brown@intel.com>
 
 --- a/drivers/net/ethernet/intel/e1000e/netdev.c
 +++ b/drivers/net/ethernet/intel/e1000e/netdev.c
-@@ -5049,7 +5049,7 @@ static bool e1000e_has_link(struct e1000
+@@ -5066,7 +5066,7 @@ static bool e1000e_has_link(struct e1000
  
        /* get_link_status is set on LSC (link status) interrupt or
         * Rx sequence error interrupt.  get_link_status will stay
@@ -32,7 +32,7 @@ Tested-by: Aaron Brown <aaron.f.brown@intel.com>
         * for copper adapters ONLY
         */
        switch (hw->phy.media_type) {
-@@ -5067,7 +5067,7 @@ static bool e1000e_has_link(struct e1000
+@@ -5084,7 +5084,7 @@ static bool e1000e_has_link(struct e1000
                break;
        case e1000_media_type_internal_serdes:
                ret_val = hw->mac.ops.check_for_link(hw);
diff --git a/target/linux/generic/pending-4.9/190-3-5-e1000e-Fix-return-value-test.patch b/target/linux/generic/pending-4.9/190-3-5-e1000e-Fix-return-value-test.patch
deleted file mode 100644 (file)
index a777138..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From patchwork Fri Jul 21 18:36:25 2017
-Content-Type: text/plain; charset="utf-8"
-MIME-Version: 1.0
-Content-Transfer-Encoding: 7bit
-Subject: [3/5] e1000e: Fix return value test
-From: Benjamin Poirier <bpoirier@suse.com>
-X-Patchwork-Id: 9857495
-Message-Id: <20170721183627.13373-3-bpoirier@suse.com>
-To: Jeff Kirsher <jeffrey.t.kirsher@intel.com>
-Cc: Lennart Sorensen <lsorense@csclub.uwaterloo.ca>,
- intel-wired-lan@lists.osuosl.org, netdev@vger.kernel.org,
- linux-kernel@vger.kernel.org
-Date: Fri, 21 Jul 2017 11:36:25 -0700
-
-All the helpers return -E1000_ERR_PHY.
-
-Signed-off-by: Benjamin Poirier <bpoirier@suse.com>
----
- drivers/net/ethernet/intel/e1000e/netdev.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/drivers/net/ethernet/intel/e1000e/netdev.c
-+++ b/drivers/net/ethernet/intel/e1000e/netdev.c
-@@ -5074,7 +5074,7 @@ static bool e1000e_has_link(struct e1000
-               break;
-       }
--      if ((ret_val == E1000_ERR_PHY) && (hw->phy.type == e1000_phy_igp_3) &&
-+      if ((ret_val == -E1000_ERR_PHY) && (hw->phy.type == e1000_phy_igp_3) &&
-           (er32(CTRL) & E1000_PHY_CTRL_GBE_DISABLE)) {
-               /* See e1000_kmrn_lock_loss_workaround_ich8lan() */
-               e_info("Gigabit has been disabled, downgrading speed\n");
diff --git a/target/linux/generic/pending-4.9/190-4-5-e1000e-Separate-signaling-for-link-check-link-up.patch b/target/linux/generic/pending-4.9/190-4-5-e1000e-Separate-signaling-for-link-check-link-up.patch
deleted file mode 100644 (file)
index cc2cf73..0000000
+++ /dev/null
@@ -1,90 +0,0 @@
-From patchwork Fri Jul 21 18:36:26 2017
-Content-Type: text/plain; charset="utf-8"
-MIME-Version: 1.0
-Content-Transfer-Encoding: 7bit
-Subject: [4/5] e1000e: Separate signaling for link check/link up
-From: Benjamin Poirier <bpoirier@suse.com>
-X-Patchwork-Id: 9857491
-Message-Id: <20170721183627.13373-4-bpoirier@suse.com>
-To: Jeff Kirsher <jeffrey.t.kirsher@intel.com>
-Cc: Lennart Sorensen <lsorense@csclub.uwaterloo.ca>,
- intel-wired-lan@lists.osuosl.org, netdev@vger.kernel.org,
- linux-kernel@vger.kernel.org
-Date: Fri, 21 Jul 2017 11:36:26 -0700
-
-Lennart reported the following race condition:
-
-\ e1000_watchdog_task
-    \ e1000e_has_link
-        \ hw->mac.ops.check_for_link() === e1000e_check_for_copper_link
-            /* link is up */
-            mac->get_link_status = false;
-
-                            /* interrupt */
-                            \ e1000_msix_other
-                                hw->mac.get_link_status = true;
-
-        link_active = !hw->mac.get_link_status
-        /* link_active is false, wrongly */
-
-This problem arises because the single flag get_link_status is used to
-signal two different states: link status needs checking and link status is
-down.
-
-Avoid the problem by using the return value of .check_for_link to signal
-the link status to e1000e_has_link().
-
-Reported-by: Lennart Sorensen <lsorense@csclub.uwaterloo.ca>
-Signed-off-by: Benjamin Poirier <bpoirier@suse.com>
----
- drivers/net/ethernet/intel/e1000e/mac.c    | 11 ++++++++---
- drivers/net/ethernet/intel/e1000e/netdev.c |  2 +-
- 2 files changed, 9 insertions(+), 4 deletions(-)
-
---- a/drivers/net/ethernet/intel/e1000e/mac.c
-+++ b/drivers/net/ethernet/intel/e1000e/mac.c
-@@ -410,6 +410,9 @@ void e1000e_clear_hw_cntrs_base(struct e
-  *  Checks to see of the link status of the hardware has changed.  If a
-  *  change in link status has been detected, then we read the PHY registers
-  *  to get the current speed/duplex if link exists.
-+ *
-+ *  Returns a negative error code (-E1000_ERR_*) or 0 (link down) or 1 (link
-+ *  up).
-  **/
- s32 e1000e_check_for_copper_link(struct e1000_hw *hw)
- {
-@@ -423,7 +426,7 @@ s32 e1000e_check_for_copper_link(struct
-        * Change or Rx Sequence Error interrupt.
-        */
-       if (!mac->get_link_status)
--              return 0;
-+              return 1;
-       /* First we want to see if the MII Status Register reports
-        * link.  If so, then we want to get the current speed/duplex
-@@ -461,10 +464,12 @@ s32 e1000e_check_for_copper_link(struct
-        * different link partner.
-        */
-       ret_val = e1000e_config_fc_after_link_up(hw);
--      if (ret_val)
-+      if (ret_val) {
-               e_dbg("Error configuring flow control\n");
-+              return ret_val;
-+      }
--      return ret_val;
-+      return 1;
- }
- /**
---- a/drivers/net/ethernet/intel/e1000e/netdev.c
-+++ b/drivers/net/ethernet/intel/e1000e/netdev.c
-@@ -5056,7 +5056,7 @@ static bool e1000e_has_link(struct e1000
-       case e1000_media_type_copper:
-               if (hw->mac.get_link_status) {
-                       ret_val = hw->mac.ops.check_for_link(hw);
--                      link_active = !hw->mac.get_link_status;
-+                      link_active = ret_val > 0;
-               } else {
-                       link_active = true;
-               }
diff --git a/target/linux/generic/pending-4.9/190-5-5-e1000e-Avoid-receiver-overrun-interrupt-bursts.patch b/target/linux/generic/pending-4.9/190-5-5-e1000e-Avoid-receiver-overrun-interrupt-bursts.patch
deleted file mode 100644 (file)
index b42fed2..0000000
+++ /dev/null
@@ -1,109 +0,0 @@
-From patchwork Fri Jul 21 18:36:27 2017
-Content-Type: text/plain; charset="utf-8"
-MIME-Version: 1.0
-Content-Transfer-Encoding: 7bit
-Subject: [5/5] e1000e: Avoid receiver overrun interrupt bursts
-From: Benjamin Poirier <bpoirier@suse.com>
-X-Patchwork-Id: 9857493
-Message-Id: <20170721183627.13373-5-bpoirier@suse.com>
-To: Jeff Kirsher <jeffrey.t.kirsher@intel.com>
-Cc: Lennart Sorensen <lsorense@csclub.uwaterloo.ca>,
- intel-wired-lan@lists.osuosl.org, netdev@vger.kernel.org,
- linux-kernel@vger.kernel.org
-Date: Fri, 21 Jul 2017 11:36:27 -0700
-
-When e1000e_poll() is not fast enough to keep up with incoming traffic, the
-adapter (when operating in msix mode) raises the Other interrupt to signal
-Receiver Overrun.
-
-This is a double problem because 1) at the moment e1000_msix_other()
-assumes that it is only called in case of Link Status Change and 2) if the
-condition persists, the interrupt is repeatedly raised again in quick
-succession.
-
-Ideally we would configure the Other interrupt to not be raised in case of
-receiver overrun but this doesn't seem possible on this adapter. Instead,
-we handle the first part of the problem by reverting to the practice of
-reading ICR in the other interrupt handler, like before commit 16ecba59bc33
-("e1000e: Do not read ICR in Other interrupt"). Thanks to commit
-0a8047ac68e5 ("e1000e: Fix msi-x interrupt automask") which cleared IAME
-from CTRL_EXT, reading ICR doesn't interfere with RxQ0, TxQ0 interrupts
-anymore. We handle the second part of the problem by not re-enabling the
-Other interrupt right away when there is overrun. Instead, we wait until
-traffic subsides, napi polling mode is exited and interrupts are
-re-enabled.
-
-Reported-by: Lennart Sorensen <lsorense@csclub.uwaterloo.ca>
-Fixes: 16ecba59bc33 ("e1000e: Do not read ICR in Other interrupt")
-Signed-off-by: Benjamin Poirier <bpoirier@suse.com>
----
- drivers/net/ethernet/intel/e1000e/defines.h |  1 +
- drivers/net/ethernet/intel/e1000e/netdev.c  | 33 +++++++++++++++++++++++------
- 2 files changed, 27 insertions(+), 7 deletions(-)
-
---- a/drivers/net/ethernet/intel/e1000e/defines.h
-+++ b/drivers/net/ethernet/intel/e1000e/defines.h
-@@ -398,6 +398,7 @@
- #define E1000_ICR_LSC           0x00000004 /* Link Status Change */
- #define E1000_ICR_RXSEQ         0x00000008 /* Rx sequence error */
- #define E1000_ICR_RXDMT0        0x00000010 /* Rx desc min. threshold (0) */
-+#define E1000_ICR_RXO           0x00000040 /* Receiver Overrun */
- #define E1000_ICR_RXT0          0x00000080 /* Rx timer intr (ring 0) */
- #define E1000_ICR_ECCER         0x00400000 /* Uncorrectable ECC Error */
- /* If this bit asserted, the driver should claim the interrupt */
---- a/drivers/net/ethernet/intel/e1000e/netdev.c
-+++ b/drivers/net/ethernet/intel/e1000e/netdev.c
-@@ -1905,12 +1905,30 @@ static irqreturn_t e1000_msix_other(int
-       struct net_device *netdev = data;
-       struct e1000_adapter *adapter = netdev_priv(netdev);
-       struct e1000_hw *hw = &adapter->hw;
-+      u32 icr;
-+      bool enable = true;
--      hw->mac.get_link_status = true;
-+      icr = er32(ICR);
-+      if (icr & E1000_ICR_RXO) {
-+              ew32(ICR, E1000_ICR_RXO);
-+              enable = false;
-+              /* napi poll will re-enable Other, make sure it runs */
-+              if (napi_schedule_prep(&adapter->napi)) {
-+                      adapter->total_rx_bytes = 0;
-+                      adapter->total_rx_packets = 0;
-+                      __napi_schedule(&adapter->napi);
-+              }
-+      }
-+      if (icr & E1000_ICR_LSC) {
-+              ew32(ICR, E1000_ICR_LSC);
-+              hw->mac.get_link_status = true;
-+              /* guard against interrupt when we're going down */
-+              if (!test_bit(__E1000_DOWN, &adapter->state)) {
-+                      mod_timer(&adapter->watchdog_timer, jiffies + 1);
-+              }
-+      }
--      /* guard against interrupt when we're going down */
--      if (!test_bit(__E1000_DOWN, &adapter->state)) {
--              mod_timer(&adapter->watchdog_timer, jiffies + 1);
-+      if (enable && !test_bit(__E1000_DOWN, &adapter->state)) {
-               ew32(IMS, E1000_IMS_OTHER);
-       }
-@@ -2683,7 +2701,8 @@ static int e1000e_poll(struct napi_struc
-               napi_complete_done(napi, work_done);
-               if (!test_bit(__E1000_DOWN, &adapter->state)) {
-                       if (adapter->msix_entries)
--                              ew32(IMS, adapter->rx_ring->ims_val);
-+                              ew32(IMS, adapter->rx_ring->ims_val |
-+                                   E1000_IMS_OTHER);
-                       else
-                               e1000_irq_enable(adapter);
-               }
-@@ -4178,7 +4197,7 @@ static void e1000e_trigger_lsc(struct e1
-       struct e1000_hw *hw = &adapter->hw;
-       if (adapter->msix_entries)
--              ew32(ICS, E1000_ICS_OTHER);
-+              ew32(ICS, E1000_ICS_LSC | E1000_ICS_OTHER);
-       else
-               ew32(ICS, E1000_ICS_LSC);
- }
index 3b09bffa157b8b74e9219bf88bfb45a0f42f9bec..e9c247fad008d97e4ca4ea4189d7c481b3e7b1d6 100644 (file)
@@ -200,7 +200,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
-@@ -3714,6 +3753,17 @@ static int __net_init ip6_route_net_init
+@@ -3718,6 +3757,17 @@ static int __net_init ip6_route_net_init
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
@@ -218,7 +218,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
  
        net->ipv6.sysctl.flush_delay = 0;
-@@ -3732,6 +3782,8 @@ out:
+@@ -3736,6 +3786,8 @@ out:
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -227,7 +227,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
-@@ -3749,6 +3801,7 @@ static void __net_exit ip6_route_net_exi
+@@ -3753,6 +3805,7 @@ static void __net_exit ip6_route_net_exi
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
        kfree(net->ipv6.ip6_blk_hole_entry);
@@ -235,7 +235,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
  }
-@@ -3822,6 +3875,9 @@ void __init ip6_route_init_special_entri
+@@ -3826,6 +3879,9 @@ void __init ip6_route_init_special_entri
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
index 6f7665390dfa6687d2ef792baa3adbd6fffc42b6..be9c4eb1b2f45b423470a1ed8b4a2252ee4353f6 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Matthew McClintock <mmcclint@qca.qualcomm.com>
 
 --- a/drivers/clk/qcom/gcc-ipq4019.c
 +++ b/drivers/clk/qcom/gcc-ipq4019.c
-@@ -1317,12 +1317,12 @@ static int gcc_ipq4019_probe(struct plat
+@@ -1327,12 +1327,12 @@ static int gcc_ipq4019_probe(struct plat
  {
        struct device *dev = &pdev->dev;
  
index da48ae3a189e805780d8c47a1998bfa02fad60f9..64597cec870804a2d07761e716748f97fad428a7 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 +};
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -403,6 +403,14 @@ config SPI_NUC900
+@@ -404,6 +404,14 @@ config SPI_NUC900
        help
          SPI driver for Nuvoton NUC900 series ARM SoCs
  
index 66860a0bb62f8aa7a0112dca0eaabd24d38d8637..7216933b7c74cf62f059720df97fc67a9318de51 100644 (file)
@@ -310,7 +310,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  #define PROT_SECT_NORMAL      (PROT_SECT_DEFAULT | PMD_SECT_PXN | PMD_SECT_UXN | PMD_ATTRINDX(MT_NORMAL))
 --- a/arch/arm64/include/asm/pgtable.h
 +++ b/arch/arm64/include/asm/pgtable.h
-@@ -356,6 +356,11 @@ static inline int pmd_protnone(pmd_t pmd
+@@ -370,6 +370,11 @@ static inline int pmd_protnone(pmd_t pmd
        __pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_DEVICE_nGnRnE) | PTE_PXN | PTE_UXN)
  #define pgprot_writecombine(prot) \
        __pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_NORMAL_NC) | PTE_PXN | PTE_UXN)
index b9c531651853292e840e8a905e6dd72ae9e1bd19..761680913b8d0bde61d8e13ac87267bf9138e80f 100644 (file)
@@ -15,16 +15,6 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  drivers/spi/spi-fsl-dspi.c | 309 ++++++++++++++++++++++++++++++++++++++++++++-
  2 files changed, 305 insertions(+), 5 deletions(-)
 
---- a/drivers/spi/Kconfig
-+++ b/drivers/spi/Kconfig
-@@ -365,6 +365,7 @@ config SPI_FSL_SPI
- config SPI_FSL_DSPI
-       tristate "Freescale DSPI controller"
-       select REGMAP_MMIO
-+      depends on HAS_DMA
-       depends on SOC_VF610 || SOC_LS1021A || ARCH_LAYERSCAPE || COMPILE_TEST
-       help
-         This enables support for the Freescale DSPI controller in master
 --- a/drivers/spi/spi-fsl-dspi.c
 +++ b/drivers/spi/spi-fsl-dspi.c
 @@ -15,6 +15,8 @@
index 69d96932b6569407e9b674cf860a1b837d301417..f360613f9f245fcad548a9d0ed11ae7b3295389e 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Ezequiel Garcia <ezequiel.garcia@imgtec.com>
 
 --- a/drivers/mtd/nand/nand_base.c
 +++ b/drivers/mtd/nand/nand_base.c
-@@ -4040,7 +4040,8 @@ static bool find_full_id_nand(struct mtd
+@@ -4043,7 +4043,8 @@ static bool find_full_id_nand(struct mtd
                mtd->erasesize = type->erasesize;
                mtd->oobsize = type->oobsize;
  
index fe2b12d2ceb713d73e9167a143c1e83154874351..e0bd5f6026e7bdcb7cf337970d3ec8ce76bc6c86 100644 (file)
@@ -18,7 +18,7 @@
                        if (ret < 0) {
                                if (use_bufpoi)
                                        /* Invalidate page cache */
-@@ -3203,8 +3207,11 @@ int nand_erase_nand(struct mtd_info *mtd
+@@ -3206,8 +3210,11 @@ int nand_erase_nand(struct mtd_info *mtd
                    (page + pages_per_block))
                        chip->pagebuf = -1;
  
@@ -31,7 +31,7 @@
                /*
                 * See if operation failed and additional status checks are
                 * available
-@@ -4398,6 +4405,7 @@ int nand_scan_ident(struct mtd_info *mtd
+@@ -4401,6 +4408,7 @@ int nand_scan_ident(struct mtd_info *mtd
                 * cmdfunc() both expect cmd_ctrl() to be populated,
                 * so we need to check that that's the case
                 */
index 0288b97556cb1ec95616622ed1e9676b7f40d91a..3150dd8382f5f65e9f475c3596c54df546cdc7d7 100644 (file)
@@ -16,7 +16,7 @@ Acked-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -533,6 +533,12 @@ config SPI_QUP
+@@ -534,6 +534,12 @@ config SPI_QUP
          This driver can also be built as a module.  If so, the module
          will be called spi_qup.
  
index 339dc5a87dc45ab224c51424bc64e807b531a6ca..984f4ada9ee98138a5bfe497e0f88182d1f29424 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -539,6 +539,12 @@ config SPI_RT2880
+@@ -540,6 +540,12 @@ config SPI_RT2880
        help
          This selects a driver for the Ralink RT288x/RT305x SPI Controller.
  
index f532f30db8129de2df71f69e24e0cfd42bbaca42..997fb6a2b3b8aabde442e7009c8c62aeb26e62ba 100644 (file)
@@ -8,12 +8,3 @@
  
  #define PPLL_DRV                      0xa0
  #define PDRV_SW_SET                   (1<<31)
-@@ -121,7 +120,7 @@ static int wait_pciephy_busy(void)
-               else
-                       break;
-               if (retry++ > WAITRETRY_MAX) {
--                      printk(KERN_WARN "PCIE-PHY retry failed.\n");
-+                      pr_warn("PCIE-PHY retry failed.\n");
-                       return -1;
-               }
-       }
diff --git a/target/linux/ramips/patches-4.9/0102-MIPS-ralink-Fix-MT7628-pinmux.patch b/target/linux/ramips/patches-4.9/0102-MIPS-ralink-Fix-MT7628-pinmux.patch
deleted file mode 100644 (file)
index f2d1ab1..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From 8ef4b43cd3794d63052d85898e42424fd3b14d24 Mon Sep 17 00:00:00 2001
-From: Mathias Kresin <dev@kresin.me>
-Date: Thu, 11 May 2017 08:11:14 +0200
-Subject: [PATCH 1/2] MIPS: ralink: Fix MT7628 pinmux
-
-According to the datasheet the REFCLK pin is shared with GPIO#37 and
-the PERST pin is shared with GPIO#36.
-
-Fixes: 53263a1c6852 ("MIPS: ralink: add mt7628an support")
-Signed-off-by: Mathias Kresin <dev@kresin.me>
-Acked-by: John Crispin <john@phrozen.org>
-Cc: Ralf Baechle <ralf@linux-mips.org>
-Cc: linux-mips@linux-mips.org
-Cc: <stable@vger.kernel.org> # 3.19+
-Patchwork: https://patchwork.linux-mips.org/patch/16046/
-Signed-off-by: James Hogan <jhogan@kernel.org>
----
- arch/mips/ralink/mt7620.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/arch/mips/ralink/mt7620.c
-+++ b/arch/mips/ralink/mt7620.c
-@@ -141,8 +141,8 @@ static struct rt2880_pmx_func i2c_grp_mt
-       FUNC("i2c", 0, 4, 2),
- };
--static struct rt2880_pmx_func refclk_grp_mt7628[] = { FUNC("reclk", 0, 36, 1) };
--static struct rt2880_pmx_func perst_grp_mt7628[] = { FUNC("perst", 0, 37, 1) };
-+static struct rt2880_pmx_func refclk_grp_mt7628[] = { FUNC("reclk", 0, 37, 1) };
-+static struct rt2880_pmx_func perst_grp_mt7628[] = { FUNC("perst", 0, 36, 1) };
- static struct rt2880_pmx_func wdt_grp_mt7628[] = { FUNC("wdt", 0, 38, 1) };
- static struct rt2880_pmx_func spi_grp_mt7628[] = { FUNC("spi", 0, 7, 4) };
diff --git a/target/linux/ramips/patches-4.9/0103-MIPS-ralink-Fix-typo-in-mt7628-pinmux-function b/target/linux/ramips/patches-4.9/0103-MIPS-ralink-Fix-typo-in-mt7628-pinmux-function
deleted file mode 100644 (file)
index 9c77840..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 05a67cc258e75ac9758e6f13d26337b8be51162a Mon Sep 17 00:00:00 2001
-From: Mathias Kresin <dev@kresin.me>
-Date: Thu, 11 May 2017 08:11:15 +0200
-Subject: [PATCH 2/2] MIPS: ralink: Fix typo in mt7628 pinmux function
-
-There is a typo inside the pinmux setup code. The function is called
-refclk and not reclk.
-
-Fixes: 53263a1c6852 ("MIPS: ralink: add mt7628an support")
-Signed-off-by: Mathias Kresin <dev@kresin.me>
-Acked-by: John Crispin <john@phrozen.org>
-Cc: Ralf Baechle <ralf@linux-mips.org>
-Cc: linux-mips@linux-mips.org
-Cc: <stable@vger.kernel.org> # 3.19+
-Patchwork: https://patchwork.linux-mips.org/patch/16047/
-Signed-off-by: James Hogan <jhogan@kernel.org>
----
- arch/mips/ralink/mt7620.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/mips/ralink/mt7620.c
-+++ b/arch/mips/ralink/mt7620.c
-@@ -141,7 +141,7 @@ static struct rt2880_pmx_func i2c_grp_mt
-       FUNC("i2c", 0, 4, 2),
- };
--static struct rt2880_pmx_func refclk_grp_mt7628[] = { FUNC("reclk", 0, 37, 1) };
-+static struct rt2880_pmx_func refclk_grp_mt7628[] = { FUNC("refclk", 0, 37, 1) };
- static struct rt2880_pmx_func perst_grp_mt7628[] = { FUNC("perst", 0, 36, 1) };
- static struct rt2880_pmx_func wdt_grp_mt7628[] = { FUNC("wdt", 0, 38, 1) };
- static struct rt2880_pmx_func spi_grp_mt7628[] = { FUNC("spi", 0, 7, 4) };
index 4edc7416a7154eb5440601cb0d78e40336ecf282..daaa0aca652b802484b1fe56909636e7251adc26 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com>
 
 --- a/drivers/mtd/nand/nand_base.c
 +++ b/drivers/mtd/nand/nand_base.c
-@@ -3850,6 +3850,7 @@ static void nand_decode_ext_id(struct mt
+@@ -3853,6 +3853,7 @@ static void nand_decode_ext_id(struct mt
        /*
         * Field definitions are in the following datasheets:
         * Old style (4,5 byte ID): Samsung K9GAG08U0M (p.32)
@@ -21,7 +21,7 @@ Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com>
         * New Samsung (6 byte ID): Samsung K9GAG08U0F (p.44)
         * Hynix MLC   (6 byte ID): Hynix H27UBG8T2B (p.22)
         *
-@@ -3947,6 +3948,19 @@ static void nand_decode_ext_id(struct mt
+@@ -3950,6 +3951,19 @@ static void nand_decode_ext_id(struct mt
                *busw = (extid & 0x01) ? NAND_BUSWIDTH_16 : 0;
  
                /*