ath79: add tiny subtarget
authorAlex Maclean <monkeh@monkeh.net>
Wed, 30 May 2018 13:18:50 +0000 (14:18 +0100)
committerJohn Crispin <john@phrozen.org>
Fri, 1 Jun 2018 06:22:38 +0000 (08:22 +0200)
Signed-off-by: Alex Maclean <monkeh@monkeh.net>
target/linux/ath79/Makefile
target/linux/ath79/image/Makefile
target/linux/ath79/image/common-tp-link.mk [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk
target/linux/ath79/image/tiny-tp-link.mk [new file with mode: 0644]
target/linux/ath79/tiny/config-default [new file with mode: 0644]
target/linux/ath79/tiny/profiles/00-default.mk [new file with mode: 0644]
target/linux/ath79/tiny/target.mk [new file with mode: 0644]

index e331cb421002274a1160804351e24281c3e1f426..6add24a72a94b723f0752856d49079e9c51b5f95 100644 (file)
@@ -4,7 +4,7 @@ ARCH:=mips
 BOARD:=ath79
 BOARDNAME:=Atheros ATH79 (DTS)
 CPU_TYPE:=24kc
-SUBTARGETS:=generic
+SUBTARGETS:=generic tiny
 
 FEATURES:=ramdisk source-only
 
index 792548657ed71bf53053aa6e08fe35927bffe087..cd136b23b9ba0365dcf6a0185bdb2997ccad77a5 100644 (file)
@@ -70,4 +70,7 @@ include ./generic.mk
 include ./generic-tp-link.mk
 include ./generic-ubnt.mk
 endif
+ifeq ($(SUBTARGET),tiny)
+include ./tiny-tp-link.mk
+endif
 $(eval $(call BuildImage))
diff --git a/target/linux/ath79/image/common-tp-link.mk b/target/linux/ath79/image/common-tp-link.mk
new file mode 100644 (file)
index 0000000..1dd5a28
--- /dev/null
@@ -0,0 +1,84 @@
+DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT TPLINK_HEADER_VERSION TPLINK_BOARD_NAME
+
+define rootfs_align
+$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs%,0x4,$(patsubst root.%,%,$(1))))))
+endef
+
+# combine kernel and rootfs into one image
+# mktplinkfw <type> <optional extra arguments to mktplinkfw binary>
+# <type> is "sysupgrade" or "factory"
+#
+# -a align the rootfs start on an <align> bytes boundary
+# -j add jffs2 end-of-filesystem markers
+# -s strip padding from end of the image
+# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
+define Build/mktplinkfw
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+               -m $(TPLINK_HEADER_VERSION) \
+               -k $(IMAGE_KERNEL) \
+               -r $@ \
+               -o $@.new \
+               -j -X 0x40000 \
+               -a $(call rootfs_align,$(FILESYSTEM)) \
+               $(wordlist 2,$(words $(1)),$(1)) \
+               $(if $(findstring sysupgrade,$(word 1,$(1))),-s) && mv $@.new $@ || rm -f $@
+endef
+
+# mktplinkfw-combined
+#
+# -c combined image
+define Build/mktplinkfw-combined
+       $(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) $(1) \
+               -m $(TPLINK_HEADER_VERSION) \
+               -k $@ \
+               -o $@.new \
+               -s -S \
+               -c
+       @mv $@.new $@
+endef
+
+define Device/tplink
+  TPLINK_HWREV := 0x1
+  TPLINK_HEADER_VERSION := 1
+  LOADER_TYPE := gz
+  KERNEL := kernel-bin | append-dtb | lzma
+  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | tplink-v1-header
+  IMAGES := sysupgrade.bin factory.bin
+  IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade | append-metadata
+  IMAGE/factory.bin := append-rootfs | mktplinkfw factory
+endef
+
+define Device/tplink-nolzma
+  $(Device/tplink)
+  LOADER_FLASH_OFFS := 0x22000
+  COMPILE := loader-$(1).gz
+  COMPILE/loader-$(1).gz := loader-okli-compile
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1)
+  KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | tplink-v1-header
+endef
+
+define Device/tplink-4m
+  $(Device/tplink-nolzma)
+  TPLINK_FLASHLAYOUT := 4M
+  IMAGE_SIZE := 3904k
+endef
+
+define Device/tplink-4mlzma
+  $(Device/tplink)
+  TPLINK_FLASHLAYOUT := 4Mlzma
+  IMAGE_SIZE := 3904k
+endef
+
+define Device/tplink-8m
+  $(Device/tplink-nolzma)
+  TPLINK_FLASHLAYOUT := 8M
+  IMAGE_SIZE := 7936k
+endef
+
+define Device/tplink-8mlzma
+$(Device/tplink)
+  TPLINK_FLASHLAYOUT := 8Mlzma
+  IMAGE_SIZE := 7936k
+endef
index 8a0388a7ffd257f57774aa1ba2273b4c33bf6cb4..0b4659abeabcc0e2dda746c35df7a2d64474e32b 100644 (file)
@@ -1,82 +1,5 @@
-DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT TPLINK_HEADER_VERSION TPLINK_BOARD_NAME
+include ./common-tp-link.mk
 
-define rootfs_align
-$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs%,0x4,$(patsubst root.%,%,$(1))))))
-endef
-
-# combine kernel and rootfs into one image
-# mktplinkfw <type> <optional extra arguments to mktplinkfw binary>
-# <type> is "sysupgrade" or "factory"
-#
-# -a align the rootfs start on an <align> bytes boundary
-# -j add jffs2 end-of-filesystem markers
-# -s strip padding from end of the image
-# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
-define Build/mktplinkfw
-       -$(STAGING_DIR_HOST)/bin/mktplinkfw \
-               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
-               -m $(TPLINK_HEADER_VERSION) \
-               -k $(IMAGE_KERNEL) \
-               -r $@ \
-               -o $@.new \
-               -j -X 0x40000 \
-               -a $(call rootfs_align,$(FILESYSTEM)) \
-               $(wordlist 2,$(words $(1)),$(1)) \
-               $(if $(findstring sysupgrade,$(word 1,$(1))),-s) && mv $@.new $@ || rm -f $@
-endef
-
-# mktplinkfw-combined
-#
-# -c combined image
-define Build/mktplinkfw-combined
-       $(STAGING_DIR_HOST)/bin/mktplinkfw \
-               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) $(1) \
-               -m $(TPLINK_HEADER_VERSION) \
-               -k $@ \
-               -o $@.new \
-               -s -S \
-               -c
-       @mv $@.new $@
-endef
-
-
-define Device/tplink
-  TPLINK_HWREV := 0x1
-  TPLINK_HEADER_VERSION := 1
-  LOADER_TYPE := gz
-  KERNEL := kernel-bin | append-dtb | lzma
-  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | tplink-v1-header
-  IMAGES := sysupgrade.bin factory.bin
-  IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade | append-metadata
-  IMAGE/factory.bin := append-rootfs | mktplinkfw factory
-endef
-
-define Device/tplink-nolzma
-  $(Device/tplink)
-  LOADER_FLASH_OFFS := 0x22000
-  COMPILE := loader-$(1).gz
-  COMPILE/loader-$(1).gz := loader-okli-compile
-  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1)
-  KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | tplink-v1-header
-endef
-
-define Device/tplink-4m
-  $(Device/tplink-nolzma)
-  TPLINK_FLASHLAYOUT := 4M
-  IMAGE_SIZE := 3904k
-endef
-
-define Device/tplink-8m
-  $(Device/tplink-nolzma)
-  TPLINK_FLASHLAYOUT := 8M
-  IMAGE_SIZE := 7936k
-endef
-
-define Device/tplink-8mlzma
-$(Device/tplink)
-  TPLINK_FLASHLAYOUT := 8Mlzma
-  IMAGE_SIZE := 7936k
-endef
 
 define Device/tl-wr1043nd-v1
   $(Device/tplink-8m)
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
new file mode 100644 (file)
index 0000000..cb5a67f
--- /dev/null
@@ -0,0 +1,2 @@
+include ./common-tp-link.mk
+
diff --git a/target/linux/ath79/tiny/config-default b/target/linux/ath79/tiny/config-default
new file mode 100644 (file)
index 0000000..01af544
--- /dev/null
@@ -0,0 +1,14 @@
+CONFIG_BLK_MQ_PCI=y
+CONFIG_LEDS_RESET=y
+CONFIG_OF_ADDRESS_PCI=y
+CONFIG_OF_PCI=y
+CONFIG_OF_PCI_IRQ=y
+CONFIG_PCI=y
+CONFIG_PCI_AR71XX=y
+CONFIG_PCI_AR724X=y
+CONFIG_PCI_DISABLE_COMMON_QUIRKS=y
+CONFIG_PCI_DOMAINS=y
+CONFIG_PHY_AR7100_USB=y
+CONFIG_PHY_AR7200_USB=y
+CONFIG_REGULATOR=y
+CONFIG_REGULATOR_FIXED_VOLTAGE=y
diff --git a/target/linux/ath79/tiny/profiles/00-default.mk b/target/linux/ath79/tiny/profiles/00-default.mk
new file mode 100644 (file)
index 0000000..aa8e119
--- /dev/null
@@ -0,0 +1,9 @@
+define Profile/Default
+       NAME:=Default Profile (all drivers)
+       PRIORITY := 1
+endef
+
+define Profile/Default/Description
+       Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/tiny/target.mk b/target/linux/ath79/tiny/target.mk
new file mode 100644 (file)
index 0000000..87af3ef
--- /dev/null
@@ -0,0 +1,6 @@
+BOARDNAME:=Devices with small flash
+FEATURES += squashfs small_flash
+
+define Target/Description
+       Build firmware images for Atheros AR71xx/AR913x/AR934x based boards with small flash
+endef