ramips: enable second SPI for VoCore
authorJohn Crispin <john@openwrt.org>
Mon, 25 Aug 2014 06:35:46 +0000 (06:35 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 25 Aug 2014 06:35:46 +0000 (06:35 +0000)
This patch enables the second SPI as spidev and also fixes some typos.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 42277

target/linux/ramips/dts/VOCORE.dts
target/linux/ramips/rt305x/profiles/vocore.mk

index e5df9abb42c72a3632314b06ad9beb1c6ca11cf1..e6288b03b8d17ca7f80c45fedfaaf08cea560f9d 100644 (file)
                                #address-cells = <1>;
                                #size-cells = <1>;
                                compatible = "s25fl064k";
-                               reg = <0 0>;
+                               reg = <0>;
                                linux,modalias = "m25p80", "s25fl064k";
                                spi-max-frequency = <10000000>;
 
                                partition@0 {
                                        label = "uboot";
                                        reg = <0x0 0x30000>;
-                                       read_only;
+                                       read-only;
                                };
 
                                partition@30000 {
                                        reg = <0x50000 0x7b0000>;
                                };
                        };
+
+                       spidev@1 {
+                               compatible = "linux,spidev";
+                               spi-max-frequency = <10000000>;
+                               reg = <1>;
+                       };
                };
        };
 
        pinctrl {
                state_default: pinctrl0 {
                        gpio {
-                               ralink,group = "jtag", "uartf", "led", "spi_cs1";
+                               ralink,group = "jtag", "uartf", "led";
                                ralink,function = "gpio";
                        };
                };
                        gpio-export,direction_may_change = <1>;
                        gpios = <&gpio1 4 0>;
                };
-
-               /* SPI_CS1 */
-               gpio27 {
-                       gpio-export,name = "gpio27";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio1 5 0>;
-               };
        };
 
        gpio-leds {
index 11fb634bebdf84c7e40458ddc2c5adee2789fc6c..92f3ce58ed980648d0970d3350fab42cf9196838 100644 (file)
@@ -9,7 +9,8 @@ define Profile/VOCORE
        NAME:=VoCore
        PACKAGES:=\
                kmod-usb-core kmod-usb-ohci kmod-usb2 \
-               kmod-i2c-core kmod-i2c-ralink
+               kmod-i2c-core kmod-i2c-ralink \
+               kmod-spi-dev
 endef
 
 define Profile/VOCORE/Description