ramips: add support for ZBT-WE1326
authorJiawei Wang <buaawjw@gmail.com>
Thu, 20 Apr 2017 03:07:26 +0000 (11:07 +0800)
committerMathias Kresin <dev@kresin.me>
Tue, 25 Apr 2017 17:29:59 +0000 (19:29 +0200)
Specification:
- SoC: MT7621AT, MT7603EN and MT7612EN
- Flash: 16 MiB (W25Q128FVSG)
- RAM: 512 MiB (EM6GE16EWXD-12H)
- Ethernet: 1 x WAN (10/100/1000Mbps) and 4 x LAN (10/100/1000 Mbps)
- Others: USB 2.0, micro SD slot, reset button and 8 x LEDs

Issues:
- Two LEDs for 2.4 GHz and 5 GHz Wi-Fi do not work, can't find GPIOs.
- The pwr LED is not GPIO controllable

How to install:
- The original firmware is OpenWrt, so both LuCI or sysupgrade can be used.
- Do not keep settings, for sysupgrade please use the -n option.

Signed-off-by: Jiawei Wang <buaawjw@gmail.com>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/ZBT-WE1326.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

index ecfa8a66e68aa8fe515c3419c1669d1b225afef1..1abe13991f8af757194c323b116b8d1fe33aa033 100755 (executable)
@@ -112,6 +112,7 @@ ramips_setup_interfaces()
        y1|\
        youku-yk1|\
        zbt-ape522ii|\
+       zbt-we1326|\
        zbt-we826|\
        zbt-wg2626|\
        zbt-wg3526|\
index eec961284acdb6f46e2cb3429deb619212130ec8..61f8a70719619e9e628b000deecb3b8bbdb41c77 100755 (executable)
@@ -649,6 +649,9 @@ ramips_board_detect() {
        *"ZBT-WA05")
                name="zbt-wa05"
                ;;
+       *"ZBT-WE1326")
+               name="zbt-we1326"
+               ;;
        *"ZBT-WE2026")
                name="zbt-we2026"
                ;;
index 036e19afe35f681e96ea7ed59a398805edf92f69..ae5a07b0b488389d57961b31631befa883575f57 100755 (executable)
@@ -192,6 +192,7 @@ platform_check_image() {
        zbt-ape522ii|\
        zbt-cpe102|\
        zbt-wa05|\
+       zbt-we1326|\
        zbt-we2026|\
        zbt-we826|\
        zbt-wg2626|\
diff --git a/target/linux/ramips/dts/ZBT-WE1326.dts b/target/linux/ramips/dts/ZBT-WE1326.dts
new file mode 100644 (file)
index 0000000..0dc2c77
--- /dev/null
@@ -0,0 +1,107 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "ZBT-WE1326";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x1c000000>, <0x20000000 0x4000000>;
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "wdt";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+               m25p,chunked-io = <32>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0xfb0000>;
+               };
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe000>;
+};
+
+&pcie {
+       status = "okay";
+
+       pcie0 {
+               mt76@0,0 {
+                       reg = <0x0000 0 0 0 0>;
+                       device_type = "pci";
+                       mediatek,mtd-eeprom = <&factory 0x8000>;
+                       ieee80211-freq-limit = <5000000 6000000>;
+               };
+       };
+
+       pcie1 {
+               mt76@1,0 {
+                       reg = <0x0000 0 0 0 0>;
+                       device_type = "pci";
+                       mediatek,mtd-eeprom = <&factory 0x0000>;
+                       ieee80211-freq-limit = <2400000 2500000>;
+               };
+       };
+};
+
+&sdhci {
+       status = "okay";
+};
index feda0f12f7974ec1b7b3c866940cdbf5bf4ed2ed..0e418fe47e696c04e531c313eac0c0030d70d5bf 100644 (file)
@@ -245,6 +245,14 @@ define Device/wsr-600
 endef
 TARGET_DEVICES += wsr-600
 
+define Device/zbt-we1326
+  DTS := ZBT-WE1326
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  DEVICE_TITLE := ZBT WE1326
+  DEVICE_PACKAGES := kmod-usb3 kmod-sdhci-mt7620
+endef
+TARGET_DEVICES += zbt-we1326
+
 define Device/zbt-wg2626
   DTS := ZBT-WG2626
   IMAGE_SIZE := $(ralink_default_fw_size_16M)