uboot-at91: fix build on buildbots
authorClaudiu Beznea <claudiu.beznea@microchip.com>
Wed, 13 Jul 2022 06:19:33 +0000 (09:19 +0300)
committerPetr Štetiar <ynezz@true.cz>
Wed, 13 Jul 2022 07:00:59 +0000 (09:00 +0200)
Buidbots are throwing the following compile error:

In file included from tools/aisimage.c:9:
include/image.h:1133:12: fatal error: openssl/evp.h: No such file or directory
            ^~~~~~~~~~~~~~~
compilation terminated.

Fix it by passing `UBOOT_MAKE_FLAGS` variable to make.

Suggested-by: Petr Štetiar <ynezz@true.cz>
Fixes: 6d5611af2813 ("uboot-at91: update to linux4sam-2022.04")
Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
package/boot/uboot-at91/Makefile

index 394cd7a42a0c8ea6b4b7111fb8562ab37aaf11ee..d75e3ba3aff9eee04c322dda72ed393296514405 100644 (file)
@@ -175,7 +175,8 @@ define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CROSS_COMPILE=$(TARGET_CROSS) \
                KCFLAGS="$(filter-out -fstack-protector \
-               -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft"
+               -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft" \
+               $(UBOOT_MAKE_FLAGS)
 endef
 
 $(eval $(call BuildPackage/U-Boot))