kernel: kmod-crypto-hw-talitos: fix dependencies
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 20 Dec 2017 19:46:21 +0000 (20:46 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 20 Dec 2017 19:57:13 +0000 (20:57 +0100)
With the updated to kernel 4.9.70 in commit f704b643b9cab ("kernel:
Update kernel 4.9 to 4.9.70"), the talitos.ko kernel module got a
new dependency to kmod-crypto-des in this upstream commit:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/commit/?id=552f74cbd6ec806ab5ce45336a26cae1e015dbe2

This fixes a build problem found by built bot.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/crypto.mk

index b05552006ade7cd7889d04dbfb3b16649d263d24..bc56b3cc12c4dafe4193a3c87f16ff6d07472108 100644 (file)
@@ -191,7 +191,7 @@ $(eval $(call KernelPackage,crypto-seqiv))
 
 define KernelPackage/crypto-hw-talitos
   TITLE:=Freescale integrated security engine (SEC) driver
-  DEPENDS:=+kmod-crypto-manager +kmod-crypto-hash +kmod-random-core +kmod-crypto-authenc
+  DEPENDS:=+kmod-crypto-manager +kmod-crypto-hash +kmod-random-core +kmod-crypto-authenc +kmod-crypto-des
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
        CONFIG_CRYPTO_DEV_TALITOS \