Revert "iptables: fix dependency for libip6tc on IPV6"
authorPetr Štetiar <ynezz@true.cz>
Fri, 9 Nov 2018 11:09:29 +0000 (12:09 +0100)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 10 Nov 2018 17:50:29 +0000 (18:50 +0100)
This patch reverts commit 2dc1f54b1205094e7c6036cae6275d2c326bad3e as it
breaks the build for me on x86-64 if I've IPV6 support disabled. Same config
builds fine on `openwrt-18.06` branch at 55d078b2.

  $ grep IPV6 .config

  # CONFIG_KERNEL_IPV6 is not set
  # CONFIG_IPV6 is not set

Build errors out on:

  Package libiptc is missing dependencies for the following libraries:
  libip6tc.so.0

Looking at iptables-1.6.2/libiptc/Makefile.am:

  libiptc_la_LIBADD   = libip4tc.la libip6tc.la

and to iptables-1.6.2/libiptc/libiptc.pc.in:

  Requires: libip4tc libip6tc

It seems that libiptc needs v4/v6 libs, so v6 isn't optional.

Cc: Rosy Song <rosysong@rosinson.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/network/utils/iptables/Makefile

index 2beaa7135e881d6fc892cbda146dfe8b180689d3..4c5a581268efd9513f86702558852007af78a1a8 100644 (file)
@@ -492,7 +492,7 @@ define Package/libiptc
 $(call Package/iptables/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libip4tc +IPV6:libip6tc +libxtables
+  DEPENDS:=+libip4tc +libip6tc +libxtables
   ABI_VERSION:=$(PKG_VERSION)
   TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
 endef
@@ -512,7 +512,7 @@ $(call Package/iptables/Default)
   CATEGORY:=Libraries
   TITLE:=IPv6 firewall - shared libiptc library
   ABI_VERSION:=$(PKG_VERSION)
-  DEPENDS:=@IPV6 +libxtables
+  DEPENDS:=+libxtables
 endef
 
 define Package/libxtables