kernel: Update kernel 4.19 to version 4.19.131
[openwrt/staging/stintel.git] / include / prereq-build.mk
index c6f99a20718bf9e4708c97b8b76c2c813b7eedfe..83dad0f2dc6e6bad1327f62f398d074d2a2eb0bf 100644 (file)
@@ -14,28 +14,23 @@ PKG_NAME:=Build dependency
 
 # Required for the toolchain
 $(eval $(call TestHostCommand,working-make, \
-       Please install GNU make v3.81 or later. (This version has bugs), \
-       $(MAKE) -v | grep -E 'Make (3\.8[1-9]|3\.9[0-9]|[4-9]\.)'))
+       Please install GNU make v3.82 or later. (This version has bugs), \
+       $(MAKE) -v | grep -E 'Make (3\.8[2-9]|3\.9[0-9]|[4-9]\.)'))
 
 $(eval $(call TestHostCommand,case-sensitive-fs, \
-       LEDE can only be built on a case-sensitive filesystem, \
+       OpenWrt can only be built on a case-sensitive filesystem, \
        rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
                test ! -f $(TMP_DIR)/test.FS))
 
 $(eval $(call TestHostCommand,proper-umask, \
        Please build with umask 022 - other values produce broken packages, \
-       umask | grep -xE 00[012][012]))
+       umask | grep -xE 0?0[012][012]))
 
 $(eval $(call SetupHostCommand,gcc, \
-       Please install the GNU C Compiler (gcc) 4.8 or later \
-       $(CC) -dumpversion | grep -E '(4\.[8-9]|5\.[0-9]|6\.[0-9]|7\.[0-9])', \
-       gcc -dumpversion | grep -E '(4\.[8-9]|5\.[0-9]|6\.[0-9]|7\.[0-9])', \
-       gcc48 --version | grep gcc, \
-       gcc49 --version | grep gcc, \
-       gcc5 --version | grep gcc, \
-       gcc6 --version | grep gcc, \
-       gcc7 --version | grep gcc, \
-       gcc --version | grep Apple.LLVM ))
+       Please install the GNU C Compiler (gcc) 4.8 or later, \
+       $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
        \nPlease reinstall the GNU C Compiler (4.8 or later) - \
@@ -44,15 +39,10 @@ $(eval $(call TestHostCommand,working-gcc, \
                gcc -x c -o $(TMP_DIR)/a.out -))
 
 $(eval $(call SetupHostCommand,g++, \
-       Please install the GNU C++ Compiler (g++) 4.8 or later \
-       $(CXX) -dumpversion | grep -E '(4\.[8-9]|5\.[0-9]|6\.[0-9]|7\.[0-9])', \
-       g++ -dumpversion | grep -E '(4\.[8-9]|5\.[0-9]|6\.[0-9]|7\.[0-9])', \
-       g++48 --version | grep g++, \
-       g++49 --version | grep g++, \
-       g++5 --version | grep g++, \
-       g++6 --version | grep g++, \
-       g++7 --version | grep g++, \
-       g++ --version | grep Apple.LLVM ))
+       Please install the GNU C++ Compiler (g++) 4.8 or later, \
+       $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \
        \nPlease reinstall the GNU C++ Compiler (4.8 or later) - \
@@ -61,10 +51,12 @@ $(eval $(call TestHostCommand,working-g++, \
                g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out))
 
+ifndef IB
 $(eval $(call TestHostCommand,ncurses, \
        Please install ncurses. (Missing libncurses.so or ncurses.h), \
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
                gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
+endif
 
 ifeq ($(HOST_OS),Linux)
   zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic
@@ -72,10 +64,9 @@ else
   zlib_link_flags := -lz
 endif
 
-$(eval $(call TestHostCommand,zlib, \
-       Please install a static zlib. (Missing libz.a or zlib.h), \
-       echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
-               gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - $(zlib_link_flags)))
+$(eval $(call TestHostCommand,perl-data-dumper, \
+       Please install the Perl Data::Dumper module, \
+       perl -MData::Dumper -e 1))
 
 $(eval $(call TestHostCommand,perl-thread-queue, \
        Please install the Perl Thread::Queue module, \
@@ -94,6 +85,11 @@ $(eval $(call SetupHostCommand,find,Please install GNU 'find', \
 $(eval $(call SetupHostCommand,bash,Please install GNU 'bash', \
        bash --version 2>&1 | grep GNU))
 
+$(eval $(call SetupHostCommand,xargs, \
+       Please install 'xargs' that supports '-r/--no-run-if-empty', \
+       gxargs -r --version, \
+       xargs -r --version))
+
 $(eval $(call SetupHostCommand,patch,Please install GNU 'patch', \
        gpatch --version 2>&1 | grep 'Free Software Foundation', \
        patch --version 2>&1 | grep 'Free Software Foundation'))
@@ -106,9 +102,9 @@ $(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
        gcp --help 2>&1 | grep 'Copy SOURCE', \
        cp --help 2>&1 | grep 'Copy SOURCE'))
 
-$(eval $(call SetupHostCommand,seq,, \
+$(eval $(call SetupHostCommand,seq,Please install seq, \
        gseq --version, \
-       seq --version))
+       seq --version 2>&1 | grep seq))
 
 $(eval $(call SetupHostCommand,awk,Please install GNU 'awk', \
        gawk --version 2>&1 | grep GNU, \
@@ -121,7 +117,6 @@ $(eval $(call SetupHostCommand,grep,Please install GNU 'grep', \
 $(eval $(call SetupHostCommand,getopt, \
        Please install an extended getopt version that supports --long, \
        gnugetopt -o t --long test -- --test | grep '^ *--test *--', \
-       /usr/local/bin/getopt -o t --long test -- --test | grep '^ *--test *--', \
        getopt -o t --long test -- --test | grep '^ *--test *--'))
 
 $(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
@@ -142,10 +137,21 @@ $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))
 
-$(eval $(call SetupHostCommand,python,Please install Python 2.x, \
-       python2.7 -V 2>&1 | grep Python, \
-       python2 -V 2>&1 | grep Python, \
-       python -V 2>&1 | grep Python))
+$(eval $(call CleanupPython2))
+
+$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+       python3.8 -V 2>&1 | grep 'Python 3', \
+       python3.7 -V 2>&1 | grep 'Python 3', \
+       python3.6 -V 2>&1 | grep 'Python 3', \
+       python3.5 -V 2>&1 | grep 'Python 3', \
+       python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+
+$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+       python3.8 -V 2>&1 | grep 'Python 3', \
+       python3.7 -V 2>&1 | grep 'Python 3', \
+       python3.6 -V 2>&1 | grep 'Python 3', \
+       python3.5 -V 2>&1 | grep 'Python 3', \
+       python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
        git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))