lantiq: fritz 7360 v2: rename device before it will be used
authorAlexander Couzens <lynxis@fe80.eu>
Mon, 18 May 2020 07:45:31 +0000 (09:45 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Mon, 18 May 2020 09:57:57 +0000 (11:57 +0200)
Use similiar naming scheme as ath79.
Since the fritz 7360 v2 was only in the tree for 2 days, there
is no compatibility for the old image.
Users which has installed the fritz 7360 v2 before this change, must
use sysupgrade --force to skip checks on the board.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Reviewed-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/lantiq/files-4.19/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360-v2.dts [new file with mode: 0644]
target/linux/lantiq/files-4.19/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts [deleted file]
target/linux/lantiq/files-5.4/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360-v2.dts [new file with mode: 0644]
target/linux/lantiq/files-5.4/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts [deleted file]
target/linux/lantiq/image/vr9.mk
target/linux/lantiq/xrx200/base-files/etc/board.d/02_network
target/linux/lantiq/xrx200/base-files/etc/hotplug.d/firmware/12-ath9k-eeprom

diff --git a/target/linux/lantiq/files-4.19/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360-v2.dts b/target/linux/lantiq/files-4.19/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360-v2.dts
new file mode 100644 (file)
index 0000000..9129ef1
--- /dev/null
@@ -0,0 +1,81 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "vr9_avm_fritz736x.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/mips/lantiq_rcu_gphy.h>
+
+/ {
+       compatible = "avm,fritz7360-v2", "avm,fritz736x", "lantiq,xway", "lantiq,vr9";
+       model = "AVM FRITZ!Box 7360 V2";
+};
+
+&power_green {
+       label = "fritz7360-v2:green:power";
+};
+
+&power_red {
+       label = "fritz7360-v2:red:power";
+};
+
+&info_green {
+       label = "fritz7360-v2:green:info";
+};
+
+&wifi {
+       label = "fritz7360-v2:green:wlan";
+};
+
+&info_red {
+       label = "fritz7360-v2:red:info";
+};
+
+&dect {
+       label = "fritz7360-v2:green:dect";
+};
+
+&state_default {
+       pcie-rst {
+               lantiq,pins = "io21";
+               lantiq,pull = <0>;
+               lantiq,output = <1>;
+       };
+};
+
+&localbus {
+       flash@0 {
+               compatible = "lantiq,nor";
+               bank-width = <2>;
+               reg = <0 0x0 0x2000000>;
+
+               partitions {
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+                       compatible = "fixed-partitions";
+
+                       urlader: partition@0 {
+                               label = "urlader";
+                               reg = <0x00000 0x20000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "firmware";
+                               reg = <0x20000 0x1f60000>;
+                       };
+
+                       partition@1f80000 {
+                               label = "tffs (1)";
+                               reg = <0x1f80000 0x40000>;
+                               read-only;
+                       };
+
+                       partition@1fc0000 {
+                               label = "tffs (2)";
+                               reg = <0x1fc0000 0x40000>;
+                               read-only;
+                       };
+               };
+       };
+};
diff --git a/target/linux/lantiq/files-4.19/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts b/target/linux/lantiq/files-4.19/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts
deleted file mode 100644 (file)
index 215a07e..0000000
+++ /dev/null
@@ -1,81 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include "vr9_avm_fritz736x.dtsi"
-
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/mips/lantiq_rcu_gphy.h>
-
-/ {
-       compatible = "avm,fritz7360v2", "avm,fritz736x", "lantiq,xway", "lantiq,vr9";
-       model = "AVM FRITZ!Box 7360 V2";
-};
-
-&power_green {
-       label = "fritz7360v2:green:power";
-};
-
-&power_red {
-       label = "fritz7360v2:red:power";
-};
-
-&info_green {
-       label = "fritz7360v2:green:info";
-};
-
-&wifi {
-       label = "fritz7360v2:green:wlan";
-};
-
-&info_red {
-       label = "fritz7360v2:red:info";
-};
-
-&dect {
-       label = "fritz7360v2:green:dect";
-};
-
-&state_default {
-       pcie-rst {
-               lantiq,pins = "io21";
-               lantiq,pull = <0>;
-               lantiq,output = <1>;
-       };
-};
-
-&localbus {
-       flash@0 {
-               compatible = "lantiq,nor";
-               bank-width = <2>;
-               reg = <0 0x0 0x2000000>;
-
-               partitions {
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-                       compatible = "fixed-partitions";
-
-                       urlader: partition@0 {
-                               label = "urlader";
-                               reg = <0x00000 0x20000>;
-                               read-only;
-                       };
-
-                       partition@20000 {
-                               label = "firmware";
-                               reg = <0x20000 0x1f60000>;
-                       };
-
-                       partition@1f80000 {
-                               label = "tffs (1)";
-                               reg = <0x1f80000 0x40000>;
-                               read-only;
-                       };
-
-                       partition@1fc0000 {
-                               label = "tffs (2)";
-                               reg = <0x1fc0000 0x40000>;
-                               read-only;
-                       };
-               };
-       };
-};
diff --git a/target/linux/lantiq/files-5.4/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360-v2.dts b/target/linux/lantiq/files-5.4/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360-v2.dts
new file mode 100644 (file)
index 0000000..9129ef1
--- /dev/null
@@ -0,0 +1,81 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "vr9_avm_fritz736x.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/mips/lantiq_rcu_gphy.h>
+
+/ {
+       compatible = "avm,fritz7360-v2", "avm,fritz736x", "lantiq,xway", "lantiq,vr9";
+       model = "AVM FRITZ!Box 7360 V2";
+};
+
+&power_green {
+       label = "fritz7360-v2:green:power";
+};
+
+&power_red {
+       label = "fritz7360-v2:red:power";
+};
+
+&info_green {
+       label = "fritz7360-v2:green:info";
+};
+
+&wifi {
+       label = "fritz7360-v2:green:wlan";
+};
+
+&info_red {
+       label = "fritz7360-v2:red:info";
+};
+
+&dect {
+       label = "fritz7360-v2:green:dect";
+};
+
+&state_default {
+       pcie-rst {
+               lantiq,pins = "io21";
+               lantiq,pull = <0>;
+               lantiq,output = <1>;
+       };
+};
+
+&localbus {
+       flash@0 {
+               compatible = "lantiq,nor";
+               bank-width = <2>;
+               reg = <0 0x0 0x2000000>;
+
+               partitions {
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+                       compatible = "fixed-partitions";
+
+                       urlader: partition@0 {
+                               label = "urlader";
+                               reg = <0x00000 0x20000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "firmware";
+                               reg = <0x20000 0x1f60000>;
+                       };
+
+                       partition@1f80000 {
+                               label = "tffs (1)";
+                               reg = <0x1f80000 0x40000>;
+                               read-only;
+                       };
+
+                       partition@1fc0000 {
+                               label = "tffs (2)";
+                               reg = <0x1fc0000 0x40000>;
+                               read-only;
+                       };
+               };
+       };
+};
diff --git a/target/linux/lantiq/files-5.4/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts b/target/linux/lantiq/files-5.4/arch/mips/boot/dts/lantiq/vr9_avm_fritz7360v2.dts
deleted file mode 100644 (file)
index 215a07e..0000000
+++ /dev/null
@@ -1,81 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include "vr9_avm_fritz736x.dtsi"
-
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/mips/lantiq_rcu_gphy.h>
-
-/ {
-       compatible = "avm,fritz7360v2", "avm,fritz736x", "lantiq,xway", "lantiq,vr9";
-       model = "AVM FRITZ!Box 7360 V2";
-};
-
-&power_green {
-       label = "fritz7360v2:green:power";
-};
-
-&power_red {
-       label = "fritz7360v2:red:power";
-};
-
-&info_green {
-       label = "fritz7360v2:green:info";
-};
-
-&wifi {
-       label = "fritz7360v2:green:wlan";
-};
-
-&info_red {
-       label = "fritz7360v2:red:info";
-};
-
-&dect {
-       label = "fritz7360v2:green:dect";
-};
-
-&state_default {
-       pcie-rst {
-               lantiq,pins = "io21";
-               lantiq,pull = <0>;
-               lantiq,output = <1>;
-       };
-};
-
-&localbus {
-       flash@0 {
-               compatible = "lantiq,nor";
-               bank-width = <2>;
-               reg = <0 0x0 0x2000000>;
-
-               partitions {
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-                       compatible = "fixed-partitions";
-
-                       urlader: partition@0 {
-                               label = "urlader";
-                               reg = <0x00000 0x20000>;
-                               read-only;
-                       };
-
-                       partition@20000 {
-                               label = "firmware";
-                               reg = <0x20000 0x1f60000>;
-                       };
-
-                       partition@1f80000 {
-                               label = "tffs (1)";
-                               reg = <0x1f80000 0x40000>;
-                               read-only;
-                       };
-
-                       partition@1fc0000 {
-                               label = "tffs (2)";
-                               reg = <0x1fc0000 0x40000>;
-                               read-only;
-                       };
-               };
-       };
-};
index d59605a15879ce9fc31f5a46323b0944db94dfb8..39ce6f14b833bcc3c9f6b34967913e0517658a35 100644 (file)
@@ -127,7 +127,7 @@ define Device/avm_fritz7360sl
 endef
 TARGET_DEVICES += avm_fritz7360sl
 
-define Device/avm_fritz7360v2
+define Device/avm_fritz7360-v2
   $(Device/AVM)
   DEVICE_MODEL := FRITZ!Box 7360
   DEVICE_VARIANT := v2
@@ -135,7 +135,7 @@ define Device/avm_fritz7360v2
   DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic kmod-usb-dwc2
   SUPPORTED_DEVICES += FRITZ7360V2
 endef
-TARGET_DEVICES += avm_fritz7360v2
+TARGET_DEVICES += avm_fritz7360-v2
 
 define Device/avm_fritz7362sl
   $(Device/AVM)
index 790fae58c9396a32d8dc0c3d1914af1c96e06d19..53312882539fbd65c75d7df945d2a9aca5ce6861 100755 (executable)
@@ -39,7 +39,7 @@ lantiq_setup_interfaces()
        avm,fritz3370-rev2-hynix|\
        avm,fritz3370-rev2-micron|\
        avm,fritz7360sl|\
-       avm,fritz7360v2|\
+       avm,fritz7360-v2|\
        avm,fritz7362sl)
                ucidef_add_switch "switch0" \
                        "0:lan:3" "1:lan:4" "2:lan:2" "4:lan:1" "6t@eth0"
index 4b6d0bf13a72db4aaa2453fdb2f01d2f8ecad24b..75cc50a207b77dbb2e1a5dfb10662a6babd79b33 100644 (file)
@@ -17,7 +17,7 @@ case "$FIRMWARE" in
                                caldata_extract_reverse "urlader" 0x1541 0x440
                                ;;
                        avm,fritz7360sl|\
-                       avm,fritz7360v2)
+                       avm,fritz7360-v2)
                                caldata_extract "urlader" 0x985 0x1000
                                ;;
                        avm,fritz7412)