fix ARCH_SUFFIX for mips64{,el}r2
authorGabor Juhos <juhosg@openwrt.org>
Wed, 20 Feb 2013 06:49:02 +0000 (06:49 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 20 Feb 2013 06:49:02 +0000 (06:49 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35688

rules.mk

index 53d4468dfc4bab6c1a3455e10e0281c70559b5bc..6455fde3f147108044bcf081ba374dd62267940a 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -60,7 +60,7 @@ ifneq ($(filter -march=armv%,$(TARGET_OPTIMIZATION)),)
   ARCH_SUFFIX:=_$(patsubst -march=arm%,%,$(filter -march=armv%,$(TARGET_OPTIMIZATION)))
   GCC_ARCH:=$(patsubst -march=%,%,$(filter -march=armv%,$(TARGET_OPTIMIZATION)))
 endif
-ifneq ($(findstring -mips32r2,$(TARGET_OPTIMIZATION)),)
+ifneq ($(filter -mips%r2,$(TARGET_OPTIMIZATION)),)
   ARCH_SUFFIX:=_r2
 endif
 ifdef CONFIG_HAS_SPE_FPU