libnftnl: Activate link time optimization (LTO)
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 1 Sep 2020 12:04:22 +0000 (14:04 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 6 Sep 2020 18:30:18 +0000 (20:30 +0200)
The ipk sizes for mips_24Kc change like this:
old:
libnftnl12_1.1.7-1_mips_24kc.ipk 47.459

new:
libnftnl12_1.1.7-2_mips_24kc.ipk 45.742

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/libs/libnftnl/Makefile

index 3d8d68ad5f15c31d33115f6d7a3fea151c9c609c..c56fb068ce941c1c7c777a1139eac243f13b1142 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnftnl
 PKG_VERSION:=1.1.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://netfilter.org/projects/$(PKG_NAME)/files
@@ -39,7 +39,8 @@ define Package/libnftnl/description
  programming interface (API) to the in-kernel nf_tables subsystem.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -flto
+TARGET_LDFLAGS += -flto
 
 CONFIGURE_ARGS += \
        --enable-static \