lantiq/xrx200: enable initramfs images
authorStijn Segers <foss@volatilesystems.org>
Sat, 27 Apr 2019 16:23:21 +0000 (18:23 +0200)
committerPetr Štetiar <ynezz@true.cz>
Wed, 15 May 2019 11:34:23 +0000 (13:34 +0200)
Commit eae6cac6a3 ("lantiq: add support for AVM FRITZ!Box 7362 SL"), but
one needs an initramfs image to flash OpenWrt from stock firmware (as
described in the commit log). This patch has the initramfs image built
by default.

Thanks to blogic (for pointing to the FEATURES declaration in the target
Makefiles) and Musashino on the forum for suggesting
config/Config-images.in needed editing too. While at it, reorder the
TARGET_INITRAMFS_COMPRESSION_LZMA declarations alphabetically.

This patch will result in initramfs images for all lantiq subtargets
that have the ramdisk flag set. I tested on the falcon and ase
subtargets, which lack that flag, to confirm they don't produce any
initramfs images with this patch - which they do not.

Given the limited scope of the lantiq (sub)target(s), blogic indicated
this should be OK.

Signed-off-by: Stijn Segers <foss@volatilesystems.org>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
[fixed the wrong reference to eae6cac6a3 commit]

config/Config-images.in
target/linux/lantiq/xrx200/target.mk

index 9daaf749158fa6e9e2c4f20f99081efa325817c9..8548c7cd24742daad4fb1c64e58bad82590795c2 100644 (file)
@@ -14,10 +14,11 @@ menu "Target Images"
 
                choice
                        prompt "Compression"
-                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ar71xx
-                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ramips
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_apm821xx
+                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ar71xx
+                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_lantiq
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_mpc85xx
+                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ramips
                        default TARGET_INITRAMFS_COMPRESSION_NONE
                        depends on TARGET_ROOTFS_INITRAMFS
                        help
index 4f682bf4866fed22184d5cb11b6e7ab3470990f9..4d92b25bcb8ccdf211ad036c4cfa583b92ae0dec 100644 (file)
@@ -1,7 +1,7 @@
 ARCH:=mips
 SUBTARGET:=xrx200
 BOARDNAME:=XRX200
-FEATURES:=squashfs atm nand
+FEATURES:=squashfs atm nand ramdisk
 CPU_TYPE:=24kc
 
 DEFAULT_PACKAGES+=kmod-leds-gpio \