don't run the image prereq check if the image directory does not exist
authorFelix Fietkau <nbd@openwrt.org>
Mon, 16 Jul 2007 00:42:19 +0000 (00:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 16 Jul 2007 00:42:19 +0000 (00:42 +0000)
SVN-Revision: 7988

target/Makefile

index a3b15b26592c8b4bc041ba11777b2fcceb4b18e2..4885ab98d3e3e97305359c2c5e6c819d7d38ed0a 100644 (file)
@@ -33,7 +33,7 @@ clean: linux-clean sdk-clean imagebuilder-clean image_clean
 
 prereq: FORCE
        $(MAKE) -C linux/$(BOARD)-$(KERNEL) prereq
-       $(MAKE) -C $(IMAGE_DIR) prereq
+       [ \! -f $(IMAGE_DIR)/Makefile ] || $(MAKE) -C $(IMAGE_DIR) prereq
 
 sdk_install: FORCE
        $(MAKE) -C sdk install