rules.mk: export TMPDIR
authorJo-Philipp Wich <jo@mein.io>
Tue, 12 Dec 2017 15:28:04 +0000 (16:28 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 12 Dec 2017 16:44:01 +0000 (17:44 +0100)
Set TMPDIR to the same value as the existing TMP_DIR variable in order to
let gcc and various other utilities use the local temporary directory
instead of the system-wide one.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
rules.mk

index ed796a54024adc4d4cbcb13d46a03bf6e0c1c8f5..3558f2f0284eb041820623b5fd1e0e02abee80c2 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -21,6 +21,7 @@ DUMP:=1
 endif
 
 export TMP_DIR:=$(TOPDIR)/tmp
+export TMPDIR:=$(TMP_DIR)
 
 qstrip=$(strip $(subst ",,$(1)))
 #"))