firmware-utils: fix nec-enc build on older architectures
authorChristian Lamparter <chunkeey@gmail.com>
Sat, 6 Apr 2019 18:29:35 +0000 (20:29 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 6 Apr 2019 18:29:35 +0000 (20:29 +0200)
This patch enable gnu99 mode for the nec-enc utility which
fixes the following build-breaking errors on some older
architectures.

nec-enc.c: In function ‘xor_data’:
nec-enc.c:34:2: error: ‘for’ loop initial declarations are only allowed in C99 or C11 mode
  for (int i = 0; i < len; i++) {
  ^~~
nec-enc.c:34:2: note: use option -std=c99, -std=gnu99, -std=c11 or -std=gnu11 to compile your code
nec-enc.c: In function ‘main’:
nec-enc.c:101:3: error: ‘for’ loop initial declarations are only allowed in C99 or C11 mode
   for (int i = 0; i < n; i++) {
   ^~~

Spotted-By: Buildbot
Fixes: fac27643f057 ("firmware-utils: add nec-enc")
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
tools/firmware-utils/Makefile

index 7745b7bab20ad3c9658794dfc68c17e0635ccfe2..76d5929af529ef0d993070c2062cc1956b728812 100644 (file)
@@ -85,7 +85,7 @@ define Host/Compile
        $(call cc,mkdlinkfw mkdlinkfw-lib, -lz -Wall --std=c99)
        $(call cc,dns313-header, -Wall)
        $(call cc,mksercommfw, -Wall)
-       $(call cc,nec-enc, -Wall)
+       $(call cc,nec-enc, -Wall --std=gnu99)
 endef
 
 define Host/Install