imagebuilder: Fix sorting package list breaks opkg dependency handling for provides
authorDaniel Dickinson <openwrt@daniel.thecshore.com>
Tue, 26 Apr 2016 08:50:27 +0000 (04:50 -0400)
committerJo-Philipp Wich <jo@mein.io>
Wed, 18 May 2016 21:53:01 +0000 (23:53 +0200)
When imagebuild sorts package lists it breaks opkg's ability to realize
that a providers for a Provides has already been installed, when the sort
results in the provider being later in the list of packages that a package
which depends on a Provides (and hence the provider is not yet installed
for opkg to realize the provider was available doesn't not handle the case
of a package that is to be installed satisfying a dependency, only one that
is already installed (or which it schedules to be installed, which in the
absence of an installed provider is whichever provider happens to be the
default)

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
target/imagebuilder/files/Makefile

index e0dc0b9cea6debf65077eb451d3008dae8de8c43..c5f8bd7681e2cb2d0d499008cdfd055291f370f3 100644 (file)
@@ -104,7 +104,7 @@ _call_info: FORCE
        echo 'Available Profiles:'
        echo; $(PROFILE_LIST)
 
-BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(USER_PACKAGES) $($(USER_PROFILE)_PACKAGES) kernel)
+BUILD_PACKAGES:=$(USER_PACKAGES) $(sort $(DEFAULT_PACKAGES) $($(USER_PROFILE)_PACKAGES) kernel)
 # "-pkgname" in the package list means remove "pkgname" from the package list
 BUILD_PACKAGES:=$(filter-out $(filter -%,$(BUILD_PACKAGES)) $(patsubst -%,%,$(filter -%,$(BUILD_PACKAGES))),$(BUILD_PACKAGES))
 PACKAGES:=